Speech Recognition in Schools

Using NaturallySpeaking V 9

By Paul Nisbet, Allan Wilson & Fionna Balfour
Speech Recognition in Schools:
Using NaturallySpeaking Version 9

Paul Nisbet, Allan Wilson & Fionna Balfour
Introducing Speech Recognition in Schools: using Dragon *NaturallySpeaking*


ISBN 1 898042 28 0

Published by CALL Scotland, University of Edinburgh, Paterson's Land, Holyrood Road, Edinburgh EH8 8AQ.
© CALL Scotland, The University of Edinburgh and the Scottish Government.

British Library Cataloguing-in-Publication Data

A catalogue record for this book is available from the British Library

Copyright is acknowledged on all company and product names mentioned in this book.

Every effort has been taken to ensure the accuracy of information contained in this book, but readers are advised to check details with suppliers prior to purchase.

We are grateful to:

- the teachers and students who took part in our project and made comments and suggestions about this book;
- the Scottish Government, for funding the original project;
- staff in local authorities who supported the project;
- IANSYST and Words World Wide for technical support;
- IBM and Nuance, for permission to print extracts from the training scripts.

Thanks to Sheila Siwo and Murray Stewart for permission to use the photograph on the front cover.
Contents

CONTENTS ..................................................................................................................... iii

FOREWORD .................................................................................................................. 1

ABOUT THE PACK ...................................................................................................... 3
  Feedback on the Pack ................................................................................................. 4

HOW TO USE THE PACK ........................................................................................... 5
  How long does it take to do the training? ................................................................. 6
  Which students might benefit from using speech recognition? .......................... 7
    Word processing and IT skills .............................................................................. 8
    Motivation ............................................................................................................. 8
    Perseverance and ability to work independently ............................................... 8
    Oral communication ............................................................................................ 9
    Reading and literacy skills .................................................................................. 9
  What support is needed? .......................................................................................... 10
  What do students use speech recognition for? ....................................................... 12
  Can young children use speech recognition? ........................................................ 12
  What happens if a student’s voice changes? ........................................................... 13
  Can the program understand strong local accents? .............................................. 13
  Will using speech recognition make students lazy and less able to write or type? 13
  Which speech recognition program is best? ......................................................... 14
    Windows ............................................................................................................... 14
    MacOS .................................................................................................................. 15
  Where should I buy a speech recognition program? .............................................. 15
  What sort of computer is needed? ......................................................................... 15
  Can the program work on a networked computer? .............................................. 16
  Microphones and Soundcards ............................................................................... 16
  Do you REALLY want to do this? .......................................................................... 17

TEACHER’S TUTORIAL ............................................................................................... 19

TEACHER’S TUTORIAL ............................................................................................... 21
  You will need: .......................................................................................................... 21
  In this tutorial you will learn how to: ...................................................................... 21
    Install the program .............................................................................................. 22
    Get started .......................................................................................................... 22
    Train Dragon NaturallySpeaking ....................................................................... 24
    Set up user options ............................................................................................ 25
    Open Dragon Pad .............................................................................................. 26
    Dictate some text ............................................................................................... 26
    Correct errors with PlayBack and Computer Speech ....................................... 27
    Voice commands ............................................................................................... 28
    Add new words to the dictionary ..................................................................... 29
    Try an example .................................................................................................. 31
    Check accuracy .................................................................................................. 31
    Finish ................................................................................................................ 31
  After the training session and before the first session with the student you should: 32

STUDENT SESSIONS ............................................................................................... 33

SESSION 1 TRAIN THE PROGRAM ............................................................................ 35
  In Session 1 the student will learn to: .................................................................... 35
    Before the student arrives: .................................................................................. 35
SESSION 4

CALL Scotland
Introducing Speech Recognition in Schools

Add a new word to the dictionary
Use voice to Playback and Read Back
Use voice to move around the document
Format text with voice

In Session
If you have time …
Recap

In Session 4 the student will learn to:

Recap

‘Scratch That’
Force dictation or commands

If you have time
Finish

SESSION 2 DICTATE AND CORRECT ................................................. 45

In Session 2 the student will learn to:

Review .......................................................... 45
Start NaturallySpeaking ........................................ 45
Set up the NaturallySpeaking Options .................. 46
Set up font and size and save it as a blank page ... 46
Turn the Microphone on and off ......................... 47
Dictate Words and Phrases ................................ 47
Use Playback to listen to what was said ............... 49
Correct errors .................................................. 49
Practise dictation ............................................ 50
Recap .......................................................... 50
If you have time ............................................. 51
Finish ........................................................ 51

SESSION 3 VOICE COMMANDS ...................................................... 53

In Session 3 the student will learn to:

Review .......................................................... 53
Get Started .................................................... 53
Dictate and correct errors ................................. 53
Voice commands ............................................. 55
Force dictation or commands ............................ 55
‘Scratch That’ .................................................. 56
Recap .......................................................... 56
If you have time ............................................. 56
Finish ........................................................ 56

SESSION 4 USE ‘READ THAT’ TO READ BACK DICTATED TEXT .......... 57

In Session 4 the student will learn to:

Review .......................................................... 57
Dictate and correct ......................................... 57
Use computer speech for proof-reading ............... 58
Back up voice files ........................................... 59
Dictate dialogue .............................................. 59
Recap .......................................................... 60
If you have time ............................................. 60
Finish ........................................................ 60

SESSION 5 VOICE COMMANDS, COMPOSING AND DICTATING TEXT .......... 61

In Session 5 the student will learn to:

Review .......................................................... 61
Get started ..................................................... 61
Format text with voice .................................... 61
Plan, compose, dictate and correct text ............... 62
Use voice to move around the document ............. 63
Use voice to Playback and Read Back ................. 63
Use voice to control the mouse and programs ...... 63
Add a new word to the dictionary ....................... 64
SESSION 6 READING AND DICTATING ........................................... 67
In Session 6 the student will learn to: ........................................... 67
Review .......................................................... 67
Get started .................................................. 67
Use text to speech to read and then dictate answers .......... 67
More dictation ........................................... 68
Finish .................................................. 69
SESSION 7 BUILDING THE VOCABULARY .................................. 71
In Session 7 the student will learn to: ........................................... 71
Review .......................................................... 71
Get started .................................................. 71
Analyse documents ............................................... 71
Comprehension activity - use speech output to read questions, and then dictate the answers .................. 73
Recap .................................................. 75
If you have time ........................................... 75
Finish .................................................. 75
SESSION 8 DICTATE A REPORT ................................................. 76
In Session 8 the student will learn to: ........................................... 76
Review .......................................................... 76
Get started .................................................. 76
The Road Accident ........................................... 76
Read and dictate text ........................................... 78
Correct errors by voice ........................................... 78
More comprehension practice ........................................... 78
Prepare for Session 9 ........................................... 79
Finish .................................................. 80
SESSION 9 DICTATE SCHOOL WORK ................................. 81
In Session 9 the student will learn to: ........................................... 81
Review .......................................................... 81
Get started .................................................. 81
Dictating numbers ............................................... 81
Preparation for dictating an exercise .................. 82
Activity .................................................. 82
Prepare another activity for Session 10 .................... 82
Finish .................................................. 82
SESSION 10 PLAN USING SPEECH RECOGNITION FOR SCHOOL WORK .......... 83
In Session 10 the student will: ........................................... 83
Review .......................................................... 83
Complete the exercise from Session 9 .................. 83
Or start another one ........................................... 83
Check accuracy ............................................... 83
Plan how you will use speech recognition from now on ........................................... 84
APPENDICES 85
APPENDIX 1 DICTATING DIRECTLY INTO OTHER APPLICATIONS ............... 87
Scanning worksheets into the computer .................. 87
Dictating into Email .......................................... 88
Dictating into other applications ...................................... 88
Dictate directly ........................................... 88
Copy and paste from DragonPad to the other application ...................................... 90
APPENDIX 2 TECHNICAL ISSUES ...................................................... 91
Introducing Speech Recognition in Schools
CALL Scotland

<table>
<thead>
<tr>
<th>Topic</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>Poor audio quality</td>
<td>91</td>
</tr>
<tr>
<td>Sound Recorder</td>
<td>91</td>
</tr>
<tr>
<td>Poor accuracy</td>
<td>92</td>
</tr>
<tr>
<td>Problems getting through training</td>
<td>93</td>
</tr>
<tr>
<td>Network issues</td>
<td>94</td>
</tr>
<tr>
<td>Transferring DNS 8 voice files between computers</td>
<td>94</td>
</tr>
</tbody>
</table>

**APPENDIX 3 RESOURCES AND SUPPLIERS** ........................................... 96

<table>
<thead>
<tr>
<th>Resource Type</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>Hardware and software</td>
<td>96</td>
</tr>
<tr>
<td>Suppliers</td>
<td>97</td>
</tr>
<tr>
<td>Web sites</td>
<td>99</td>
</tr>
<tr>
<td>Books, articles and papers</td>
<td>100</td>
</tr>
</tbody>
</table>
Foreword

This pack was first created in 2001 as pilot material for use in a project that the CALL Centre (now CALL Scotland) was running in a number of schools in Scotland to investigate the use of speech recognition to support pupils with writing difficulties. The initial material was produced for use with Dragon NaturallySpeaking Version 4 but they had to be updated to cover Version 5 of the program prior to the publication of the finished pack in May 2002.

The pack was produced as a book and CD that were distributed to Secondary schools in Scotland and made available to others who requested them. The book and resources could also be downloaded from the CALL Centre web site. These materials have consistently been among the most frequently downloaded resources on the web site, suggesting that they are still useful despite changes in the software. Nevertheless, we have received regular requests for the content to be updated to match later versions of NaturallySpeaking, which has now progressed to Version 9.

NaturallySpeaking has evolved considerably in the six years since the first edition of this pack was published in 2002. The quality of recognition has improved significantly so that most users will find that a very high percentage of what they dictate will be recognised accurately. However, we are still far from a situation where a conversation in a room can be instantly transcribed into text by a computer. It is possible to use the program without training it to your voice, though we would strongly recommend anyone planning to make serious use of the program to go through the training process in order to achieve a high level of accuracy. Unfortunately, training has not been made any easier and this still presents a significant barrier for many users.

The program has also improved in its handling of ‘young’ voices. When we tried the program with Primary school pupils six years ago, results were generally unintelligible. Recent results, albeit with a small number of P6/P7 pupils have been much better, though not as good as the accuracy levels we would expect with an adult voice. Nevertheless, the concentration levels required for successful use of speech recognition are such that we would generally advise against its use in Primary schools.
About the Pack

This Pack is designed to help teachers and parents teach young people with special educational needs to use the Dragon Naturally Speaking Preferred Version 9 speech recognition program.

Speech recognition has been presented as a ‘panacea’ for people with dyslexia and other writing difficulties. Some students have used speech recognition systems successfully for their work and for exams, and the use of this technology has helped them to overcome their difficulties and go on to higher education (see the references in Appendix 3). However, there have been other students in other schools, who have been unsuccessful in using speech recognition.

The aim of the CALL Introducing Speech Recognition in Schools project was to investigate best practice in schools where speech recognition was being used successfully, and develop and evaluate training materials to help other schools get going with speech recognition.

This Pack, which came out of the project is not intended to replace the Quick Start and User’s Guides that came with the program - which you should read. The pack is different from the product guides in that it gives you lessons and instructions for teaching students the skills needed to use speech recognition.

The Pack was evaluated by secondary schools in Scotland from November 2000 to March 2002, and modified in response to comments from staff and students. We chose to focus on Support for Learning Departments in secondary schools, rather than special schools or units, because the largest potential group of students in Scotland are those with specific learning difficulties in secondary education.

For each school, CALL provided:

• an initial on-site session to install the software, train staff and discuss which students might benefit from being involved in the project;
• the option of a second visit to support staff when starting work with students;
• the resource pack;
• one copy of either IBM NaturallySpeaking Millenium Pro 7, or Dragon NaturallySpeaking Preferred 4 or 5 (half the schools got ViaVoice, the other NaturallySpeaking);
• one high quality TalkMic or Plantronics microphone;
• support by telephone and email.

Each school identified:

• one PC capable of running the speech recognition program, in a suitable location (for example, a Learning Support base or other place which was readily accessible to students when they needed to use the system);
• a lead member of staff to co-ordinate the project;
• up to three students to participate in the project.

Following the first training session, the teacher(s) looked through the ten Training Sessions in the Pack and practised the exercises in each session to become confident with the system and the training. Once they had become familiar with the program and the training pack they had the option to contact CALL to arrange a second half-day training day. On this visit, we helped the staff go through the first Session with the student and attempted to resolve any problems or issues that had arisen with the program or its use in school. At the end of the project we asked staff and students to complete an evaluation form. Some of the comments and results from the evaluations are given here, and the full report is on the CD that accompanies the Pack.

Feedback on the Pack

We asked staff to rate the support provided by CALL, and the Training Pack.

The responses show that the Pack was well received, but that the initial training was just as important. If you are intending to introduce speech recognition in your school, you should try and obtain training from a supplier or a centre like CALL before you start.

The most common suggestion for improvements was for a pack that students could work through independently, because the training was staff intensive. We have responded to this by including Student Tutorial sheets in the CD that comes with the Pack, but these should be used with caution: you are unlikely to be successful unless you put time into learning how to use the program and working with the student.
How to use the Pack

1. Attend a training course on the topic, or ideally arrange in-service training on site in your school from a supplier or organisation like CALL (see Appendix 3).

2. Find a suitable computer in a suitable location (see *What sort of computer is needed?* later) and install the program.

3. Learn to use the program by working through the *Teacher’s Tutorial*.

4. Look through the ten Sessions so you don’t experience any surprises when you start work with a student.

5. Identify a small number of students (we suggest 3) to work with.

6. Purchase extra microphones (see *Microphones* below) so that each student has their own.

7. Set up a folder for each pupil on the speech recognition computer, and copy the contents of the *Dragon Training Files* folder from the *Introducing Speech Recognition* CD to the student's folder.

8. Obtain a loose-leaf folder for each student, to collect printouts of work.

9. Arrange a timetable for the training sessions, and for the student to have access to the computer for independent practice sessions.

10. Prepare the resources that you will need for the sessions. For example, you may want to look on the CD and:
   
   • print out *Student Tutorial* sheets for each session;
   
   • print and laminate the *Dragon Quick Guides* and stick them on the wall beside the computer;
   
   • print out the *Dragon Training Scripts* so the student can practise reading them before starting training.

11. Work through the sessions with the student.

12. At the end of the sessions review progress with the student. Discuss:
   
   • whether the student will use speech recognition for school work from now on;
   
   • for which subjects the student will use speech recognition;
   
   • where the student will work – learning support base, library, ICT suite, classrooms;
   
   • where / how the student will obtain printouts of work;
   
   • whether the student will use speech recognition for homework – if a laptop computer is used, can the student take it home; or is there a home computer that can be used (some students in the project commented that it was very helpful to be able to practise dictation at home);

13. If the student needs access to speech recognition in several locations around the school:
   
   • speak to the network or ICT coordinator or technician to discuss how the program can be made available on different computers. Remember you will need multiple licences to install it on several machines. Also note that the
program saves the user’s voice file on the desktop computer, not the server, so you will need to copy voice files between computers, or develop a separate voice file for each machine that the pupil uses. The Preferred edition of Naturally Speaking allows voice files to be imported and exported.

- use the more expensive Naturally Speaking Professional version, which can be used over a network.
- or buy laptop computers.

How long does it take to do the training?

The training comprises ten Sessions, and each Session will generally be completed in about 50 minutes. However, it depends on the skills and abilities of the student and staff – some students will get through the exercises very quickly, while others will take a long time. The training sessions could be timetabled once or twice per week, or once a day. Feedback from schools suggests that students also benefit from extra time themselves to consolidate their learning and practise dictation, so you should plan for this.

A few students found that they did not necessarily need to complete all 10 sessions – they did 8 or 9 and felt they were confident enough to start using speech recognition for school work.

Ideally, a member of staff should work one-to-one with a student, and the pack was originally written assuming this arrangement. Many of the teachers who evaluated the training pack reported they did not have time for one-to-one sessions with pupils, and asked if we could produce instructions so that the students could work through the training themselves. Therefore, the instructions for each session are in two forms: this Pack has the more detailed master instructions for the trainer, and there are also shorter Student Tutorial sheets on the Introducing Speech Recognition in Schools CD. You should not just copy the student tutorials, hand them to the student and leave them to get on with it – success is unlikely unless the student is a good reader, has considerable ICT skills, and is highly motivated!

If you do not have time to work on a one-to-one basis, you could train the student during small group teaching in a Support for Learning base. You would prepare the session and resources according to the instructions in the pack, start the student off, and leave them to work through the Student Tutorial, checking on progress every ten minutes or so.

Alternatively, train a teaching assistant or another member of staff who does have one-to-one time allocated with the student by working through the Teacher’s
Tutorial with them. Or, another student who already uses speech recognition may be able to tutor the novice student through the sessions.

The training should be done in a relatively quiet room - not so much because of the speech recognition, which will work with some background noise - but because you need peace to work with the student. The average classroom is not the best place to learn to use a speech recognition system (but once you have learned it, you can use it in the class). The microphones and software can filter out much background noise, but sudden, loud noises will be misrecognised as speech attempts, resulting in extra words appearing on screen. The distraction caused to the rest of the class by one person sitting dictating into a computer may be a bigger problem than background noise. The best place to practise in a school is usually a learning support base, or a quiet alcove within the library.

Once the training sessions are complete, and the student can use the system well (we hope!), it may be introduced and used in a subject classroom.

At the end of the ten sessions, the student should be able to use speech recognition effectively to complete learning tasks. After training, close supervision may not be necessary all the time, but support should be available, if required. This obviously has management and timetabling implications for the school.

**Which students might benefit from using speech recognition?**

A simple question to which there is no simple answer!

The best way to answer it is for you to work through the Teacher's Tutorial and learn to use the program yourself, then think about the students in your school and their skills, the difficulties they face, and then answer the question yourself.

Speech recognition can be useful for people with physical access difficulties (e.g. repetitive strain injury, arthritis, high spinal injury) that make writing difficult. It can also be effective for students with reading, writing or spelling difficulties (e.g. dyslexia) and for those with visual impairment. There are no ‘tests’ that can predict whether a student will succeed with speech recognition – the only way to find out is to try it - but experience and reports indicate that success is most likely with students with:

- good oral communication skills;
- word processing and IT skills;
- high motivation to learn to use the system.

The references in Appendix 3 list some research reports and case studies about speech recognition. The papers by Elaine Donald, Miles, Martin & Owen, Malcolm Litten, the BECTa reports and the *Supporting Writing with Speech Recognition* information sheet (on the *Introducing Speech Recognition in Schools* CD) give a lot of useful information.

Before starting work with the speech recognition program on the CALL project, we asked staff to score student skills, on a scale from ‘poor’ to ‘excellent’, with respect to an ‘average’ pupil. The chart below gives the average scores for the students,
with separate bars for those who did and did not intend to continue using speech recognition, having tried it. The small numbers involved mean that the scores are not statistically significant, but they do illustrate some useful points for discussion.

<table>
<thead>
<tr>
<th>Poor</th>
<th>Fair</th>
<th>Average</th>
<th>Good</th>
<th>Excellent</th>
</tr>
</thead>
<tbody>
<tr>
<td>WRITING</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>READING</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>SPELLING</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>ORAL SKILLS</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>OVERALL ACADEMIC ABILITY</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>PERSEVERANCE</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>ABILITY TO WORK INDEPENDENTLY</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>MOTIVATION TO WRITE</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>MOTIVATION TO USE SR</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>ICT SKILLS</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>SR SKILLS</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

Students who will continue to use SR
Students who won’t continue to use SR

**Average of student abilities, scored by staff**

(Based on scores for 17 pupils who intend to continue with speech recognition and 3 who do not)

**Word processing and IT skills**

The students had ‘average’ IT skills: clearly, it helps if students have some understanding of word processing, editing and file management before they start to use speech recognition (or any other ICT tool) for recording work.

**Motivation**

Motivation to use speech recognition tended to be ‘good’ or ‘excellent’, and there was little difference between successful and unsuccessful students: in fact, the latter were said to be more motivated. Learning to use speech recognition is hard work, and can be very frustrating, so you and the student need to be prepared to put in a lot of effort to get useful results.

**Perseverance and ability to work independently**

Staff chose students with whom to work with above-average perseverance and ability to work independently.
Oral communication

To use speech recognition, a student must be able to:

• think of what they want to say;
• compose their thoughts into written English sentences;
• speak reasonably clearly.

If a student has severe learning difficulties, and is not able to compose and speak clearly, speech recognition is unlikely to be successful. In our sample, those who were successful tended to have slightly better oral skills than those who were not successful. Several staff noted that students who were already skilled at using dictaphones found it easier to compose text before dictating to NaturallySpeaking.

Reading and literacy skills

All the students had reading, spelling and writing skills which were worse than average – hence their reason for evaluating speech recognition. Those who were successful had slightly better reading skills than those who were not. It is generally agreed that it helps if the student has some reading, or at least word recognition, skills. This is because the programs will always make mistakes, and so to write independently, the student must be able to spot the mistakes and correct them.

Having said that, students who are poor readers do use speech recognition successfully. NaturallySpeaking Preferred has a text-to-speech facility to read back the text that has been dictated; or a specialist speech output program like Keystone ScreenSpeaker or TextHelp can be used; or the writer can get help from staff or other students to proof read and correct errors. It may be harder for a poor reader to be successful with speech recognition than a good reader but poor readers may well be more motivated to persevere than other students because they have few alternatives.

Handwritten:

I really like the Dragon program. I think it will help me a lot. To do my work in classes. I would like to use it in all my subjects at the Academy. I was surprised because I did not think a computer could listen and learn so easily.

Scott, age 12, reading age 8 years 3 months

Dictated and then sent by email.....

“I really like the Dragon program. I think it will help me a lot. To do my work in the class/es. I would like to use it in all my subjects at the Academy. I was surprised because I did not think a computer could listen and learn so easily. I was very surprised when the words I was saying came up on the screen. I thought it was really excellent.”
What support is needed?

Results from the CALL and other projects shows that the success or otherwise of introducing speech recognition in schools depends as much on school and staff resources, as on the skills of the individual student:

The BECTa project suggests that success depends on the “Three T’s” – the right Technology, sufficient Time, and suitable Training. Time is a major factor in achieving success with speech recognition. We asked staff to record how often they worked with the student on speech recognition, and the table shows the results. It is clear that those students who say they will continue to use speech recognition had more frequent practice.

A simple interpretation is that if you practise once a week or more you are more than twice as likely to be successful, compared with practising less often. Of course, other factors will have an effect on success – for example, 3 of the 8 students who decided not to use speech recognition gave up after 4 or less sessions because they found accuracy was so poor. Nevertheless, there is no doubt that students will require regular practice to become successful with speech recognition. This may mean that the student’s (or staff member’s) timetable has to be altered while he or she is learning to use speech recognition, or that the student is given preferential access to a computer.

We asked staff involved in the CALL project to say whether the student intended to use speech recognition for school work – this seemed to us to be the best measure of ‘success’. Of the 32 evaluations that we received:

- 23 (72%) students intended to continue using speech recognition;
- 1 (3%) was not sure;
- 8 (25%) did not intend to continue.

The reasons given were:

Reasons for not continuing to use speech recognition:

- “Feeling that this project did not meet the pupil’s needs fully. Have investigated other software which has improved writing skills and motivation.” [Boy, S2, Dragon NaturallySpeaking 4, Pentium II, 64 MB]
- “The speech recognition was too unpredictable: sometimes good, sometimes poor. Her final session was in conditions more like what would normally happen and it did not work properly. However she now uses an HP Jornada for computer access and finds this beneficial.” [Girl, S4, muscular atrophy, using Dragon NaturallySpeaking 4, Pentium 4, 128 MB RAM]
- “Found it difficult and time consuming to produce accurate results. He preferred using his laptop. Pupil had difficulty speaking clearly and slowly enough for the system to give an accurate response. He got easily frustrated and often needed a break because of an illness and did not wish to continue with the training.” [Boy, S2, specific learning difficulties, using Dragon NaturallySpeaking 5]
One significant point is that 6 of the 8 said that having trialed speech recognition, they preferred to use a word processor or other program (such as a word predictor). This underlines the fact that speech recognition is just another writing tool, which suits some, but not all writers.

Other possible reasons for lack of success, apart from time, which we discussed earlier, are the technology (i.e. the program or the computer), and the skills of the student.

Six of the eight pupils who will not continue used NaturallySpeaking, which might suggest that it is less effective than ViaVoice. In fact, we do not believe this to be the case – the numbers are too small to be significant (8 students in 6 schools, 4 of which used NaturallySpeaking and 2 of which used ViaVoice).
What do students use speech recognition for?

We asked staff and students to say why they intended to continue using speech recognition, and for what subjects and learning tasks. The most common reasons to use speech recognition were: the speed at which text could be produced; the legibility and spelling accuracy; and independence. Students generally intended to use speech recognition for longer pieces of work in English or for projects and reports.

Some reasons to continue to use speech recognition:

- “Only way to produce work that can be read. Whenever extended writing is required.” [Boy, S2, dyslexic, using NaturallySpeaking 4]
- “To assist with redrafting long pieces of text - typing slow - spell check difficult. Use in mainly English.” [Boy, S5, dyslexic, using IBM ViaVoice]
- “Poor speller. Any extended writing but mainly for Standard Grade folio work.” [Boy, S2, dyslexic, using IBM ViaVoice]
- “Best way to produce work which can be read easily. As many [subjects] as possible where extended writing is required.” [Boy, S1, dyslexic, using NaturallySpeaking 5]
- “It is definitely the solution to his learning difficulties. English and subjects where there is extended writing requirements.” [Boy, S2, dyspraxic & very poor spelling, using IBM ViaVoice]
- “Will continue because it should speed up writing and increase independence from scribe.” [Boy, S3, spastic diplegia, poor handwriting, using IBM ViaVoice]
- “To facilitate speed of output: handwriting is slow, keyboarding faster, but not as fast as speech recognition. Initially to be used for extended pieces of writing in English.” [Boy, S2, dyspraxic, laboured handwriting and erratic spelling, using NaturallySpeaking 5, Celeron 600, 64 MB]

Can young children use speech recognition?

Speech recognition programs are designed for adult voices and so young children’s voices may be pitched too high to work well. Having said that, Rosemary Savison and Lindy Springett (Savison & Springett, 2002) reported children aged nine using the programs successfully. Recent versions of NaturallySpeaking work better than the ones used in the original project – we tried Version 9 with boys in the 10 – 12 age group with reasonable results. Since Version 9 can be used without having to complete the laborious training procedure, it is possible to get an idea of the likelihood of success quickly and easily.

Young children would probably find it easier to use SpeakQ (available from http://www.wordq.com) as it has an easier interface and includes a model based on a child’s voice. SpeakQ is available as a ‘30-day demo’ so it is possible to give it a good trial with a child before making the commitment to a purchase. Nevertheless, we would not generally recommend using speech recognition with young children due to the concentration and language skills required.
What happens if a student's voice changes?

Some students report that the accuracy of the programs dropped drastically if they had a cold, or if their voice changed – due to voice breaking, for example. In these cases, there is no option but to retrain the voice file again or to start again with a new one.

Can the program understand strong local accents?

Sometimes! It is designed for standard British English, and accents do not cause too many problems provided your speech is still clear and distinct. Local dialects are a different matter – if words are spoken in a quite different way to ‘standard’ English (e.g. ‘fit’ for ‘what’, ‘ken’ for ‘know’) then NaturallySpeaking will not recognise the words unless you correct and train them individually.

Will using speech recognition make students lazy and less able to write or type?

No – in fact, the opposite is often the case. In a ten-week trial of IBM Simply Speaking with eleven children (Miles, Martin & Owen 1998), the reading age of the pupils increased by an average of 13.4 months (British Ability Scales Reading Test) and the average spelling age by 6.1 months (Schonell test).

With this in mind, we asked staff to test reading and spelling before and after going through the CALL speech recognition training. We also asked staff to estimate how student’s skills had changed, and the chart below gives the scores averaged across all the students.
Mean changes in abilities reported by staff
(Based on 17 pupils who intend to continue with speech recognition and 6 who do not)

Most students who intend to continue with speech recognition were reported as having improved in all areas. The biggest changes were in skills and motivation to use speech recognition itself. There were also increases in writing, spelling and reading skills but staff did not report the dramatic improvements in reading and spelling recorded by Miles and his colleagues. Only four staff actually tested five students’ reading and spelling directly before and after the speech recognition training and the results were patchy: some students showed no change, while others showed huge improvement (e.g. 3.6 years Reading age improvement, over 4 months; 2 years Reading Age improvement over 10 weeks; 2 years Spelling age improvement over 4 months.) The project report on the CD gives full details of these scores.

Most of the students who did not find speech recognition useful reported no change or a slight improvement across the range of skills, although several had less motivation to use speech recognition, as would be expected.

Which speech recognition program is best?

Windows

At the time of the original project we generally recommended either IBM ViaVoice Pro, or Dragon NaturallySpeaking Preferred. We would no longer recommend
Introducing Speech Recognition in Schools

CALL Centre

INTRODUCTION

ViaVoice as it has not been updated for a number of years. There are two other options to consider: the Microsoft Speech Recognition built into the Windows XP and Vista operating systems and SpeakQ. The Microsoft option in Vista is particularly good, but the training is integrated into the tutorial and requires a high level of concentration. SpeakQ is based on the Microsoft speech recognition engine for Windows XP, but has a much easier interface, particularly for training, and is very suitable for young pupils. If a person is likely to become a sophisticated user of speech recognition, possibly moving on to use it at university, or in work, NaturallySpeaking is the best option.

The older Dragon Dictate (a ‘discrete’ program where you dictate one word at a time, with a pause between each word) is still available and may be appropriate for people who have speech difficulties, or those with learning difficulties who find it helpful to concentrate on speaking and correcting one word at a time.

MacOS

Two of the schools in the original project used IBM ViaVoice Millenium Pro USB on Apple Macs and found it effective. ViaVoice was the best program for the Mac at the time of the project in 2002, but it has not been updated for a number of years and does not work with modern Macs. iListen became the best option for Mac users, but it has now been replaced by MacSpeech Dictate, which only works on the latest Macs with Intel processors.

Where should I buy a speech recognition program?

We recommend you buy the software from a specialist such as iANSYST or Words Worldwide, as their expertise and after sales support are much better than mail order or high street retailers. See Appendix 3 for addresses.

What sort of computer is needed?

NaturallySpeaking Version 9 runs on a computer with:

- Processor: Intel® Pentium or equivalent running at 1 GHz. Performance will be significantly better on a faster machine.
- RAM: 1 GByte RAM (minimum).
- Sound card: Creative® Labs Sound Blaster® 16 or equivalent.
- Hard disc: 1 GByte of free hard disk space for a Custom Installation where you install only the program files and 1 set of speech files.
- CD: CD-ROM drive (8x or faster) required for installation.

The program will check that you have an adequate computer during the installation process and will not install if minimum requirements are not met.
**We asked the schools involved in the project to give details of the computers they used, and there was a very wide range, from 2 year old Celerons to a 6 month old Pentium 4. The processor or amount of RAM actually appeared to make no difference to the success or otherwise of the speech recognition: for example, one school reported great success (including being able to use the 'short' training on NaturallySpeaking) with a Celeron 300 and 64 MB of RAM – the bare minimum for running the version of the program provided. It is generally agreed, though, that your chances of a satisfactory experience with speech recognition are higher if you use a computer with a specification better than the minimum.

Can the program work on a networked computer?

Most schools, particularly secondaries, now have their computers set up as a network, with few, if any, remaining as standalone machines. This has the advantage that staff and pupils can access their work from any machine on the network, but can result in other difficulties, depending on how the network is set up and managed.

*NaturallySpeaking Preferred Version 9* is designed for use on a standalone machine or a laptop. It may be possible to install it on a network, but the procedure is very complicated, requires considerable technical knowledge and may give less than satisfactory results.

If you have to use the program in a networked environment we would strongly advise you to get *NaturallySpeaking Professional*. This includes a 'Roamer' facility which allows the program to be used over the network.

Microphones and Soundcards

Speech recognition requires a high quality sound input signal, which means a good quality microphone and soundcard in the computer. The microphone supplied with *NaturallySpeaking* is satisfactory, but at the time of the project we recommended the better TalkMic mics from iANSYST. These are high performance microphones and are also light, comfortable and stable to wear. It is very difficult to give hard and fast advice about microphones because the models change so often, and because some types seem to work better with some computers than others. For example, one school thought the TalkMics were too flimsy, bought bigger, chunkier headset microphones from a high street computer shop for £10 each, and found they were perfectly satisfactory. We have also had excellent results with microphones costing less than £5, though some low cost microphones can become uncomfortable if used for a long session. Our current recommendation is the Andrea NC-91 (£25 from iANSYST), which produces a good signal, is light, comfortable and stable.

There can also be a problem with how the sound signal is processed when it enters the computer, though this is less of an issue than it was in the past. Some computers have poor quality components handling sound input, others, particularly some laptops can have components tightly packed together so that the sound input can be affected by electrical interference. If a desktop computer has unsatisfactory sound input, it is possible to get a replacement soundcard, e.g. the Soundblaster
Audigy or another card that has performed well in tests with speech recognition. (Check the Nuance website, http://www.nuance.co.uk for details of these tests. We would advise against changing the soundcard, unless you have some technical expertise as it can be fiddly to install and installation can invalidate the warranty of the computer. The better option (and only realistic option in the case of a laptop is to get a USB pod, e.g. the Andrea USB sound adaptor, which processes the signal before it enters the computer.

**Do you REALLY want to do this?**

The CALL project, and the others we have listed in Appendix 3, have shown that successful introducing of speech recognition needs a lot of time, energy and commitment from teaching staff, management, parents and, especially, the student. It also requires access to a suitable computer.

If this cannot be provided, then it may be better to consider some of the alternatives, such as the use of a computer, word predictor, typing, or tape recorder.

Still interested? Then read on…..
Teacher’s Tutorial
Teacher's Tutorial

Work through this tutorial before you start training the student.

You will need:

- A reasonable knowledge of the Windows operating system
- To be able to use and adjust the basic multi-media functions of Windows – Sound Recorder, microphone and speaker volume settings
- A basic knowledge of word processing: creating, editing, printing, loading and saving files.

In this tutorial you will learn how to:

- Install the program on the computer
- Start the program
- Create a user voice file
- Adjust the microphone settings
- Train a voice file
- Set up the NaturallySpeaking Options
- Dictate, Playback and correct
- Use Speech Output for proof reading
- Use voice commands
- Add new words to the NaturallySpeaking dictionary
- Save and load documents
- Use NaturallySpeaking to complete a sample comprehension exercise
Install the program

Installation should not pose any difficulties if you are using a standalone machine or a laptop. If you have a laptop computer, power it from the mains while you install and train the program.

1. Read the section on Installing Dragon NaturallySpeaking in chapter 2 on p. 7 of the NaturallySpeaking 9 manual.
2. Put the CD into the drive, and run the setup program to install the program.
3. Install the Text to Speech and tutorial files.
4. Create a folder for ‘Speech Recognition’ in the ‘My Documents’ folder.
5. Copy the Dragon files from the CALL Introducing Speech Recognition in Schools web site to the Speech Recognition folder.

Get started

- Plug in the microphone, and load NaturallySpeaking
  
  Start > All Programs > Dragon NaturallySpeaking 9 > Dragon NaturallySpeaking 9

  Or double-click the icon on the desktop

- If you are the first person to use the program on that particular computer, follow the User Wizard instructions. You will be prompted to activate the program. Choose Activate Now and Activate Automatically following the on-screen instructions, otherwise after the fifth use the program will be disabled.

- The next thing you need to do is to create a user voice file.

  1. Enter the name of the user.
  2. Make sure the ‘UK English’ language is selected, unless you are of North American, Australian, Asian etc origin.
  3. Select the correct type of ‘Dictation source’ – either a mic plugged into the mic socket, or a USB type.
  4. We recommend that you don’t skip initial training, unless you are just doing a ‘quick trial’ of the program.
  5. Click Next.

- Put on the microphone and adjust it so it is about 2 cm away from your mouth, and slightly to one side. See p. 16 in the NaturallySpeaking manual.

- Click Next. NaturallySpeaking will now adjust the volume settings for the mic, and check the sound quality. If your computer has more than one sound system, you will be asked to choose the one you want to use.
Volume Check
1. Click on **Start Volume Check** and read the paragraph. (Note you don’t have to read the text shown – say anything as long as it is in your normal voice.)
2. When the computer has adjusted the volume it will beep.
3. If it does not beep, check that the mic is plugged in and adjusted correctly, or try another microphone. Then look at the trouble shooting section in Appendix 2.
4. Click Next.

Sound quality check:
1. Click on **Start Quality Check**, and read the text until the computer beeps. (Again, you can dictate any text here.)
2. If it does not beep, check the microphone and connections.
3. Provided the quality check is ‘passed’, click on **Finish** to carry on. It is worth repeating this step, making slight adjustments to the microphone to try to get a ‘score’ greater than 20.
4. If the quality is ‘unacceptable’, click on the **Play** button to hear a recording of what you said. This will give clues about possible problems, e.g. a ‘booming’ sound indicates the microphone is too close. Try the following to increase your score:
   - speaking slightly louder and more clearly;
   - moving the mic closer or further away;
   - a different mic.
Train Dragon NaturallySpeaking

Before you start, switch off any screen savers, plug the mains adapter in if you have a laptop, and switch off any power saver features.

1. Click the Demo button to hear how to speak.

2. Then Click Go and read the first two sentences.

You will need to read these without pausing on each screen but for the rest you can choose Pause if you need to.

Choose a text to read then click on OK.

The stories will take an average reader around 5 minutes to read.

Training tips

1. The text to be read is shown on screen, and as the program recognises the speech, the words change from black and to grey.

2. Read the first phrase or short sentence, and then wait for the text to turn grey before carrying on with the next phrase. Once you get into the swing of it, you can dictate more text without pausing.

3. Dictate a few words or a phrase at a time, rather than speaking individual words and pausing between each word.

4. If the program doesn’t seem to recognise anything, click Pause, and start again by reading the first few words. Make a conscious effort to speak clearly, and wait until the text turns grey before continuing.

5. When the student does the training you can click on Pause after each phrase or sentence, to stop recording, so the student can practise reading the next one. You can even pause to practise every word if necessary - but the training will take a long time if you do! Read the text to the user and have them practise it before clicking Go.
6. If the program does not pick up a particular word, repeat it. If the word is not recognised after a couple of tries, click on Skip. Try to avoid using Skip, if you can. You can press the Pause button at any time to stop, and read the next sentence. You can also dictate slowly - a few words at a time, or even one word at a time. If the computer gets stuck and doesn’t recognise a word even after repeating it a few times, click Skip.

7. Stop and have a rest at least three or four times during training to relax and have a sip of water.

Once you have finished reading the text the computer will analyse the recording and create the voice model. You will be asked if you wish to ‘Adapt NaturallySpeaking to your writing style’, by having it analyse your emails and documents. If you have such documents available on your computer, we would recommend that you do this.

- Dragon Tutorial
  Do the Dragon Tutorial if you have time, if not click Begin dictating, then Finish.

**Set up user options**

1. Once NaturallySpeaking has started up, click on the arrows at the top right hand corner of the NaturallySpeaking Toolbar.

2. You can now access the Playback and Correction ‘Extras’

3. Click on the Tools menu and choose Options.

4. Click on the Correction tab, and then tick Automatic Playback on correction.

5. Make sure that the “Correct” command is set to “bring up Spell dialogue box”

6. Click OK.
Open Dragon Pad

- Open Dragon Pad from the Tools menu.
- Select the font and size in Dragon Pad that you prefer.

Dictate some text

- Turn on the mic
  
  Press the + key on the numeric keypad or click the mic button at the top left of the Dragon toolbar. We recommend that you use the + key to control the microphone – it is easier to control than the mouse. If you are using a laptop, there may not be a numeric keypad so you may have to define another key for this purpose. Click on Tools, Options, Hotkeys, Microphone On/Off and then press the key you plan to use.

- Dictate a few sentences and basic punctuation. Remember that you have to dictate the punctuation by saying “full stop”, “comma”, etc.
  
  E.g. “My name is ……….”, “Today is …………”, “I am talking to this computer.”

- Learn that NaturallySpeaking can handle context and grammar
  
  Dictate “I can hear music. Here is a new way of writing. There were two teachers with their computers.”

- Turn off the mic
  
  Press the + key on the numeric pad.

Dictation Procedure

- Get comfortable, sit up straight, and breathe deeply so you can speak clearly.
- Make sure the mic is switched off.
- Compose (and if necessary practise) your sentence.
- Switch the mic on.
- Don’t mutter, sigh, sniff, say ‘ummm’, ‘er’ etc before you start the sentence – the computer will pick these up.
- Speak the phrase or sentence clearly, with a comma or full stop. Use a "dictating voice", speaking slightly more slowly and carefully than you would for conversation. Try to speak like a newscaster - you can speak with an accent, but you must be clear and distinct. Avoid running words together, or letting your voice tail off at the ends of words and sentences.
- There is often a delay with the first sentence you speak before the words appear on screen, so wait until they do before dictating the next sentence.
Introducing Speech Recognition in Schools

CALL Centre

Introducing Speech Recognition in Schools

Dragon NaturallySpeaking v.9

Teacher’s Tutorial

- Wait silently until the words appear on screen - don’t say ‘Ooh look it’s great/rubbish/what’s it doing now etc’ - it will pick this up.
- Switch the mic off and compose the next piece of dictation.
- Once accuracy improves, you can dictate a paragraph or two before stopping to correct mistakes, but at first you should correct each sentence as soon as it is dictated.

Correct errors with PlayBack and Computer Speech

- Use Playback to hear a recording of the dictated text:
  - Select a word or phrase and click the **Playback** button on the DragonBar.

- Use computer speech for proof-reading and correcting
  - The **Sound** menu has two choices for listening to your text.
    - **Play That Back** will read out the text in your own voice as dictated.
    - **Read That** will use computer speech. This is useful for proofreading the dictation.

  If you want to slow the speech down, go to **Tools** and **Options** then select **Text-to-speech** and adjust the settings as required.

- Correct the error
  1. Select the mis-recognised word or phrase.
  2. Click on the Correction button to bring up the Correction Box. You can also open the Correction Box by pressing ‘.’ on the numberpad.
  3. If the correct word or phrase is in the list, double-click it to select it.
  4. If you are not sure what your original word was, choose **Play That Back** to hear what you said.
  5. If the word or phrase is not in the Correction list, click on **Spell That** and type it in.
6. Now click on **Train** and record the way you say the word.

7. We suggest that the student trains the words when correcting them because this helps improve accuracy, and also helps the student concentrate on the text. After the ten sessions are completed, accuracy should be quite good and it is not necessary to train corrected words.

- Understand the difference between correction and text revision
  
  Always use the Correction Box to correct a mis-recognised word because this helps *NaturallySpeaking* improve your voice model. Do not just type over the text because that just changes the text - it does not teach *NaturallySpeaking* how you speak the words.

- Save the document
  
  Click **File > Save**.

**Voice commands**

- *NaturallySpeaking* can understand commands as well as text. When you say the commands below, run the words together – if you pause between each word *NaturallySpeaking* will probably type the words rather than carry out the command.

- If *NaturallySpeaking* types the words instead of performing the instruction, hold down the **CTRL** key while you say the command. Similarly, you can force it to type the words by holding down **SHIFT** while you speak.

- To practice using voice commands dictate the following:
  
  "Go-to-Top"
  "Set-Font-Bold, Set-Size-18"
  "Speech recognition training session"
  "Set-Font-Plain, Set-font-12"
  "Go-To-Bottom"
  "As well as dictating I can also tell the computer what to do [Exclamation Mark]"
  "Go-To-Sleep"

- Turn mic on and off
  
  - Say "**Go-To-Sleep**" to turn it off temporarily, and **"Wake Up"** to wake it up.
Delete phrase.

- If NaturallySpeaking gets it completely wrong, or if you suddenly splutter, cough or otherwise generate a lot of rubbish on screen, say "Scratch That" to delete it. Only use Scratch That when most of the phrase is wrong – if only a word or two needs corrected, use the Correction Box.

You can use your voice to correct errors.

- Say "Correct word" where word is the mis-recognised word. To choose a word from the correction list, say "Choose n", where n is the number in the list.

Use voice to select and edit text.

- Dictate "Select Speech recognition training session", then "Cap That" to capitalise each word. "Select tell" then "instruct" to replace the word tell with instruct.

To print and save the document, dictate:

  "Click File…Print….OK"
  "Click File…Save"

You can also control programs and the mouse. Dictate:

  "Start-WordPad" to open the WordPad.
  "Mouse-Up-10" to move the mouse up 10 units
  "Mouse click" to click.

Review the NaturallySpeaking commands in the Quick Reference Card, or by clicking Tools > Command Browser from the NaturallySpeaking menu.

Add new words to the dictionary

One word at a time…

- To add an individual word - from the Words menu, choose New then enter the word. If the word already exists you will be alerted to this in the toolbar.

OR

- Dictate a sentence with an unusual word or rare proper noun (e.g. Muggles, thermodynamics, haggises, Jamiroquai etc), and then correct and train it. Once you have recorded the word, dictate it again to make sure it has been learned. This new word has now been added to the dictionary. You can check words have been added by clicking on the Words menu and selecting View/Edit. In the Vocabulary Editor choose Display: Custom words only to view those words which you have added. Any that have been incorrectly added can be deleted here.

From a document…

If the document has been created in MicrosoftWord® or Corel WordPerfect® you can have the words directly analysed.
1. Click on **Tools> Accuracy Centre**

2. Click on **Add words from your documents to the vocabulary**

3. Click on **Find unknown words** and **Preview the list of unknown words**. You can also choose to have it adapt to your writing style if you wish but we would recommend you leave that just now.

4. Select folders or documents that you wish to have words added from then click on **Next**.

5. When analysing is complete click on **Next**.

6. You will then be prompted to check the words you want and uncheck those you do not want to be added. Click on **Next** when ready.

7. Words you have listed will now be available to Train. Click on **Go** and record your voice then click on **Done**.

8. Once all words have been trained you will be given a summary of the number of words found and the number added to your dictionary.

9. Click on **Finish**.

- **From a word list…**
  1. Create the text file with words on a single line and check spelling before saving as a .txt file. **Note:** it can only deal with text files with extension .txt

  2. From the **Words** menu choose **Import**.

  3. Tick both options then **Next**.
4. Choose Add File then locate and select the file(s).

5. Analysis will be carried out and if all is well you will see a tick beside the filename, if not you will be told the reason.

**Try an example**

- Open the **Haggis Questions** file from the *Dragon Training Files* on the CALL *Introducing Speech Recognition in Schools* CD.
  
  File > Open > select ‘Haggis Questions’

- Use Read That to read the text and questions
  
  Select the text to read, then click Sound > Read That.

  Move the cursor around by saying “Go-to-top”, “Move-down-1-line”, “Move-up-2-lines”, “Go-to-bottom”.

  Read a line by saying “Read-Line”.

  Read a paragraph by saying “Read-Paragraph”.

- Dictate and correct the answers.

- Print and save the file under a new name
  
  Say “File”....”Print”, then “File”....”Save as”

**Check accuracy**

- If you have time, start a new document, and then dictate five paragraphs from one of the texts printed at the end of Session 1. Use one that you did not use for training *NaturallySpeaking*. Don’t correct any errors.

- Select the errors and mark them (underline, or make them bold) so you will be able to count them easily. Copy and paste the text into Microsoft Word, or another program that can count words. Click on Tools > Word Count in Word to count the number of words. Count the errors and divide by the total number of words to get an accuracy score:

  \[
  \text{Accuracy} = \frac{\text{Number of words} - \text{Number of errors}}{\text{Number of words}}
  \]

- For example, if you have 10 errors in 300 words, this gives an accuracy of 96.6%.

- Don’t count unknown words, or proper names as errors if they are not in the dictionary; a short phrase with a couple of errors counts as one error; and so does a word split into two words.

- Repeat this exercise every so often to monitor accuracy.

**Finish**

- Close the program down by clicking *Naturally Speaking* > Exit. When the program asks you if you want to save changes to the speech file, say Yes (provided that you have been correcting mis-recognised words).
After the training session and before the first session with the student you should:

- Read the NaturallySpeaking Quick Reference Card.
- Go through the 10 Sessions and make sure you are able to use the features of NaturallySpeaking described in them.
- Set up a folder for each pupil on the speech recognition computer, and copy the Dragon Training Files from the Introducing Speech Recognition CD to the student's folder.
- Obtain a loose-leaf folder for each student, to collect printouts of work.
- Arrange a timetable for the training sessions, and for the student to have access to the computer for independent practice sessions.
- Prepare the resources that you will need for the sessions. For example, you may want to look on the CD and:
  - print out Student Tutorial sheets for each session;
  - print and laminate the Dragon Quick Guides and stick them on the wall beside the computer;
  - print out the Dragon Training Scripts so the student can practise reading them before starting training.
Student Sessions
Session 1  Train the program

In Session 1 the student will learn to:

- Connect and adjust the microphone
- Start up NaturallySpeaking and open his or her voice file
- Train NaturallySpeaking to recognise his or her voice

Before the student arrives:

- Decide on the training text you will use and have a paper copy of the text available (it’s given at the end of this session, and on the CALL Introducing Speech Recognition in Schools CD)
- Depending on the student, it may be a good idea to go through the training text on the paper copy, identifying any words that he / she finds difficult

Connect the microphone

Show the student how to plug the microphone in to the computer.

Start NaturallySpeaking

Ask the student to double click on the NaturallySpeaking icon on the desktop, or click Start > Programs > Dragon NaturallySpeaking9.

Demonstrate NaturallySpeaking

Demonstrate NaturallySpeaking to the student by dictating a short piece of text – say, 50 – 100 words – making any corrections that are necessary at the end of the passage. It’s usually best if this text has been practised beforehand, to reduce the likelihood of something going seriously wrong! Make sure that the font is big enough for the student to read easily.

Discuss the demonstration with the student, trying to find out what their first impressions are and whether they think it might help them. Make it clear that you are using the computer as a writing tool, not having a conversation with it. This is
an important point that is worth repeating at regular intervals. The aim of using the system is to produce a piece of written English, not a transcript of a conversation. NaturallySpeaking bases part of its recognition process on people speaking in grammatical sentences, not the broken phrases typical of conversational English.

Assuming the student sees the relevance of the system and is willing to give it a try, go through the steps involved in creating a new user file, verbally, before moving back to the computer.

Create a new user speech file

The first time NaturallySpeaking is used, it automatically asks for a speech file to be created. Thereafter, it will assume that the same person is always using the system until a new user is created.

1. Create a new user file for the student, by clicking on NaturallySpeaking > Open User.
2. Click New and then type in the name of the new user.
3. Make sure the ‘UK English’ language is selected, unless you are of North American, Australian, Asian etc origin.
4. Select the correct type of ‘Dictation source’ – either a mic plugged into the mic socket, or a USB type, etc.
5. You have the option to ‘Skip initial training of this user’ at this point. We would generally advise against this, but there may be times when this can be useful, e.g. if you are working with a small group of students with limited time and you want to give them all an idea of what speech recognition is all about. Stress that this is only to give them a quick taster and that proper training is necessary for good speech recognition.
6. Click Next.

Hint!

When speech models have been created for more than one person on a computer, it is vital that you only use your own speech model. If you use another person’s model, not only will the computer be less successful at recognising your speech, the other person’s model will be changed, making it more difficult for the computer to recognise them the next time they use the system.
Microphone and Audio Setup

Next, set up the microphone with the student. Consistent positioning of the microphone in relation to the user's mouth is vital for speech recognition. First position the headset so that it is comfortable and then adjust the microphone. The microphone should be placed a little to the side of the mouth, to reduce interference from “breathing noises”, and about a thumb’s width from the lips. This distance can be adjusted slightly, depending on the user’s voice level. A quiet speaker will need a smaller distance for best results, while a person with a loud voice may want to move the microphone further away. Most microphones for speech recognition are ‘unidirectional’, with the sound signal maximised from one direction. The better microphones feature “active noise cancellation”, to damp down noise coming from any other direction. It is important to make sure that the direction of the best signal (usually indicated by a white or red dot on the end of the microphone) is towards the user’s mouth.

Adjust the microphone volume

After adjusting the microphone position the student must read some text into the machine so that NaturallySpeaking can adjust the microphone volume. The text is shown below, but the user need not read those particular words - he or she can say anything provided it is spoken clearly and at a normal volume and speed.

### Adjust your volume

In this step the computer listens to the sound of your voice and adjusts the volume setting of the microphone. When the computer has finished adjusting the volume, it beeps to signal that the process is complete. If you reach the end of this text but have not heard a beep, start reading the text again from the beginning. You should only have to read for about ten to fifteen seconds.

1. Click on **Start Volume Check** and read the text shown.
2. When the computer has adjusted the volume it will beep.
3. Click **Next**.
4. If it does not beep, check that the mic is plugged in and adjusted correctly, or try another microphone.
Check audio quality

Next, the student must read in a paragraph and NaturallySpeaking will check the quality of the sound input. The Audio quality text is below but again, if the student has difficulty reading the text from screen, he or she can say anything provided it is clear and continuous.

Audio quality test

In this step the computer checks the audio input from your sound card. Having high quality audio input is very important for good speech recognition. Poor audio input will make it difficult or impossible for the program to recognise your speech accurately. When the computer has finished checking the audio quality, it beeps to signal that the text is complete. If you reach the end of this text but you have not heard a beep, start reading the text again from the beginning. You should only have to read for about fifteen seconds.

NaturallySpeaking will show the quality of the audio input - if it says the audio is poor quality, use the Play button to listen to a recording of the audio and experiment until you get a better signal. If the recording is very quiet, try moving the microphone closer; if it is loud and ‘boomy’, move the microphone further away. Do not carry on with NaturallySpeaking until you have sorted the audio quality out - you will be wasting your time.

1. Click on Start Quality Check, and read the text until the computer beeps.
2. If it does not beep, check the microphone and connections.
3. Provided the quality check is 'passed', carry on.
4. If the quality is ‘unacceptable’, try:
   • speaking slightly louder and more clearly;
   • moving the mic closer or further away;
   • a different mic;
   • if all else fails, try using the Sounds and Audio Devices control panel, accessed from the Windows Start Menu. You can use this to check that the right sound input has been selected and to test your sound system. For example, you might find that the internal microphone of a laptop has been selected as the current input device, rather than a headset microphone.
Train NaturallySpeaking to recognise the user’s voice

Train the program in the same room that it will be used, if possible - the systems can be sensitive to changes in background acoustics. It’s also a good idea to have a little background noise during the training, rather than “perfect silence”. Have a radio playing quietly, or a conversation going on across the room.

Before you start, switch off any screen savers, plug the mains adapter in if you have a laptop, and switch off any power saver features.

To create the voice model, the user must read out the text shown on the computer screen. The first two sentences are shown below – have the user practise both sentences before you click Go to begin.

Welcome to general training.
Training is about to begin.

1. Click on the Demo button to hear how to dictate.
2. Then click Go and read the two introductory sentences.
3. You can click Pause to stop and coach the student with the sentences if necessary.

Next, you will be offered a choice of stories to read, to train NaturallySpeaking.

Helping the student get through training

Many students will have difficulty reading the training texts. Also, you cannot stop halfway through, save the recording you have done, and come back the next day to carry on - you must complete the training in one sitting. You can click on Pause and go for a break provided you don't switch the computer off.

Before you start training, go over the text with the student and practise any difficult words or phrases. You may want to print out the text in a larger font, from the CALL Introducing Speech Recognition in Schools CD.

1. The text to be read is shown on screen for, and as the program recognises the speech, the words change from black to grey.
2. Read the first phrase or short sentence, and then wait for the text to turn grey before carrying on with the next phrase. Once the student gets into
the swing of it, they can dictate more text without pausing.

3. Say a few words or a phrase at a time, rather than speaking individual words and pausing between each word.

4. If the program doesn’t seem to recognise anything, click Pause, and start again by reading the first few words. Make a conscious effort to speak clearly, and wait until the text turns grey before continuing.

5. If the student has difficulty reading the text, click on Pause after each phrase or sentence, to stop recording, so the student can practise reading the next one. You can even pause to practise every word if necessary - but the training will take a long time if you do! Read the text to the user and have them practise it before clicking Go.

6. If the student gets stuck on a word, whisper it – the computer will not pick up your voice.

7. If the program does not pick up a particular word, the student should repeat it. If the word is not recognised after a couple of tries, click on Skip. Try to avoid using Skip, if you can. You can press the Pause button at any time to stop, and read the next sentence. You can also dictate slowly - a few words at a time, or even one word at a time. If the computer gets stuck and doesn’t recognise a word even after repeating it a few times, click Skip.

8. Stop and have a rest at least three or four times during training to relax and have a sip of water.

**Hint!**

Prolonged dictation can lead to a dry throat so it is a good idea to have a glass of water nearby and to take occasional sips. You should train the system with your normal voice, not a dry, croaky voice!

You could also try printing the text out with each sentence on a separate line, then ask the student to read from the paper rather than the screen. Use the Pause and Go buttons and prompt the student when to stop and start speaking. The student could use a piece of card to keep the place when reading from the paper.

Or, you could load the training text into the NaturallySpeaking window (or into another talking word processor, like Write:Outloud, or Microsoft Word with WordTalk. Arrange the word processor window beside the training window, and then use the computer speech to read the text before dictating it.

**Hint!**

If the student has significant reading difficulties, you might consider buying Keystone SpeechMaster. This program can read out the training text direct from the NaturallySpeaking screen using the computer’s speech. The student listens to the text, and then repeats it. Keystone can also read back text as it is dictated to help the user check the dictation, and can read the items in the Correction Window, to help the user correct errors. It also provides simpler training texts. See Appendix 3 for more information on Keystone.
When the training text has been completed, the computer will create a voice file for the student.

**Finish**

If you have time at the end of the session click on Help > Tutorial then Menu and have a look through some examples of how the program is used.

Take a few minutes to discuss how the session went.

Shut down NaturallySpeaking by clicking on NaturallySpeaking > Exit.
Talking to Your Computer training text

We’d like you to read aloud for a few minutes while the computer listens and learns how you speak. When you’ve finished reading, we’ll make some adjustments, and then you’ll be able to talk to your computer and see the words appear on your screen. In the meantime, we’d like to explain why talking to a computer is not the same as talking to a person and then give you a few tips about how to speak when dictating.

Understanding spoken language is something that people often take for granted. Most of us develop the ability to recognize speech when we're very young. We're already experts at speech recognition by the age of three or so.

When people first start using speech-recognition software, they might be surprised that the computer makes mistakes. Maybe unconsciously we compare the computer to another person. But the computer is not like a person. What the computer does when it listens to speech is different from what a person does.

The first challenge in speech recognition is to identify what is speech and what is just noise. People can filter out noise fairly easily, which lets us talk to each other almost anywhere. We have conversations in busy train stations, across the dance floor, and in crowded restaurants. It would be very dull if we had to sit in a quiet room every time we wanted to talk to each other!

Unlike people, computers need help separating speech sounds from other sounds. When you speak to a computer, you should be in a place without too much noise. Then, you must speak clearly into a microphone that has been placed in the right position. If you do this, the computer will hear you just fine, and not get confused by the other noises around you.

A second challenge is to recognize speech from more than one speaker. People do this very naturally. We have no problem chatting one moment with Aunt Grace, who has a high, thin voice, and the next moment with Cousin Paul, who has a voice like a foghorn. People easily adjust to the unique characteristics of every voice.
Speech-recognition software, on the other hand, works best when the computer has a chance to adjust to each new speaker. The process of teaching the computer to recognize your voice is called "training," and it’s what you’re doing right now.

The training process takes only a few minutes for most people. For a small percentage of speakers, extra training can significantly improve results. If, after you begin using the program, you find that the computer is making more mistakes than you expect, additional training may help.

Another challenge is how to distinguish between two or more phrases that sound alike. People use common sense and context—knowledge of the topic being talked about—to decide whether a speaker said "ice cream" or "I scream."

Speech-recognition programs don’t understand what words mean, so they can’t use common sense the way people do. Instead, they keep track of how frequently words occur by themselves and in the context of other words. This information helps the computer choose the most likely word or phrase from among several possibilities.

Finally, people sometimes mumble, slur their words, or leave words out altogether. They assume, usually correctly, that their listeners will be able to fill in the gaps. Unfortunately, computers won’t understand mumbled speech or missing words. They only understand what was actually spoken and don’t know enough to fill in the gaps by guessing what was meant.

To understand what it means to speak both clearly and naturally, listen to the way newscasters read the news. If you copy this style when you use Dragon NaturallySpeaking, the program should successfully recognize what you say.

One of the most effective ways to make speech recognition work better is to practice speaking clearly and evenly when you dictate. Try thinking about what you want to say before you start to speak. This will help you speak in longer, more natural phrases.
Speak at your normal pace without slowing down. When another person is having trouble understanding you, speaking more slowly usually helps. It doesn't help, however, to speak at an unnatural pace when you're talking to a computer. This is because the program listens for predictable sound patterns when matching sounds to words. If you speak in syllables, Dragon NaturallySpeaking is likely to transcribe each syllable as a separate word.

With a little practice, you will develop the habit of dictating in a clear, steady voice, and the computer will understand you better.

When you read this training text, Dragon NaturallySpeaking adapts to the pitch and volume of your voice. For this reason, when you dictate, you should continue to speak at the pitch and volume you are speaking with right now. If you shout or whisper when you dictate, Dragon NaturallySpeaking won't understand you as well.

And last but not least, avoid saying extra little words you really don’t want in your document, like "um" or "you know." The computer has no way of knowing which words you say are important, so it simply transcribes everything you say.

We hope you've enjoyed reading about the different ways that people and computers recognize spoken language as well as some tips for effective dictating.
Session 2   Dictate and correct

In Session 2 the student will learn to:

- Start NaturallySpeaking and select the correct voice file
- Turn the microphone on and off
- Dictate some text
- Use Playback to check dictation
- Correct mis-recognised words
- Understand the difference between correcting dictation and text revision
- Exit from the program

Review

During the first session the student learned about how to position the microphone on his / her head and trained the system to recognise his / her voice by dictating a number of sentences into the computer. The student's voice model should now be good enough to start some dictation - but bear in mind that more training and use will be needed to improve the voice model.

Start NaturallySpeaking

1. Check that the microphone is connected and positioned correctly.
2. Load NaturallySpeaking by clicking on the desktop icon, or on Start > Programs > Dragon NaturallySpeaking.
3. Select the student's voice from the list shown.

Hint!

Be sure to select the correct user's voice file when loading the program. You can see the current voice file at any time in NaturallySpeaking by looking below Help on the NaturallySpeaking toolbar - the current user's name will be displayed.
Introducing Speech Recognition in Schools

CALL Centre

Drago NaturallySpeaking v.9

Session 2  Dictate and Correct

Set up the NaturallySpeaking Options

Click on the arrow at the top right hand corner of the NaturallySpeaking Toolbar, to show the Playback and Correction buttons if not already there.

1. Click on Tools > Options to open the NaturallySpeaking Options.

2. Click on the Correction tab, and then tick Automatic Playback on correction.

3. Make sure that the “Correct” command is set to bring up the ‘Spell dialog box’.

4. Click OK.

Set up font and size and save it as a blank page

1. Type in the student's name at the top of the DragonPad word processor, then “Session:”, “Date:” and then add a few blank lines.

2. Click on View > Format Bar if the bar is not visible.

3. Click on Edit > Select All to highlight all the text. Then use the Format Bar to select a suitable font and size that the student can read comfortably. Arial, Tahoma or Comic Sans, all size 14 or bigger, are most suitable for students with reading difficulties. Use a bigger font if the student has a visual impairment.

4. Click on File > Save, to open the Save dialog box.

5. Create a new folder for the student’s speech recognition work by clicking on the third button from the right, with what looks like the exploding folder. Open it.

6. Type in Student's name blank page as the File Name, and click Save.

Show the student how to open this blank document every time they use NaturallySpeaking, and to fill in the date and the number of the Session.
Turn the Microphone on and off

When using a speech recognition system it is important to be able to switch the microphone off quickly: the student may have a question; the teacher may want to talk about something that has happened on screen; there may be some disturbance in the room. There are three ways to turn the microphone off:

**With the Keyboard** – The + key on the Numeric keypad (usually on the right of the keyboard) can be used to switch the microphone off and on. Some laptops do not have a numeric keypad. If this is the case, use **Tools, Options, Hot keys** to select another key. We generally recommend using this method, particularly for students who have difficulty with the mouse.

**With the Mouse** – Click on the microphone icon on the NaturallySpeaking button bar. This is more reliable than turning the microphone off by voice, but is slower than using the keyboard. It means the student gets into the habit of checking that the mic is switched off before turning and chatting to other people.

**By Voice** – The command *Microphone Off* can be used to turn the microphone off – it can then only be turned on by using the keyboard or mouse. Use the command *Go to Sleep* to temporarily turn the mic off. Say *Wake Up* to turn the microphone on again. We don’t generally recommend this method. While it is asleep, the system “listens” for the phrase *Wake Up* before reactivating the microphone. It may misinterpret some other phrase as the *Wake Up* call, and will then try to interpret any later speech as dictation, resulting in unwanted text appearing on screen.

**Hint!**

To start with, click with the mouse or use the keyboard to switch the mic on and off, and to look at the mic button to make sure it has not been left on by mistake. We recommend that the teacher should control the microphone for the first couple of sessions – it gives the student less to worry about!

Dictate Words and Phrases

**Major Hint!**

It is very important to get into a good ‘rhythm’ of dictation as quickly as possible. When you first start dictating, the routine is:

1. Sit up straight and make sure you can breathe properly, so you can speak clearly.
2. Make sure the mic is switched off.
3. Compose and practise a sentence.
4. Switch the mic on.
5. Don’t mutter, sigh, sniff, say 'ummm', 'er' etc before you start the sentence - the computer will pick these up.
6. Speak the phrase or sentence clearly, with a comma or full stop. Use a "dictating voice", speaking slightly more slowly and carefully than you would for conversation. Try to speak like a newcaster - you can speak with an accent, but you must be clear and distinct. Avoid running words together, or letting your voice tail off at the ends of words and sentences.
7. Speak slowly and watch the words as they appear in the small 'results box' and then on screen, to try and spot errors. This will help you learn a good rhythm and will also help improve your word recognition and spelling skills.
8. Wait silently until the words appear on screen - don’t say 'Ooh look it’s great/rubbish/what’s it doing now etc’ - it will pick this up.
9. Switch the mic off.
10. Play back and correct the errors for the sentence.

This can be summarised as:
1. Think about what you want to say.
2. Switch on the microphone.
3. Say it.
4. Switch off the microphone.
5. Look at your text and correct it.

Once accuracy improves, you can dictate a paragraph or two before stopping to correct mistakes, but at first you should correct each sentence as soon as it is dictated.

Turn the microphone on and ask the student to dictate the following:

My name is....(student name) [FULL STOP] [NEWLINE]
Today is... (day of the week) [FULL STOP] [NEWLINE]
This is the first time that I have spoken to a computer [FULL STOP] [NEWLINE]

Turn off the microphone.
Use Playback to listen to what was said

With the microphone off review the text with the student. You can ‘play back’ a recording of what the student actually said and compare it to the text, to check accuracy.

1. Use the mouse to highlight a word, phrase or sentence you need to check.
2. Click on the Playback button.
3. You can also press Ctrl-Shift-S to play back the selection.

Correct errors

If there are no mis-recognised words so far, ask the student to dictate a few more sentences until the computer makes a mistake. Explain that the program will sometimes mis-hear and type the wrong word, so we have to correct it so that it understands the student’s speech properly.

1. Use the Playback button to listen to the recording of the dictation, to find any mis-recognised words.
2. Double click on the word, or highlight two incorrect words, as shown.
3. Click the Correction button on the Toolbar to bring up the Correction Window.
4. If the student cannot use the mouse, press the ‘*’ key on the numeric keypad to bring up the Correction Box.
5. See if the desired word is in the list of options. If it is, select it with the mouse or keyboard, by pressing the ALT key and the number of the word you want. If the word is not offered, type it in.
6. Click on Train. (It is not strictly necessary to train mis-recognised words, but it is good practice in the early stages of use, and improves initial accuracy. In later sessions the student can just correct the word, and not bother training it.)
7. Click OK to replace the mistake with the correct word.
8. Save the document (File > Save) as StudentsNameSession2
Hint!

You can correct errors by just clicking once somewhere in the middle of the mistake, and then clicking Correction, but this tends to show the complete phrase in the Correction Box, rather than just the wrong word. Poor readers will find it easier to fix the mistake by selecting only the wrong word, or words, and then clicking on Correction.

Use Playback to encourage the student to think about why some words might be misrecognised. Did they slur two words together? Did they start saying a word and then change it to something else? NaturallySpeaking is very good at recognising long words, but may make mistakes with short words like “a” and “the”, or “but” and “the”. Taking care to speak these short words clearly will help to improve recognition.

When the misrecognitions have been corrected and trained, ask the student to repeat the dictated text. The results should be better the second time.

Major Hint!

Explain to the student that it is very important to correct mis-recognised words - if you don’t, NaturallySpeaking will probably make the same mistake the next time. Mis-recognitions MUST be corrected with the Correction Box - do not just type over or delete mistakes with the keyboard as this just changes the text, and does not tell the program that it has made a mistake. See the section in chapter 5, pg 53 in the NaturallySpeaking manual for more on correction.

Practise dictation

Ask the student to dictate a few paragraphs from a piece of writing they have previously handwritten or typed. Or, dictate new work using sentence starters, such as “Last weekend I…”, Next weekend I will..”, “My favourite band / team / book / is …”. Encourage the student to think about what he / she wants to say and to practise it with the microphone off, before turning the microphone on and starting to dictate. It can also be helpful for the student to write the text out by hand before they start to dictate. Discuss the student’s initial feelings about using speech recognition and see if he or she is willing to dictate a couple of sentences to describe how they feel. Remember to correct and train any misrecognised words and to dictate all the punctuation.

Recap

Ask the student to dictate what they have learned this session – for example “I can dictate by speaking clearly….I must always fix mistakes by using the
Correction window”.
Print and save again.

If you have time …
Open a new blank document, and choose a story from one of the student’s current school books, the Talking to your Computer text printed at the end of Session 1 or one of the stories in the training. Dictate a few sentences and then correct and train mistakes. Dictate as much as you can and then save the document as StudentsNameSession2B.

Finish
Select NaturallySpeaking > Exit
If the session has gone well click ‘yes’ to save the changes to the user’s voice and vocabulary.
Session 3  Voice Commands

In Session 3 the student will learn to:

- Use voice to control basic functions in DragonPad
- Use ‘Scratch That’
- Force NaturallySpeaking to understand dictation or commands

Review

In the last session the student started dictation, learned to play back recorded speech, and corrected mis-recognised words with the keyboard. In this session, we do more dictation, show how to correct errors in more detail and introduce voice commands.

Get Started

1. Put the microphone on.
2. Start up NaturallySpeaking and select the user voice file.
3. Open the Student’s name2 file from last session.
4. Repeat the first three sentences dictated last session to make sure the system is working properly and the mic is in the correct position. If accuracy is poor, check mic position and try again. Correct any errors and save the file.
5. Switch the mic off.

Dictate and correct errors

1. Open the Student’s name blank page file and fill in the date and number of the session.
2. Switch off the microphone and ask the student to practise the text below before dictating.
3. Switch the mic on and dictate:
Introducing Speech Recognition in Schools

CALL Centre

Session 3  Voice Commands

My name is... (student name) [FULL-STOP] [NEWLINE]
Today is... (day of the week) [FULL-STOP] [NEWLINE]
This is the second time that I have spoken to a computer [FULL-STOP] [NEWLINE]
The program should be getting better at listening to my voice [FULL-STOP] [NEWLINE]

4. Switch the mic off, and show the student again how to double click on a word and then to open the Correction Window. Help the student to correct any mis-recognised words.

5. Save the work as StudentsNameSession3.

6. Switch the mic on and ask the student to dictate the text below. Remind the student to say the punctuation. Don’t correct any errors yet.

It is important for you to know how to speak to this computer [FULL-STOP] [NEW-LINE]
Each word should be spoken clearly to get the best accuracy [FULL-STOP] [NEW-LINE]
Try not to stutter and be careful not to breathe too loudly into the microphone [FULL-STOP] [NEW-LINE]
Imagine that you are talking to someone who does not understand the language very well [FULL-STOP] [NEW-LINE]
Try not to confuse your computer too much [EXCLAMATION-MARK] [NEW-LINE]
Talking too quickly makes it hard to keep up with the dictation [FULL-STOP]
You also tend to slur your words [FULL-STOP] [NEW-LINE]
A good thing about speech recognition is that you never make spelling mistakes. [FULL-STOP] [NEW-LINE]

7. Switch the mic off.

8. Select the text, copy it (press CTRL-C) and then paste it (CTRL-v) so you have two copies.

9. Working on the first copy, select the errors and mark them (underline, or make them bold) so you will be able to count them easily. Count the errors, subtract from the total number of words (108), and divide by the total number of words to get an accuracy score:

\[
\text{Accuracy} = \frac{(108 - \text{No. of errors})}{108}
\]
For example, if you have 10 errors in the 108 words above, you have an accuracy of 90.7%.
Count a short phrase with a couple of errors as one error; count a word split into two words as a single error.
10. Type the accuracy score below the first copy of the text.
11. Now go through the second copy of the dictation with the student to correct any errors. Ask the student to point out the errors and the corrections. Give them help if necessary.
12. Save the file again.

Voice commands

Explain that NaturallySpeaking can understand dictation, for writing, and also commands, for controlling the computer. Commands can control menus and buttons on the computer, and move the cursor or mouse around the screen. Some students find it great fun to tell the computer what to do, while others aren’t interested or have difficulty getting to understand commands. Have a go — if it doesn’t work or seem useful, don’t spend too much time on it.

1. Ask the student to switch the mic on and then say “Click File”, then “Print” then “OK” to print the file.
2. Click on Help > Sample Commands and look through the selection of commands to show the student what can be done with voice commands. Say that we will use some of the commands in later sessions. A complete list can be found in Tools > Command Browser.
3. Point out that the commands are also listed in the Dragon Quick Reference Card, and on one of the CALL Dragon Quick Guides.

Force dictation or commands

Sometimes the computer will type the words instead of treating them as a command — for example it will type ‘File’ on the screen instead of opening the File Menu. You can force NaturallySpeaking to do the action by holding down the CTRL key while you say the command.
Conversely, sometimes you do want it to type the word, rather than treat it as a command. You force dictation by holding down the SHIFT key as you dictate.
1. Switch the mic on.
2. Hold the SHIFT key down, and dictate “I can write a file, print it, and save it.” Point out that the words are typed on screen, rather than commands being carried out.
3. Dictate “Click File”, “Save” to save the file.
'Scratch That'

Sometimes the program gets commands or dictation completely wrong and types a complete load of rubbish on screen. Rather than correcting the whole lot, it may be quicker to say "Scratch That", which deletes the last thing typed.

1. Ask the student to dictate a short sentence quickly and to slur their words.
2. Then hold down CTRL and say "Scratch That". The sentence will be deleted.
3. Dictate the sentence properly again.

Recap

Dictate a few sentences about what you have learned this session, about voice commands and Scratch That. Save the file.

If you have time ...

Start a new document and chose another piece of text from the student’s school books, or continue with the Talking to your Computer or one of the selection of stories. Before you correct errors, do an accuracy check (Accuracy = No. of words dictated – no. of errors, divided by no. of words dictated), and type the score on the document. Save the document as StudentsNameSession3B.

Finish

Exit from the program and remove and store the microphone.
Session 4 Use ‘Read That’ to read back dictated text

In Session 4 the student will learn to:

- Use computer speech for proof-reading and correcting
- Back up the voice file

After the session ask the student to bring along a favourite poster or magazine article to the next session, to use to practise dictation

Review

In Session 3 you practised more dictation, the student started to correct errors, and also learned some voice commands. This session, we will continue with more dictation and show how the NaturallySpeaking 'Read That' command can be used for reading back the dictated text.

Dictate and correct

Ask the student to connect the microphone, start NaturallySpeaking, select their voice model, and open a blank document.

Practise, then dictate the text below.

| Speech recognition training session 4 [NEW PARAGRAPH] |
| Name [COLON] student’s name [NEW PARAGRAPH] |
| Tom didn’t like writing [FULL STOP] [NEW-LINE] |
| Whenever he picked up a pen his hand seemed to shake and the marks he made on the page never quite matched the ideas that were in his head [FULL STOP] [NEW-LINE] |
| It was so frustrating [EXCLAMATION MARK] [NEW-LINE] |

Switch the mic off, and work with the student to correct errors.
Use computer speech for proof-reading

Carry on dictating the text below:

Even when he tried to take a lot of time to produce his best handwriting, people said that his spelling was atrocious.

He had seen adverts on television for a speech recognition system.

People talked into the computer and words would appear on the screen.

It looked very impressive, but there must be a catch.

Switch the mic off. Talk about the importance of correcting mis-recognised words again, and say that NaturallySpeaking can speak out the text to help you find the mistakes. Explain the difference between the actual recording, which can be played back, and the dictated text, which is read back.

1. Highlight the text the student has just dictated, and then select Sound > Read That, hold down the Ctrl and Alt keys and then press S or right click and choose Read That from the menu. The computer will read out the text using its speech synthesiser.

2. You can stop the text being read by right-clicking and choosing Stop Playback/Reading or by pressing ESC.

3. If you want to slow the speech down, go to Tools > Options then select Text-to-speech and adjust the settings as required. Often the standard speech is too fast for many students to understand.

4. If you want to hear a particular word or sentence, highlight it and select Read That again. Ask the student to highlight each sentence in turn and use the speech to listen to and find errors. Use Play That Back to listen to what was dictated, and Read That to hear what was actually typed. Then use the Correction Window to fix any errors.
5. To stop the text being read out when using Playback, you can also use the Stop button on the toolbar.

6. Once all the errors have been corrected, ask the student to say "Click File", then "Print", and print the file.

7. Then say "Click File", and "Save" and save the file as Student's Name Session 4.

Read That can be a very useful tool for students with poor reading skills because it can help them check the text and spot errors. Encourage the student to get into a routine of dictating, then reading back, then correcting, after every sentence or two. As accuracy increases, the student can dictate more text before correcting.

Speech output programs like TextHelp Read and Write and Keystone (see Appendix 3) are also worth investigating if the student is a poor reader. Keystone can read back each phrase or sentence automatically as it is dictated and so help the student review and correct errors. It can also read out the words in the correction box to help students identify the correct word, read out the text in the training stories, and read menus and text in dialogue boxes.

Back up voice files

Now that the student has spent time and effort creating a voice file, it is a good idea to back it up so that there is a copy in case anything happens to the working version.

1. Click NaturallySpeaking > Manage Users > Advance > Back Up. Select the user to be backed up and NaturallySpeaking will create a backup of that voice file.

2. If the student’s own voice file gets damaged – for example, if a session goes badly and the changes get saved accidentally, or if someone else uses the voice file by mistake, the backup can be restored by clicking on NaturallySpeaking > Manage Users > Advance > Restore.

Dictate dialogue

When you dictate a story to the computer, you will need to use inverted commas to mark the words that are spoken by the characters in the story. Try dictating the following:

Scott put on the microphone and started the computer [FULL STOP] He clicked on the speech recognition program [COMMA] and made sure his voice file was loaded [FULL STOP] He switched on the microphone and started to dictate [FULL STOP, NEW LINE]
Suddenly the door opened and his little brother came in. What are you doing? said his brother.

Scram! you wee pain! said Scott in his usual brotherly manner.

But he had forgotten to switch the microphone off and when he looked back at the computer he saw that it had typed: Scramble you read the.

Now look what you've made me do! he shouted. And the computer typed: There equate mainly due on the screen.

His brother looked at the expression on Scott’s face and vanished.

Try both ways of dictating the quotation marks to see if one works better than another. If they are not recognised properly, click on Words > Train in the Naturally Speaking menu, type the command in (e.g. open quote, or begin quote), click on Train, read it, and then try it again. This time it should work.

**Recap**

Dictate the things that you have learned this session: about reading the text, using punctuation, training commands, and backing up your voice file. Save the file.

**If you have time ...**

Start a new document and choose another text from the student’s school books, or more of the Talking to your Computer or one of the selection of stories. Before you correct errors, do an accuracy check (Accuracy = No. of words dictated – no. of errors, divided by no. of words dictated), and type the score into the document. Then correct the errors and save as StudentsNameSession4B.

**Finish**

Exit from the program. Ask the student to bring a poster or picture from a magazine to the next session to practise dictation.
Session 5  Voice commands, composing and dictating text

In Session 5 the student will learn to:

- Move around the text and format with voice
- Control the mouse
- Add a new word to the dictionary
- Plan, compose, dictate and correct text

Review

Last session you practised dictation and correction with 'Read That' to help read back the dictated text. This session you will do some more dictation, add new words to the dictionary, and learn new voice commands.

Get started

Put on the microphone, start NaturallySpeaking and open the blank page.

Format text with voice

Switch the mic on, and ask the student to dictate:

```
SELECT-ALL
DELETE THAT
```

This will delete the text in the blank document. Then dictate:

```
SET-FONT-BOLD, SET-SIZE-18
Speech recognition training session 5 [NEW PARAGRAPH]
SET-FONT-PLAIN, SET-SIZE-12
```
Name [COLON] student’s name [NEW PARAGRAPH]
As well as dictating I can also tell the computer what to do [EXCLAMATION MARK]
GO-TO-SLEEP

**Hint!**

Speak the command words together without a pause - say "Set-font-bold" - if you pause between each word, the program may type them on screen, instead of carrying out the command. If NaturallySpeaking types your command instead of performing it, say "Scratch-that" and the text will be deleted. Repeat the command. If it is typed again, hold down the Ctrl key and repeat the command - this will force NaturallySpeaking to accept the speech as a command rather than as dictation.

Warn the student to avoid using Scratch-that all the time. If only a few errors are made in the sentence it is much better to correct them with the Correction Window than delete the whole thing with "scratch-that". Use Scratch That where more or less the whole phrase or sentence is messed up.

Click on Help > Sample Commands to see other voice commands. If you click on Command Browser from there you will be given a sample of Global commands.

**Plan, compose, dictate and correct text**

This session we will go through the process of planning, composing and dictating a new piece of work.

Switch the mic off and discuss the poster or picture in a newspaper or magazine with the student. Talk about the elements that make up the poster or picture.

Then switch the mic on, and ask the student to describe what's happening, using NaturallySpeaking. Try to produce a few paragraphs of four or five sentences each.

Highlight each sentence in turn, and click the Playback button to listen to the dictation, then Read That to hear what NaturallySpeaking actually typed. Note that you can click the Stop button or press ESC to stop the playback and the reading. Use the Correction Box to fix any errors.

Once all the errors have been corrected ask the student to say "File", then "Print", and after the file has printed, "File", "Save" to save the file as Student'sNameSession5.
Use voice to move around the document

Ask the student to say “Go-to-top” and the cursor should go to the top of the document. Remember to run the words together (“Go-to-top”) so that NaturallySpeaking recognises the command rather than typing the words. Then say “Move-down-one-paragraph” and then “Move-down-two-lines”. Switch the mic off, then click Tools > Command Browser, click on the Browse tab then click and hold the down arrow (current command context) to scroll down the list to choose Voice Dictation Commands. Go over the various voice commands with the student.

Use voice to Playback and Read Back

Ask the student to move the cursor to the top again, and then say "Play Back Line" - the recording will be played back. Then say "Read Line" and the computer will read out the text written on screen. Point out that the student can use these commands to listen to what was said, and then what was typed as many times as he or she wants, to check for errors.

After saying "Read Line", the cursor is moved to the next line down, ready for playing back or reading the next line.

Put the cursor in the middle of a paragraph and ask the student to say "Play Back Paragraph" and then "Read Paragraph".

Use voice to control the mouse and programs

Click on Tools > Command Browser, click in Context and scroll down the list to choose Voice Dictation Commands. Now click on Filter and in the Choose word box enter move then click on Add and then Done. Review the mouse commands, and then try a few out. Say "MouseGrid". Then choose part of the screen by saying the grid number. Move the mouse pointer around by saying "Move-up-5", "Move-right-10". Try to point at an icon on the desktop, then start it by saying "Mouse-double-click".
Add a new word to the dictionary

Explain to the student that *NaturallySpeaking* has a dictionary of hundreds of thousands of words, so it will know most words that are commonly spoken. However, sometimes you will say a word that is not in the dictionary, so you have to teach *NaturallySpeaking* the new word.

Switch the mic on and ask the student to dictate:

```
The computer knows lots of unusual words and proper names [COMMA] like Auchterarder [COMMA] Yamaha [COMMA] and Larsson. [FULL STOP] [NEW-LINE]
But it does not know Quidditch [COMMA] Artur Boruc or Rihanna [FULL STOP] [NEW-LINE]
```

1. *NaturallySpeaking* will not have typed these words because they are not in the dictionary.
2. Double click on what it typed for *Quidditch*, and then click **Correction**.
3. Type in "Quidditch" to the Correction Box and then click **Train** to train the word.
4. Click **Go** and then read the word.
5. *NaturallySpeaking* may ask you to dictate other words as well as *Quidditch* so that it can distinguish between them.
6. Click on **Done** and the new words will be added to the dictionary.
7. Repeat the process for the other words.

Test the new words by saying:

```
Now the computer knows about Quidditch [COMMA] Artur Boruc and Rihanna [EXCLAMATION-MARK] [NEW-LINE]
```

Say "File" then "Save" to save the file. Switch the mic off.

Open **Words > View/Edit** and have a browse around the dictionary of active words used by *NaturallySpeaking*. Click the down arrow in the **Display** box at the bottom of the box and select **Custom words only** to see a list of the words you have just added. If you don't want to use these words again, select them and then click **Delete**.
Recap

Dictate a few sentences about the things that have been covered in this session: text formatting, composing and dictating text, using voice to move around the document, and adding new words to the dictionary. Save the file.

Finish

Exit from the program and remove and store the microphone.
Session 6  Reading and dictating

In Session 6 the student will learn to:

- Use *NaturallySpeaking* to read a passage and questions, and then dictate answers

Review

Last session you learned about voice commands, added new words to the *NaturallySpeaking* dictionary, and planned and dictated a new story. This session you will put some skills into practice by reading and answering questions, and then do some more dictation practice.

Get started

Ask the student to put on the mic, start *NaturallySpeaking* and select the voice file.

Use text to speech to read and then dictate answers

Look in the files on the CALL *Introducing Speech Recognition in Schools CD*, and open the "Using Speech Recognition" file.

Remind the student that the Read That text to speech can be used to help read text loaded into the computer. You can use text to speech in several ways (see p. 74 in the User's Guide for more details):

- Highlight the first sentence and then press **CTRL-ALT-S** and the text will be read out.
- Highlight the second sentence and select **Sound > ReadThat**
- Highlight the third sentence and click the right hand mouse button, then choose **Read That** from the pop-up menu.
- Put the cursor at the start of the line and say "Read-That". If the computer types something instead of reading the line, say "Scratch-That", and try it again while holding down the **Ctrl** key to force it to recognise the command.
- Put the cursor at the start of the document and say "Read-Paragraph".
• Put the cursor at the start of the Questions and say "Read-from-here" and the text will be read out from that point.

Stop reading at any time by pressing ESC.

Practise using the speech output to read the text. Then ask the student to dictate a copy of the text. Save the file, use text to speech to read the questions, and then dictate answers. The answers should be in full sentences, such as "Before you start dictating you should........", rather than answers of just a few words.

Print and save the file as Student'sName6.

Using speech recognition

When you dictate to a computer, you must remember some important things.

a) Before you start dictating a sentence, think about it in your mind. Make sure the sentence makes sense before you open your mouth. Practise the sentence before you start, if you're not sure about it.

b) Speak clearly without stuttering or mumbling.

c) Switch the microphone off after dictating, so the computer doesn’t pick up anything you say to friends.

d) After dictating a few sentences or a paragraph, you MUST correct any errors it makes with the Correction Window. If you can’t spell the correct word, ask for help. If you don’t correct the errors, the program will not learn to recognise your voice.

Questions:

What should you do before you start dictating a sentence?

How should you speak?

What do you do right after dictating?

Why must you correct errors?

More dictation

If you have time, open a new blank page and do some more dictation about a topic, such as a hobby, or going on holiday. It may help for you to write or type out the sentences first so that the student just has to read them out, rather than having to
remember the sentence. Print and save the document as Student'sName6B.

Finish
Switch off the mic and exit. Remove and store the microphone.
Session 7  Building the vocabulary

In Session 7 the student will learn to:

- Analyse documents to teach NaturallySpeaking new words
- Use NaturallySpeaking to read and complete a comprehension exercise

Review

Session 6 covered speech output to read text and questions. In this session you will add new vocabulary to the dictionary and then complete another comprehension exercise.

Get started

Put on the mic, start NaturallySpeaking and select the student's voice file.

Analyse documents

Remind the student that NaturallySpeaking knows a lot of words, but doesn't have every word in its dictionary. To save you adding all the extra words you might need one by one, it has a facility to add new words to the dictionary from files already on the computer.

When NaturallySpeaking analyses the document, it not only adds new words, but also adapts the user's voice model to the style of the text. This means it is better at recognising text because it will 'know' about the topic you are writing about.

Before tackling a piece of writing on a particular topic - such as the Stewart Kings, or Magnetism – you can run text about the topic through the NaturallySpeaking Vocabulary Builder so that any new words or phrases are added.
1. Click on **Tools> Accuracy Centre** then **Add words from your documents to the vocabulary**.

2. Select **Find unknown words**
   And
   **Preview the list of unknown words**

3. Click **Next**, then click on **Add Document** and look for the *Haggis text* file that is on the CALL Introducing Speech Recognition in Schools CD supplied with this pack.

4. Click on **Open** and the document will be analysed for new words and style. Click on **Next** when analysis is finished.

5. Select the words you want to add to the dictionary. Only add words you are likely to actually use when writing. Click on **Next**.
6. You will now be prompted to select words to train. Click on any word you want to include then click on **Train**. Click on **Go** and say the word then click on **Done**.

7. Once you have trained all the words you want click **Next** and you will be presented with a summary of the number of new words found and the number added to your vocabulary.

8. Click **Finish**

**Comprehension activity - use speech output to read questions, and then dictate the answers**

Now ask the student to say "**File**" followed by "**Open**". Look for the **Haggis Questions** file, and open it.

Use the computer speech to read the text and the questions. Get the student to look back at the text to check on the answer to each question, and use speech again, if necessary. Once the student has practised each answer, switch on the mic and the student should dictate the answers. Use complete sentences, e.g.

"**Americans and other visitors to Scotland are often told... ...**".

Switch the mic off and save the file as **Student'sName7**.
Haggis

Americans and other visitors to Scotland are often told that the haggis is a small three-legged creature that runs around the mountains of Scotland. The haggis is a very well dressed creature, usually wearing a kilt in the family tartan - Royal Stewart is the most commonly seen tartan among the haggises in the Cairngorm mountains but you can also catch an occasional glimpse of a haggis wearing the MacDuff tartan.

The male haggis has its left hind leg longer than its right, which means that it has to run round the mountain in a clockwise direction or else it will fall over and tumble down the mountainside. If a haggis forgets about the leg problem and tries to go the opposite way, it shouts out “gardiloo” as it falls. The female, on the other hand, has a longer right hind leg and therefore runs in an anti-clockwise direction. As a result of the males and females always running round the mountain in opposite directions, they hardly ever meet. During the breeding season visitors to the Highlands can often hear the distinctive wailing cry of the male haggis as he tries to find a mate. The music of the Scottish bagpipes has been inspired by the wail of the haggis.

Haggises have a very limited diet which is why they are only found in Scotland. They eat heather (“fraoch” – spoken as “freuch”) and drink water flavoured with berries called irnbru.

Some people say this is a myth - a story made up to confuse tourists. They say that haggis is actually Scotland’s national dish, made from the liver, heart and lungs of a sheep, along with oatmeal, onions and spices, all chopped up and wrapped up in a sheep’s stomach and then cooked. This seems unlikely to me - I mean, who would ever eat something like that? The idea about the small animal with different legs seems much more believable!

Haggis Questions

1. What are Americans and other visitors to Scotland told about the haggis?

2. Which tartans do haggises usually wear?

3. What is the main difference between male and female haggises?
4. What do haggises shout if they fall off the mountain?

5. What was the inspiration for the music of the Scottish bagpipes?

6. What do haggises eat and drink?

7. What are the "real" ingredients of a haggis?

Recap

Dictate a few sentences about what the session has covered: analysing documents to build a vocabulary; using text to speech to read; and dictation to answer questions.

Say “File” then “Print” then “OK” to print the document, and then save it as StudentsNameSession7.

If you have time....

Open a blank document and do some more dictation practice from a piece of work the student has written before, or from a text book. Print and save as StudentsNameSession7B.

Finish

Switch off the mic and exit. Remove and store the microphone.
Session 8    Dictate a Report

In Session 8 the student will learn to:

- Use speech recognition to plan and write a short report
- Correct errors by voice

In the next Session (9) the student will use speech recognition for a class exercise. Discuss which exercise to use with the student and the subject teacher. Choose an exercise which can be completed within one session. You may need to create an electronic version of the text or worksheet so that the student can use computer speech to read it, so prepare this in advance.

Review

Last session we looked at adding new vocabulary to NaturallySpeaking, and then using it to complete an English comprehension activity. This session we will try another activity, and explore other ways of correcting errors.

Get started

Start NaturallySpeaking, select the student's voice file, switch the mic on, and say "File" then "Open". Find and open The Road Accident file from the Introducing Speech Recognition in Schools CD.

The Road Accident

This activity here is to plan and write a report of an accident, as an eye witness. The report could be an important piece of evidence. The accident has happened to a cyclist. The student has to think up a situation and then describe it using the structure below.

Discuss accidents and their causes with the student, e.g. pedestrians not looking when they cross the road; drivers overtaking when they can't see; cyclists going too fast on pavements, drivers falling asleep, and so on.
Talk about any accidents the student has seen or been involved in, and the causes.

The Road Accident.

Report.

Name:
Date:

1. The circumstances
   At what time of day did the accident occur?

   What were the weather conditions at the time?

2. Where did the accident take place?

3. Who was involved, and what happened?

4. How quickly did help (police, ambulance) come?

   What kind of help was given by passers by and ambulance crew?

Discuss the report with the student - talk about:
- the time of day when the accident occurred;
- the weather conditions;
- where the accident took place;
who was involved and what happened
how quickly police/medical help arrived and what they did.

Read and dictate text
Switch the mic on and ask the student to say "Read-from-here" to listen to the whole text and questions.
Use voice commands to move around the text (e.g. "Move-down-1-line") to put the cursor in the correct place to read and add answers.
Help the student to compose and then dictate a few short sentences for each section of the report. The text does not need to be dictated in order - text for section 4 can be put in first, for example.

Correct errors by voice
Use Playback and Speech Output to check for errors after each sentence. To correct an error, don't use the keyboard in the correction window. Instead, say "Correct-thing", where thing is the word to be corrected.
The Correction Window will open, with the word or phrase you want to correct. If you see the word or phrase you want in the list, say "Choose x" - x is the number of the word or phrase. If the correct words are not in the list, type them in and then press return.
Try also selecting an error, and then press the “-“ key on the numeric keypad to bring up the Correction box.
Click on Help > Help Topics > Contents > Correcting recognition errors to learn more about correction.
When the student has finished putting in answers, print the document and save it as Student'sName8.

More comprehension practice
If you have time in this session, say "File" then "Open" and open the "Snow questions" file on the CALL Introducing Speech Recognition in Schools CD.
Use Speech Output to read the text and questions, and dictate the answers. Print and then save the file as Student'sName8B.
**Snow**

I like snow! It is so cool to wake up on a winter's morning to find the ground covered with fresh snow. If it's the weekend, I'll wrap up warm, with a coat, scarf and gloves, and rush out to play. Sometimes I like to make a snowman, using two big balls of snow to make a body and a smaller ball for a head. Fresh snow that's not too dry and powdery is best for making a snowman as long as it's not too wet and slushy. I usually use small stones to make a nose and eyes. I've got an old scarf that I sometimes wrap around his neck to make him look smart.

Sometimes my pals Liam, Mark and Chloe come round and we'll have a snowball fight. That's a good laugh! We never pack the snow too hard when we make snowballs so nobody gets hurt. Some people put stones in snowballs, but I think that is very bad.

Mark has a sledge so we sometimes go up the Doune Brae and sledge down the hill. Somebody usually falls off each time we go down so we all get covered with snow by the end of the morning. It's good fun! After that we'll go back home for a hot bowl of soup and to change into dry clothes.

When I am older I hope to learn how to ski - I am sure that I would love it!

1. What clothes does the writer wear for playing in the snow?
2. What is the best snow for making a snowman?
3. What are the three activities that the writer enjoys doing in the snow?
4. What two things does the author not do when making a snowball?
5. What does the author hope to do when she is older?

**Prepare for Session 9**

In the next Session (9) the student will use speech recognition for a class exercise. Discuss which exercise to use with the student and the subject teacher. Choose an exercise from a communication subject like English or History that can be completed within one session. Discuss completing the exercise with speech recognition with the student and the subject teacher.

Get paper copies of any supporting materials - story texts, worksheets, etc - and if possible, get electronic copies on disc as well.
If you have the text on a disc, you may be able to copy it so that the DragonPad word processor can read it. To do this, open the file in your usual word processor and then either:

7. copy and paste it into DragonPad, or

8. save it as a text or Rich Text File document, and then open it in DragonPad.

If electronic copies are not available, either use a scanner and OCR program to scan them into the computer, dictate them yourself, or type them in. Save the files in 'RTF' format, so that they can be read by DragonPad and other word processors.

If the text contains unusual words or place names, use the NaturallySpeaking Accuracy Centre in Tools to analyse the text and add the terms to the dictionary.

Finish

Switch off the mic and exit. Remove and store the microphone.
Session 9  Dictate school work

In Session 9 the student will learn to:

- Dictate numbers
- Use speech recognition for a classwork exercise

Review

So far, you have trained NaturallySpeaking to the student's voice, learned to dictate, proof-read and correct errors, and practised a little with voice commands and editing. In this session, you put these skills together to tackle a piece of classwork. You will also look at dictating numbers in various formats.

Get started

Start NaturallySpeaking, select the student's voice file, say "File", "Open", and load the student's blank page.

Dictating numbers

Ask the user to repeat the following text. Use “Go-To-Sleep” to switch the mic off after each sentence if you need to practise before dictating. When you say the times, run the words together – say “Nine-a-m” as one phrase.

| A CD costs about fifteen pounds. [Full-stop] [New Line] |
| My birthday is on January twelfth nineteen sixty two [Full-stop] [New Line] |
| (or whatever the student's date is) |
| Half of five is two point five [Full-stop] [New Line] |
| A woman won five hundred thousand pounds on television [Full-stop] [New Line] |
| At the third stroke, the time will be two o'clock [Full-stop] [New Paragraph] |
| Nine a m [tab key] [tab key] English [New Line] |
| Nine fifty a m [tab key] [tab key] Maths [New Line] |
Point out that NaturallySpeaking formats the numbers correctly. Look at p. 85 in the NaturallySpeaking User's Guide for more on dictating numbers.

Ask the student to say "File", "Save" and save the file as Student'sName9.

**Preparation for dictating an exercise**

Before the session, identify a suitable exercise that the student has to complete, from a communication subject like English or History. Discuss completing the exercise with the student and the subject teacher. Choose work that can be completed during one dictation session. Get paper copies of any supporting materials - story texts, worksheets, etc - and if possible, get electronic copies as well. If electronic copies are not available, scan them into the computer with a scanner and OCR program, dictate them yourself, or have them typed in. Save the files in 'RTF' format, so that they can be read by NaturallySpeaking.

If the text contains unusual words or place name, use the NaturallySpeaking Vocabulary Builder to analyse the text and add the terms to the dictionary.

**Activity**

Give the student the exercise on disc, and ask them to go through the whole process of starting NaturallySpeaking, loading in the exercise, reading with Speech Output, inserting dictation, finding and correcting errors, and printing and saving the text. Give help and support where necessary - it is very important that the student is successful in this activity.

If the student does not complete the activity in this Session, correct what you have done and save so you can finish it in Session 10.

Talk about how other items of work could be completed in the same way - who and how would work get put onto disc; when would the student use the speech recognition program to complete them; how would the results be kept with other written material.

Print and save the document.

**Prepare another activity for Session 10**

If you have finished the first class exercise, choose another class exercise to do for Session 10. Arrange to get paper and if possible electronic copies of the text in advance.

**Finish**

Switch off the mic and exit. Remove and store the microphone.
Session 10 Plan using speech recognition for school work

In Session 10 the student will:

- Use speech recognition for another classwork exercise
- Discuss and plan how speech recognition will be used for school work from now on

Review

Discuss how the last session went with the student and staff.

Complete the exercise from Session 9...

If the last session did not work out, discuss why. Was it the task, something about NaturallySpeaking, or was the task not suited to dictation? Try to find a solution to any problems and repeat the activity.

Or start another one...

If the last session was completed successfully, repeat the process for another piece of work. Carry out the preparation with the student - collecting the paper and files on disk, analysing any text, and doing and checking the work. If you have a scanner, try scanning in a simple worksheet, save it as a 'RTF' document, and then open it in NaturallySpeaking. Or, copy and paste the text into NaturallySpeaking. Then use NaturallySpeaking to read and complete the exercise.

Check accuracy

Find a passage of text of 300 words or so (about 5 paragraphs). Start a new document, and then ask the student to dictate the text. Don't correct any errors.

Select the errors and mark them (underline, or make them bold) so you will be able to count them easily. Copy and paste the text into Microsoft Word, or another
Program that can count words. Click on **Tools > Word Count** in Word to count the number of words. Count the errors and divide by the total number of words to get an accuracy score:

\[
\text{Accuracy} = \frac{(\text{Total number of words} - \text{Number of errors})}{\text{Total number of words}}
\]

For example, if you have 10 errors in 300 words, this gives an accuracy of 96.6%.

Don’t count unknown words, or proper names as errors if they are not in the dictionary; a short phrase with a couple of errors counts as one error; and so does a word split into two words.

Type the score in and save as StudentsSession10.

**Plan how you will use speech recognition from now on**

Discuss how the student has found the speech recognition program and training. Some questions to consider are:

1. Will the student use speech recognition for school work from now on?
2. For which subjects and assignments?
3. Where will the student work – learning support base, library, ICT suite, classrooms?
4. Where will the student obtain printouts of work?
5. Will the student use speech recognition for homework – if a laptop computer is used, can the student take it home; or is there a home computer that can be used (some students in the project commented that it was very helpful to be able to practise dictation at home);
6. Does the student need access to speech recognition in several locations around the school? If so:
   - speak to the network or ICT coordinator or technician to discuss how the program can be made available on different computers. Remember you will need multiple licences to install it on several machines. Also note that the program saves the user’s voice file on the desktop computer, not the server, so you will either need a smart technician to copy voice files between computers, or buy *Keystone Roamer* (see Appendix 3);
   - or buy a laptop computer.
Appendices
Appendix 1  Dictating directly into other applications

Most of the time it is best to use NaturallySpeaking DragonPad for dictation because it is fastest and easiest. You can also dictate into other programs, like Microsoft Word, or email or web browser applications.

However, when you use Word, for example, NaturallySpeaking is generally slower to respond unless you have a lot of RAM in your computer.

You may want to use Word or another word processor to save you converting files from Word to RTF format all the time; or because you need facilities like headers/footers or tables.

Refer to pages 37-42 in the NaturallySpeaking User's Guide for more about dictating into Microsoft Word and other Windows programs.

1. Start up NaturallySpeaking, then click on Tools > Options and click the Miscellaneous tab. Make sure Active Accessibility is ticked. This lets you control the menus in most programs by using your voice.

2. Switch the mic on and say: "Start-WordPad", or "Start-Microsoft-Word" or whatever your word processor is called.

3. Dictate and correct as usual. Be aware that dictation is often slower when you talk into Microsoft Word because it takes more memory than DragonPad, so you may have to wait before the words start to appear on screen.

Scanning worksheets into the computer

If speech recognition is to work practically in school, you will need to get printed materials and worksheets into the computer, use the Accuracy Centre to add new words to the vocabulary, and open the file in DragonPad so the student can use Speech Output to read the material and tasks.

There are several programs you can use for scanning text into the computer. Kurzweil 3000 or WYNN are very fast, easy to use scanning programs designed specifically for students with literacy difficulties. You slap the page on the scanner, press scan, and the program does the rest. It scans, re-sizes, rotates as necessary, and presents the scanned image of the page on screen. You can then use the speech to listen to the text: Kurzweil and WYNN highlight the word and sentence being read as they speak. You can change the text colours and sizes to suit the reader, and can add text and recorded voice notes, bookmarks, and highlights. They have spellcheckers and other writing tools like word prediction. Unfortunately, Kurzweil 3000 and WYNN are expensive!

Other scanning programs are:

Read and Write Gold. This is based on TextHelp Read and Write and adds
speech output and scanning facilities to *Microsoft Word* and other applications (R & W Gold). It does not have all of the features of Kurzweil, but it is effective and also not as expensive.

A cheaper alternative is to use the scanning and optical character recognition software that was supplied with your scanner. The OCR software provided with the scanner will probably be a basic version, so it is worth upgrading to a full version of *TextBridge*, *OmniPage* or *FineReader*. All these programs can scan directly into *Microsoft Word*, and then you can use the *NaturallySpeaking* text-to-speech, or the free *WordTalk* add-on to read the text, and dictate answers. They work well with documents that are mainly text, but pages with complicated layout and lots of graphics (like worksheets) often lose formatting and do not look much like the original unless you spend some time editing and adjusting them.

Once the text is scanned in, you will need a program to read it out. The *NaturallySpeaking* computer speech is fairly limited, so it is worth looking at *Keystone ScreenSpeaker*, *TextHelp Read and Write* or *WordTalk*, all of which have better speech output facilities. They give more control over the speech, and also highlight the words as they are read so it is easier to follow.

The advantage of scanning into *Word* and then using speech output is that the full set of *NaturallySpeaking* tools, including Playback and Correction, are available. The disadvantage, compared to *Kurzweil*, for example, is that you end up using several different programs – the OCR, *Word*, *NaturallySpeaking*, and maybe also a speech output program. This is more complicated than just using *Kurzweil* or *WYNN* plus *NaturallySpeaking*, may therefore be fiddly and less reliable, and may require lots of memory in your computer.

**Dictating into Email**

Close *Word*, switch the mic on, and say “Start-Mail”. Your email program should start up. You can control and dictate straight into most email programs including Outlook and Eudora. Click **Tools > Options** and click the **Formatting** tab. Make sure **Automatically format text** and **Web and E-mail addresses** are ticked.

Try creating and writing an email message. For example, in Outlook, say:

2. Dictate the name of the recipient. Say “dot” for a dot, and “at sign” for ‘@’.
3. Move from ‘To’ to ‘Subject’ to the message box by saying “Tab-key”.

**Dictating into other applications**

There are two techniques for dictating into other applications:

1. dictate directly into the program;
2. dictate into DragonPad, and then copy and paste into the program.

**Dictate directly**

You can dictate into almost anything, but some of the *NaturallySpeaking* commands and facilities do not work with some programs. The advantage of using
Introducing Speech Recognition in Schools

CALL Centre

Appendix 1 Dictating into other applications

_NaturallySpeaking_ v.9

**Word,** or one of the other programs supported by _NaturallySpeaking_, is that playback and correction work properly, and you can edit, format and use the _Word_ menus.

To dictate directly into an application, start up _NaturallySpeaking_, then open up a new page in the word processor. Switch on the mic, click on the word processor window and start dictating.

Dictate in the normal way into the word processor. You will probably find that the text appears a little slower (and if you have an older computer with only 512 MB of RAM, a lot slower) than it would if you were using the DragonPad word processor. To stop dictating either switch the mic off, or say "**Microphone Off**". The straightforward dictation works in the same way as when you dictate into DragonPad but the playback, read back and correction window usually do not.

The main limitation of dictating into many applications is that you cannot select a mistake and then click on the Correction button to correct it – you have to say "**Correct-That**" as soon as the error appears on screen. This technique works well if you dictate one or only a few words at a time, and check the results immediately. It also focuses the student's attention on the text, which will help improve their word recognition skills. (Note - if you _don't_ correct the errors, _don't_ save your user speech files when you finish.)

The other main limitation is that Playback does not work fully and Read That does not work at all. You can only play back the last thing you said, by opening the correction window and clicking Playback.

The commands to control the cursor and the programs _usually_ seem to work okay - voice commands can be used to move around the document ("**Go-to-top**", "**Move-down-1-line**" etc) and open, close, save and access menus ("**File**", "**Save**").

With _NaturallySpeaking_ you can dictate into talking word processors like _Write:Outloud_ or _TextEase_. By setting the speech feedback to read back after each sentence, the user gets spoken confirmation about the text. (Note – speech feedback of every word does not work very well because the talking word processor waits until it receives a space before reading the word, which means it is always one word behind the dictation.)

If the user really needs speech feedback to identify errors and proof-read, you are much better off with _Keystone SpeechMaster_. It gives very effective speech feedback, can read out the words in the Correction Box and links well with Word and _NaturallySpeaking_ so that when you pause, your dictated text is automatically read back to you. It also comes with a set of simpler stories to read for training _NaturallySpeaking_, and can read them out,. Which makes training much easier for students with reading problems.

You can also get symbol support by dictating into _Writing with Symbols_ or _Clicker_. The screen shot shows how _Writing with Symbols_ automatically types a symbol on screen to match the text as it is dictated. Although it may seem slightly strange to suggest that a poor reader who uses symbols to support their reading might use speech recognition, we think it is worth considering. We would not expect the student to generate large quantities of text, but rather dictate small amounts as an alternative to using symbol grids or overlay keyboards.
Copy and paste from DragonPad to the other application

The second technique for using speech recognition with other applications is to compose the text with DragonPad, then copy and paste it into the target program. For example, to write an email you would:

1. Open the email program then say “Minimize window”
2. Open Dragon Pad
3. Dictate the email with DragonPad.
4. Say “Copy all to clipboard” to copy the text.
5. Say “Switch to Outlook Express” (or whatever the email program is called).
6. Click on the message box, and then say “Paste That” to insert the dictated text.
Appendix 2 Technical issues

Poor audio quality

If you get poor audio quality when you go through the audio setup sequence, you must try to fix it otherwise you will be wasting your time with speech recognition. Poor audio is due to:

a) The microphone being plugged into the wrong socket on the computer. This is easier to do than you might think! Check it.

b) Poor microphone positioning. Check that the mic is positioned to the side of your mouth, about 2cm away. Check the mic is facing your mouth - some mics have a small dot and this must be facing your mouth. If it faces the room it will be doing it's best to cancel out your voice, and listen to the rest of the room!

c) Poor or defunct microphone. The mic may not be working properly, or it might have got broken, or the cable snagged. Try a different mic to see if that makes a difference.

d) Poor quality soundcard. Some soundcards are better than others at getting a good clean signal for speech recognition. Laptops in particular may have poor sound input because the electronics are all jammed in close together and the signal can pick up noise from other components. Use the Sound Recorder (see below) to check the sound input – if it is ‘hissy’ and noisy, you should either fit another sound card, or try a USB microphone (e.g. the Dragon Naturally Clear mic) or USB ‘pod’, such as the Andrea USB Pod from iANSYST. USB mics plug into the USB port on the computer and by-pass the soundcard. You can connect a standard mic into the USB pod, and then plug it into the USB port on the computer, again by-passing the soundcard. There are sometimes technical hitches with USB, though - see the iANSYST web site (http://www.iansyst.co.uk).

e) Sound input settings. It is possible that your computer's sound input settings may be switched off, or adjusted in some way that affects sound input. For example, if your sound card is set to apply reverb or echo to sounds, it will obviously affect the recognition!

Click on Start > Settings > Control Panel, and open the Sounds and Audio Devices Control panel. Click on Voice and Test Hardware to test your system. You should also check Audio to make sure that the correct device has been selected for Sound Recording.

Sound Recorder

Use the Sound Recorder to investigate the sound quality. Click on Start > All Programs > Accessories > Entertainment > Sound Recorder. Record some speech, and then play it back. You may find that the signal is far too loud, or that is very crackly and noisy when played back. If it sounds too loud and seems to pick up your breathing, move the mic away from you mouth, or speak more quietly.
If you have tried different mics, adjusted the sound input settings, and experimented with different positions without success, you may have to give up on the sound card in your computer or use a USB mic or pod. See Appendix 3 for suppliers.

**Poor accuracy**

1. If you experience poor accuracy, first run the Audio Setup (**Tools** > **Accuracy Centre** > **Check your audio settings**) to make sure the sound is OK – see earlier.

2. **Equipment**
   
   You need a good microphone and soundcard that produce a consistent, clean signal (see above). The Andrea NC-7100 (iANSYST) and Sennheiser (Words Worldwide / iANSYST) mics are good, and the Andrea NC-91 and BlueParrot are also recommended. Make sure the mic is adjusted correctly and consistently. If you don’t have a good mic, you are wasting your time.
   
   Sound cards with a good name are the SoundMax and the Creative Labs Audigy 2. See the iANSYST or Nuance web site for more on sound cards.
   
   The minimum computer specification quoted by Dragon will give you minimum results, so get more memory (and/or buy a faster computer). Memory is cheaper and also appears to make more of a difference than a faster processor. Go for lots of RAM - 2 GB or more if you can.

3. **Mic positioning**
   
   The microphone must be positioned in the same correct place every time. It should be 2 cm away from the corner of your mouth. Practise putting it in the correct place using a mirror if necessary. If the accuracy suddenly changes from the previous session, try adjusting the mic a little. Use the Sound Recorder (see above) once when accuracy is good and save the recording. Then if accuracy is bad, use the Sound Recorder again and compare the saved good recording with the current sound. Adjust the mic to try and replicate the good recording.

4. **Complete the training and do more**
   
   Make sure you read through the NaturallySpeaking training text. If accuracy is still poor, click **Tools** > **Accuracy Centre** > **Perform Additional Training**. Choose another story and do more training. This will involve reading for 18 minutes, so only start it if you have time to finish it.

5. **Correct errors / train mis-recognised words**
   
   Use the Correction Box to correct errors. If a word is consistently mis-recognised, click **Train** in the Correction Box to record a pronounciation of how you say that word.

6. **Speak clearly**
   
   Sit up straight, and try to speak like a newsreader. You can still have your own accent, but you need to speak confidently and clearly, without slurring or missing small words, or tailing off at the end of the sentence.

7. **Speak sense**
   
   NaturallySpeaking is not a mind reader – it will only recognise sounds. It does not know what words mean, so if you want it to print a word, you have to say the word. If you talk nonsense, change your mind halfway through a sentence, say ‘umm’, ‘ahh’, etc, that’s what NaturallySpeaking will type on the screen.
8. Speak in short phrases, rather than single words.

9. Use the Accuracy Centre Vocabulary options to adapt your dictionary for the words you use.

10. If you find that your recognition dips slightly some months after you start using speech recognition, it can be a good idea to create a new profile from scratch. Inevitably your voice file picks up on inconsistencies over time and becomes ‘messy’. A fresh profile lets it start with a clean slate, using your voice after you have become an experienced speech recognition user.

**Problems getting through training**

1. Before you start training, go over the text with the student and practise any difficult words or phrases. You may want to print out the text in a larger font, from the CALL *Introducing Speech Recognition in Schools* CD. You could also try printing the text out with each sentence on a separate line, then ask the student to read from the paper rather than the screen. Use the Pause and Go buttons and prompt the student when to start and stop speaking. The student could use a piece of card to keep the place when reading from the paper.

2. Read the first phrase or short sentence, and then wait for the text to turn grey before carrying on with the next phrase. Once the student gets into the swing of it, you can dictate more text without pausing.

3. Dictate a few words or a phrase at a time, rather than speaking individual words and pausing between each word.

4. If the program doesn’t seem to recognise anything, click Pause, and start again by reading the first few words. Make a conscious effort to speak clearly, and wait until the text turns grey before continuing.

5. If the student has difficulty reading the text, click on Pause after each phrase or sentence to stop recording, so the student can practise reading the next one. You can even pause to practise every word if necessary - but the training will take a long time if you do! Read the text to the user and have them practise it before clicking Go.

6. If the student gets stuck on a word, whisper it – the computer will not pick up your voice.

7. If the program does not pick up a particular word, the student should repeat it. If the word is not recognised after a couple of tries, click on Skip. Try to avoid using Skip, if you can. You can press the Pause button at any time to stop, and read the next sentence. You can also dictate slowly - a few words at a time, or even one word at a time. If the computer gets stuck and doesn’t recognise a word even after repeating it a few times, click Skip.

8. Stop and have a rest at least three or four times during training to relax and have a sip of water.

9. If the student has significant reading difficulties, you should consider buying *Keystone ScreenSpeaker*. This program can read out the training text direct from the *NaturallySpeaking* screen using the computer's speech. The student listens to the text, and then repeats it. Keystone can also read back text as it is dictated to help the user check the dictation – when the user pauses after each phrase, Keystone reads the text back using the computer speech. It can also read menus,
dialogue boxes, and the items in the Correction Window to help the user correct errors. It provides a set of simpler training texts, split into short easy to read paragraphs. See Appendix 3 for cost and suppliers.

10. Or, you could load the training text into the *NaturallySpeaking* window (or into another talking word processor, like *Write:Outloud, TextEase* or *First Word*). Arrange the word processor window beside the training window, and then use the computer speech to read the text before dictating it. *Write:Outloud* and *TextEase* are particularly helpful because they can highlight each word as it is spoken out by the computer.

**Network issues**

If speech recognition is to work successfully in secondary schools, the students must have access to the program in different locations across the school. Therefore, the student must have their own individual laptop computer, or the program must be installed on several desktop computers, or it must be available on the network server.

“Enterprise” versions of the program are available from suppliers for installation on network servers. However, since most schools run networks where each computer has its own Windows operating system, with only files and desktops controlled from the server, enterprise versions may not work as they are designed for full client-server networks where the program resides on the server.

The Professional edition has a Roaming User facility which allows the user to connect to any machine on the network and use their own files so that the same files can easily be used in different classrooms or on a laptop. Voice files are automatically updated so a laptop could be used both at home and at school with voice files automatically updated when reconnected to network.

**Transferring DNS 8 voice files between computers**

1. Create a new user, with the same name, on your new computer and read the first two sentences of training. Exit *NaturallySpeaking* without saving the training. This will create an untrained voice file.

2. Find the folder with your voice files on the new computer, and open it – go to c:\Program Files\Dragon Systems\NaturallySpeaking\users\(your name).

3. Go to your original computer and copy the contents of the same folder (c:\Program Files\Dragon Systems\NaturallySpeaking\users\(your name) to a memory stick or a recordable CD, or across the network.

4. Replace the files in your user file on the new computer, with the files from the original.

5. Start up *NaturallySpeaking* and do some dictation to test the voice file.

User files can also be imported and exported between machines using the *NaturallySpeaking* menu. A system needs to be designed to keep the user files up-to-date. It may be easier to manage if each time a user logs onto a new machine they
import the last used voice file as this will be the newest.

1. Go to NaturallySpeaking>Manage Users.
2. Choose the user file you wish to transfer.
3. Click on the Advanced button then select Import.
4. A Windows Browse dialogue box will appear to enable you to find the location of the file you want to import.
## Appendix 3 Resources and suppliers

### Hardware and software

<table>
<thead>
<tr>
<th>Item</th>
<th>Description</th>
<th>Price (ex VAT)</th>
<th>Supplier</th>
</tr>
</thead>
<tbody>
<tr>
<td>Dragon NaturallySpeaking Preferred v 9</td>
<td>Recommended version of NaturallySpeaking</td>
<td>£149</td>
<td>IANSYST, Words Worldwide, computer shops</td>
</tr>
<tr>
<td>Dragon NaturallySpeaking Professional v 9</td>
<td>Recommended version for a user requiring access at different points in a network.</td>
<td>£525</td>
<td>IANSYST, Words Worldwide, computer shops</td>
</tr>
<tr>
<td>Dragon Dictate Power Edition</td>
<td>Older ‘discrete’ speech recognition program</td>
<td>£150</td>
<td>Words Worldwide</td>
</tr>
<tr>
<td>Quillsoft WordQ</td>
<td>Word prediction software required for using SpeakQ.</td>
<td>cdn $225</td>
<td><a href="http://www.wordq.com">http://www.wordq.com</a></td>
</tr>
<tr>
<td>Quillsoft SpeakQ</td>
<td>Alternative speech recognition program designed for people with reading and writing difficulties.</td>
<td>cdn $135</td>
<td><a href="http://www.wordq.com">http://www.wordq.com</a></td>
</tr>
<tr>
<td>Andrea NC-7100</td>
<td>Good mic with earpiece speaker</td>
<td>£49</td>
<td>IANSYST</td>
</tr>
<tr>
<td>ParrotTalk Pro Max</td>
<td>High quality stereo mic.</td>
<td>£65</td>
<td>Words Worldwide</td>
</tr>
<tr>
<td>Andrea NC-91</td>
<td>Good, basic microphone</td>
<td>£26</td>
<td>IANSYST</td>
</tr>
<tr>
<td>Andrea USB Adapter Pod</td>
<td>Connects standard mic to a USB compatible computer, bypassing sound card</td>
<td>£33</td>
<td>IANSYST</td>
</tr>
<tr>
<td>Keystone ScreenSpeaker</td>
<td>Reads back dictated text as it is dictated with NaturallySpeaking. Also reads correction list and has simpler training scripts</td>
<td>£150</td>
<td>Words Worldwide</td>
</tr>
<tr>
<td>TextHelp Read and Write Gold 8.1</td>
<td>Reads text and menus etc in any program; has spellchecker, word prediction. Can also scan documents.</td>
<td>From £320</td>
<td>IANSYST, Concept Northern, Words Worldwide</td>
</tr>
<tr>
<td>OmniPage Pro 16</td>
<td>Claims to be the most accurate OCR.</td>
<td>£68</td>
<td>IANSYST, computer shops</td>
</tr>
<tr>
<td>FineReader Pro 9</td>
<td>Good scanning OCR program</td>
<td>£68</td>
<td>IANSYST, computer shops</td>
</tr>
<tr>
<td>Kurzweil 3000 v10 (v3 Mac) Scan/Read</td>
<td>Excellent program for scanning and reading. Lots of useful study tools. Expensive.</td>
<td>£500 (mono)</td>
<td>Sight and Sound, IANSYST</td>
</tr>
<tr>
<td></td>
<td></td>
<td>£725 (colour)</td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td>£185</td>
<td></td>
</tr>
<tr>
<td>Kurzweil Learn Station</td>
<td>Read only.</td>
<td></td>
<td></td>
</tr>
<tr>
<td>WYNN</td>
<td>Similar to Kurzweil 3000. WYNN Wizard (with OCR).</td>
<td>£730</td>
<td>Don Johnston Special Needs</td>
</tr>
<tr>
<td></td>
<td></td>
<td>£335</td>
<td></td>
</tr>
</tbody>
</table>
Introducing Speech Recognition in Schools

Dragon NaturallySpeaking v.5

CALL Centre

Appendix 3  Resources and Suppliers

<table>
<thead>
<tr>
<th><strong>WYNN Reader</strong></th>
<th><strong>£71</strong></th>
<th><strong>Don Johnston</strong></th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Write:Outloud SOLO</strong></td>
<td>Simple talking word processor. Scottish schools can purchase this cheaper under the LTS Software licensing scheme.</td>
<td><strong>£71</strong></td>
</tr>
<tr>
<td><strong>TextEase CT</strong></td>
<td>Good word processor/desktop publishing program. Scottish schools can purchase this cheaper under the LTS Software licensing scheme.</td>
<td><strong>£85</strong></td>
</tr>
<tr>
<td><strong>Clicker 5</strong></td>
<td>On-screen grid program with talking word processor. Upgrade from v4</td>
<td><strong>£120</strong></td>
</tr>
<tr>
<td><strong>Writing with Symbols 2000</strong></td>
<td>Word processor with symbols and grids</td>
<td><strong>£160</strong></td>
</tr>
<tr>
<td><strong>Communicate: in Print</strong></td>
<td>Symbol-supported desktop publishing package.</td>
<td><strong>£89</strong></td>
</tr>
</tbody>
</table>

**Suppliers**

<table>
<thead>
<tr>
<th><strong>Concept Northern</strong></th>
<th><strong>Crick Software Ltd</strong></th>
<th><strong>Dabs</strong></th>
</tr>
</thead>
<tbody>
<tr>
<td>11-13 St Bryde Street</td>
<td>Crick House Boarden Close Moulton Park Northampton NN3 6LF</td>
<td>Direct House Wingates Industrial Park Westhoughton Bolton BL5 3XD</td>
</tr>
<tr>
<td>East Kilbride G74 4HQ</td>
<td>Tel: 01604 671692 Fax: 01604 671692</td>
<td>Tel: 0870 429 3120</td>
</tr>
<tr>
<td>Tel: 01355 573173 Fax: 01355 573073</td>
<td><a href="http://www.cricksoft.com/uk">http://www.cricksoft.com/uk</a></td>
<td><a href="http://www.dabs.com/">http://www.dabs.com/</a></td>
</tr>
<tr>
<td><a href="http://www.assistiveit.co.uk">http://www.assistiveit.co.uk</a></td>
<td><strong>Don Johnston Special Needs</strong></td>
<td><strong>Inclusive Technology</strong></td>
</tr>
<tr>
<td><strong>iANSYST Ltd</strong></td>
<td><strong>Fen House</strong></td>
<td><strong>Riverside Court, Huddersfield Road, Delph Oldham OL3 5HZ</strong></td>
</tr>
<tr>
<td>Calver Road</td>
<td>Fen Road Cambridge, CB4 1UN</td>
<td>Tel: 01457 819790</td>
</tr>
<tr>
<td>Winwick Quay</td>
<td>Sales: 0800 018 0045</td>
<td>Fax: 01457 819799</td>
</tr>
<tr>
<td>Warrington WA2 8QP</td>
<td>Tel: 01223 42 01 01</td>
<td><a href="http://www.inclusive.co.uk">http://www.inclusive.co.uk</a></td>
</tr>
<tr>
<td>Tel: 01925 256500 Fax: 01925 241745</td>
<td>Fax: 01223 42 66 44</td>
<td><strong>Words Worldwide</strong></td>
</tr>
<tr>
<td><a href="http://www.donjohnston.co.uk">http://www.donjohnston.co.uk</a></td>
<td><a href="http://www.dyslexic.com">http://www.dyslexic.com</a></td>
<td><strong>Widgit Software Ltd</strong></td>
</tr>
<tr>
<td><strong>Sight &amp; Sound Technology</strong></td>
<td><strong>Ash House</strong></td>
<td><strong>Denny Lodge Business Park Ely Road, Chittering Cambridge CB25 9PH</strong></td>
</tr>
<tr>
<td>Qantel House</td>
<td>Bell Villas, Ponteland Newcastle Upon Tyne NE20 9BE</td>
<td>Tel: 01223 815 210</td>
</tr>
<tr>
<td>Anglia Way</td>
<td>Tel: 01661 860999 Fax: 01661 822777</td>
<td>Fax: 01223 864 962</td>
</tr>
<tr>
<td>Moulton Park</td>
<td><a href="http://www.wordsworldwide.co.uk">http://www.wordsworldwide.co.uk</a></td>
<td><a href="http://www.widgit.com">http://www.widgit.com</a></td>
</tr>
<tr>
<td>Northampton NN3 6JA</td>
<td><strong>Learning &amp; Teaching Scotland</strong></td>
<td><strong>Learning &amp; Teaching Scotland</strong></td>
</tr>
<tr>
<td>Tel: 01604 798070 Fax: 01604 798090</td>
<td>The Optima 58 Robertson Street Glasgow G12 9JN</td>
<td><strong>The Optima 58 Robertson Street Glasgow G12 9JN</strong></td>
</tr>
<tr>
<td><a href="mailto:sales@sightandsound.co.uk">sales@sightandsound.co.uk</a></td>
<td>Tel: 0141 337 5000 Fax: 0141 337 5050</td>
<td>Tel: 0141 337 5000 Fax: 0141 337 5050</td>
</tr>
<tr>
<td><a href="http://www.sightandsound.co.uk">http://www.sightandsound.co.uk</a></td>
<td><a href="http://www.sightandsound.co.uk">http://www.sightandsound.co.uk</a></td>
<td><a href="http://www.ltscotland.org.uk">http://www.ltscotland.org.uk</a></td>
</tr>
<tr>
<td><strong>Softease, Market Place, Ashbourne, Derbyshire DE5 1ES</strong></td>
<td><strong>Widgit Software Ltd</strong></td>
<td><strong>Widgit Software Ltd</strong></td>
</tr>
<tr>
<td>Tel: 01335 343421 Fax: 01335 343422</td>
<td><strong>Denny Lodge Business Park Ely Road, Chittering Cambridge CB25 9PH</strong></td>
<td><strong>Denny Lodge Business Park Ely Road, Chittering Cambridge CB25 9PH</strong></td>
</tr>
<tr>
<td><a href="http://www.softease.com">http://www.softease.com</a></td>
<td>Tel: 01223 815 210 Fax: 01223 864 962</td>
<td>Tel: 01223 815 210 Fax: 01223 864 962</td>
</tr>
<tr>
<td><strong>Writing with Symbols 2000</strong></td>
<td><strong>Word processor with symbols and grids</strong></td>
<td><strong>Widgit</strong> (Inclusive Technology)</td>
</tr>
<tr>
<td><strong>Communicate: in Print</strong></td>
<td>Symbol-supported desktop publishing package.</td>
<td><strong>£89</strong></td>
</tr>
</tbody>
</table>
Web sites


Ability Net (UK) http://www.abilitynet.co.uk/edu_resources Several useful information sheets covering different aspects of speech recognition, including use by people with dyslexia and visual impairment.

British Dyslexia Association – http://www.bdadyslexia.org.uk Information about dyslexia and downloadable information sheets on a wide range of related topics including the use of technology to support writing.

CALL Scotland (UK) http://www.callscotland.org.uk Electronic versions of this Pack plus other resources on speech recognition, plus information on a range of curriculum-based topics related to augmentative communication and assistive technology.

Comp.Speech FAQ http://svr-www.eng.cam.ac.uk/comp.speech/index.html. This is a site with answers to frequently asked questions regarding all aspects of computers and speech. Chapter 6 is devoted to voice recognition. Some of the information is quite technical, but the site contains a comprehensive guide to the many different packages available, with links to manufacturers’ web sites, and a lot of useful background material, including material on health issues.

Computing Outloud (USA) http://speechwiki.org/out-loud/ This site brings together the thoughts of a number of speech recognition users on different programs, with useful information and tips.


Iansyst Ltd. http://www.dyslexic.com Specialist supplier for speech recognition in education. The site is regularly updated with comparative reviews and the latest pricing information. Probably the second best place to start looking for information on speech recognition.

The Literacy Centre (USA) http://www.theliteracy-center.com Deals with literacy and students with SEN; includes case studies and hints and tips on speech recognition.


Microphones.com (USA) http://www.microphones.com US microphone company – good for seeing which mics are currently recommended.

SNOW (Special Needs Opportunities Window) (Canada) – http://snow.utoronto.ca Massive collection of material, including curriculum resources (e.g. on-line electronic books), lesson plans and guides to good practice (e.g. guidelines for introducing Dragon Dictate voice recognition).

Speaking to Write (USA) http://www.edc.org/spk2wrt This was an American project exploring the use of voice recognition technology to support secondary age students with disabilities. The site includes an archived discussion group, including contributions from the UK, where many educational and practical issues were discussed. No longer updated, but the site is still live.

Typing Injury FAQ: Speech Recognition http://www.tifaq.com/speech.html Detailed reviews of most of the systems available and lots of links to other sites. People should be able to track down any information they want from this, or the Comp.Speech FAQ site.

WordQ (Canada) http://www.wordq.com. Developers of the SpeakQ speech recognition system

Words Worldwide Ltd. – http://www.wordsworldwide.co.uk Information on Keystone, NaturallySpeaking and voice recognition systems.
Books, articles and papers

See the BECTa, iANSYST (dyslexic.com) and Words Worldwide web sites for some of these, and other articles and case studies.


Hopkins, Janet (2002) *Speech Recognition software does it belong at your school? Closing the Gap* Vol 21.2


Litten, M. *Usable Voice Recognition Software: The Mark College Experience!* Dyslexia
Introducing Speech Recognition in Schools

CALL Centre

Dragon NaturallySpeaking v.5

Appendix 3  Resources and Suppliers

Review, Vol. 13 No. 2. Also
http://www.keyspeli.com/Speechproducts/speechproducts.htm


Mundl, Jen and Redepenning, Sue (2008) *And watch the words appear* **Closing the Gap** Vol 26.6


Savison, Rosemary & Springett, Lindy (2002) *When Writing means Talking*. In Dyslexia Contact. BDA, 98 London Road, Reading RG1 5AU.


Wald, Mike (2006) *An Exploration of the Potential of Automatic Speech Recognition to Assist and Enable Receptive Communication* University of Southampton (http://eprints.ecs.soton.ac.uk/12136/)


Speech Recognition in Schools: Using NaturallySpeaking V 9

By Paul Nisbet, Allan Wilson & Fionna Balfour

This book is designed to help teachers and parents teach young people to use the Dragon NaturallySpeaking Preferred 9 speech recognition program.

Speech recognition has been presented as the latest “panacea” for people with dyslexia and other writing difficulties. Some students have used speech recognition systems successfully for their work and for exams, and the use of this technology has helped them to overcome their difficulties and go on to higher education. However, there have been other students in other schools, who have not found speech recognition useful.

This book contains information and advice for schools who wish to introduce speech recognition successfully. It includes background information on a CALL Scotland project involving the introduction of speech recognition in a number of schools in Scotland in 2001, along with a guide for teachers and ten student lessons. The student lessons are structured to teach skills at a pace suitable for students with reading or writing difficulties. A CD with extra resources and files for use in the student lessons is available from CALL Scotland. Resources can also be downloaded from the CALL Scotland web site.

The book was originally developed and evaluated in conjunction with staff and pupils in secondary schools in Scotland. It has now been updated to take into account the changes to NaturallySpeaking and other developments in speech recognition over the past few years.

ISBN 1 898042 28 0

2008

CALL Scotland
Communication, Access, Literacy and Learning

Paterson’s Land, Holyrood Road
Edinburgh EH8 8AQ
Tel 0131 651 6235/6236
Fax 0131 651 6234
Email info@callscotland.org.uk
http://www.callscotland.org.uk