




Introducing Speech Recognition in Schools: using IBM ViaVoice 

April 2002   Paul Nisbet & Allan Wilson. 

ISBN 1 898042 23 8 

Published by the CALL Centre, University of Edinburgh, Paterson�s Land, Holyrood Road, 
Edinburgh EH8 8AQ. 

Ò CALL Centre, University of Edinburgh and Scottish Executive Education Department. 

British Library Cataloguing-in-Publication Data 

A catalogue record for this book is available from the British Library 

This book may be reproduced in full or in part, with the permission of the authors, by 
education authorities or others working with people with disabilities.  Copies may not be 
sold for profit. 

Copyright is acknowledged on all company and product names mentioned in this book.  

Every effort has been taken to ensure the accuracy of information contained in this book, 
but readers are advised to check details with suppliers prior to purchase. 

The preparation of this book was funded by the Scottish Executive Education Department.
The views expressed within are not necessarily those of the Department or any other 
government department. 

We are grateful to: 

¶ the teachers and students who took part in our project and made comments and 
suggestions about this book; 

¶ the Scottish Executive Education Department, for funding the project; 

¶ staff in local authorities who supported the project; 

¶ IANSYST and Words World Wide for technical support; 

¶ IBM and Scansoft, for permission to print extracts from the training scripts. 

Thanks to Sheila Siwo and Murray Stewart for permission to use the photograph on the 
front cover.



Introducing Speech Recognition in Schools IBM ViaVoice v.9 
CALL Centre

ii



Introducing Speech Recognition in Schools IBM ViaVoice v.9 
CALL Centre

Contents

ABOUT THE PACK ............................................................................................................................................7

Feedback on the Pack...........................................................................................................................................8

HOW TO USE THE PACK.................................................................................................................................9

How long does it take to do the training?...........................................................................................................10
Which students might benefit from using speech recognition?..........................................................................11

Word processing and IT skills .......................................................................................................................12
Motivation .....................................................................................................................................................12
Perseverance and ability to work independently12
Oral communication......................................................................................................................................12
Reading and literacy skills ............................................................................................................................13

What support is needed? ....................................................................................................................................14
What do students use speech recognition for? ...................................................................................................16
Can young children use speech recognition? .....................................................................................................16
What happens if a student�s voice changes? ......................................................................................................16
Can the program understand strong local accents? ............................................................................................17
Will using speech recognition make students lazy and less able to write or type? ............................................17
Which speech recognition program is best?.......................................................................................................18

Windows ........................................................................................................................................................18
MacOS...........................................................................................................................................................19

Where should I buy a speech recognition program? ..........................................................................................19
What sort of computer is needed? ......................................................................................................................20
Can the program work on a networked computer? ............................................................................................20
Microphones and Soundcards ............................................................................................................................21
Do you REALLY want to do this?.....................................................................................................................21

TEACHER�S TUTORIAL.................................................................................................................................25

You will need:....................................................................................................................................................25
In this tutorial you will learn how to:.................................................................................................................25

Install the program........................................................................................................................................26
Get started.....................................................................................................................................................26
Audio Setup ...................................................................................................................................................27
Train ViaVoice ..............................................................................................................................................27
Set up user options ........................................................................................................................................29
Dictate some text ...........................................................................................................................................30
Correct errors with PlayBack and Computer Speech ...................................................................................31
Voice commands............................................................................................................................................33
Save a speech session to correct later...........................................................................................................34
Add new words to the dictionary...................................................................................................................34
Try an example..............................................................................................................................................35
Check accuracy .............................................................................................................................................36
Finish ............................................................................................................................................................36

After the training session and before the first session with the student you should:..........................................36

iii



Introducing Speech Recognition in Schools IBM ViaVoice v.9 
CALL Centre

STUDENT SESSIONS ....................................................................................................................................... 37

SESSION 1 TRAIN THE PROGRAM.......................................................................................................... 39

In Session 1 the student will learn to: ................................................................................................................ 39
Before the student arrives:............................................................................................................................ 39

Connect the microphone .................................................................................................................................... 39
Start ViaVoice ................................................................................................................................................... 39
Demonstrate ViaVoice....................................................................................................................................... 39
Create a new user speech file............................................................................................................................. 40
Microphone and Audio Setup............................................................................................................................ 41

Adjust the microphone volume...................................................................................................................... 41
Train ViaVoice to recognise the user�s voice..................................................................................................... 42

Helping the student get through training ...................................................................................................... 44
Switch to test user ......................................................................................................................................... 46

Finish ................................................................................................................................................................. 46
Homework Story 1............................................................................................................................................. 47

SESSION 2 DICTATE AND CORRECT ..................................................................................................... 51

In Session 2 the student will learn to: ................................................................................................................ 51
Review............................................................................................................................................................... 51
Start ViaVoice ................................................................................................................................................... 51
Set up the ViaVoice Options ............................................................................................................................. 52
Set up the font and size for the student, and save it as a blank page.................................................................. 53
Turn the Microphone on and off........................................................................................................................ 53
Dictate Words and Phrases ................................................................................................................................ 54
Use Playback to listen to what was said ............................................................................................................ 55
Correct errors..................................................................................................................................................... 55

Correcting without the Correction Box......................................................................................................... 56
Problems reading the correction box list ........................................................................................................... 57
Practise dictation................................................................................................................................................ 58
Recap ................................................................................................................................................................. 58
Start Homework Story 2 .................................................................................................................................... 58
Finish ................................................................................................................................................................. 58
Homework Story 2............................................................................................................................................. 59

SESSION 3 VOICE COMMANDS................................................................................................................ 65

In Session 3 the student will learn to: ................................................................................................................ 65
Review............................................................................................................................................................... 65
Get Started ......................................................................................................................................................... 65
Dictate and correct errors................................................................................................................................... 65
Voice commands ............................................................................................................................................... 67
The Attention Word........................................................................................................................................... 68
�Scratch That� .................................................................................................................................................... 68
Recap ................................................................................................................................................................. 68
Homework Story 2............................................................................................................................................. 68
Finish ................................................................................................................................................................. 68

SESSION 4 USE �BEGIN READING� TO READ BACK DICTATED TEXT......................................... 69

In Session 4 the student will learn to: ................................................................................................................ 69
Review............................................................................................................................................................... 69
Dictate and correct............................................................................................................................................. 69
Use computer speech for proof-reading............................................................................................................. 70
Dictate dialogue................................................................................................................................................. 71
Recap ................................................................................................................................................................. 72
Homework Story 2............................................................................................................................................. 72
Back up voice files ............................................................................................................................................ 72
Finish ................................................................................................................................................................. 72

iv



Introducing Speech Recognition in Schools IBM ViaVoice v.9 
CALL Centre

SESSION 5 VOICE COMMANDS, COMPOSING AND DICTATING TEXT........................................73

In Session 5 the student will learn to: ................................................................................................................73
Review ...............................................................................................................................................................73
Get started ..........................................................................................................................................................73
Format text with voice .......................................................................................................................................73
Plan, compose, dictate and correct text ..............................................................................................................74
Save speech session ...........................................................................................................................................74
Use voice to move around the document ...........................................................................................................75
Use voice to Playback and Read Back ...............................................................................................................75
Use voice to control the mouse and programs ...................................................................................................76
Add a new word to the dictionary 76
Recap .................................................................................................................................................................77
Finish .................................................................................................................................................................77

SESSION 6 READING AND DICTATING ..................................................................................................79

In Session 6 the student will learn to: ................................................................................................................79
Review ...............................................................................................................................................................79
Get started ..........................................................................................................................................................79
Load the speech session .....................................................................................................................................79
Use text to speech to read and then dictate answers...........................................................................................80
More dictation....................................................................................................................................................81
Finish .................................................................................................................................................................81

SESSION 7 ADAPTING THE VOCABULARY ..........................................................................................83

In Session 7 the student will learn to: ................................................................................................................83
Review ...............................................................................................................................................................83
Get started ..........................................................................................................................................................83
Analyse documents ............................................................................................................................................83
Comprehension activity - use speech output to read questions, and then dictate the answers ...........................85
Recap .................................................................................................................................................................86
If you have time�. ............................................................................................................................................86
Finish .................................................................................................................................................................86

SESSION 8 DICTATE A REPORT...............................................................................................................87

In Session 8 the student will learn to: ................................................................................................................87
Review ...............................................................................................................................................................87
Get started ..........................................................................................................................................................87
The Road Accident.............................................................................................................................................87
Read and dictate text ..........................................................................................................................................89
Correct errors by voice.......................................................................................................................................89
More comprehension practice ............................................................................................................................89
Prepare for Session 9..........................................................................................................................................90
Finish .................................................................................................................................................................91

SESSION 9 DICTATE SCHOOL WORK ....................................................................................................93

In Session 9 the student will learn to: ................................................................................................................93
Review ...............................................................................................................................................................93
Get started ..........................................................................................................................................................93
Dictating numbers ..............................................................................................................................................93
Preparation for dictating an exercise..................................................................................................................94
Activity ..............................................................................................................................................................94
Prepare another activity for Session 10..............................................................................................................94
Finish .................................................................................................................................................................94

SESSION 10 PLAN USING SPEECH RECOGNITION FOR SCHOOL WORK.................................95

In Session 10 the student will: ...........................................................................................................................95
Review ...............................................................................................................................................................95
Complete the exercise from Session 9� ...........................................................................................................95
Or start another one�........................................................................................................................................95
Check accuracy ..................................................................................................................................................95

v



Introducing Speech Recognition in Schools IBM ViaVoice v.9 
CALL Centre

Switch off the Attention Word Required ........................................................................................................... 96
Plan how you will use speech recognition from now on ................................................................................... 96

APPENDICES .................................................................................................................................................. 97

APPENDIX 1 DICTATING DIRECTLY INTO OTHER APPLICATIONS........................................... 99

Scanning worksheets into the computer ............................................................................................................ 99
Dictating into Email......................................................................................................................................... 100
Dictating into other applications...................................................................................................................... 101

Dictate directly ........................................................................................................................................... 101
Transferring dictation to another application ............................................................................................ 102

APPENDIX 2 TECHNICAL ISSUES......................................................................................................... 103

Poor audio quality............................................................................................................................................ 103
Sound Recorder ............................................................................................................................................... 104
Poor accuracy .................................................................................................................................................. 104
Problems getting through training ................................................................................................................... 105
Network issues................................................................................................................................................. 106
Transferring voice files between computers .................................................................................................... 106

APPENDIX 3 RESOURCES AND SUPPLIERS....................................................................................... 107

Hardware and software .................................................................................................................................... 107
Suppliers .......................................................................................................................................................... 108
Web sites ......................................................................................................................................................... 109
Books, articles and papers ............................................................................................................................... 110

vi



Introducing Speech Recognition in Schools IBM ViaVoice v.9 
CALL Centre Introduction

About the Pack 
This Pack is designed to help teachers and parents teach young people with 
special educational needs to use the IBM ViaVoice Pro 9 speech recognition 
program. Speech recognition has been presented as the latest �panacea� for 

people with dyslexia and other writing difficulties. 
Some students have used speech recognition 
systems successfully for their work and for exams,
and the use of this technology has helped them to 
overcome their difficulties and go on to higher 
education (see the references in Appendix 3). 
However, there have been other students in other 
schools, who have been unsuccessful in using 
speech recognition. 

The aim of the CALL Introducing Speech 
Recognition in Schools project was to investigate best practice in schools where 
speech recognition was being used successfully, and develop and evaluate training 
materials to help other schools get going with speech recognition. 

"For so long they [dyslexic pupils] have 
had to rely on others to scribe for them
that they have begun to despise
themselves and �switch off�. VoiceText
[IBMDictate] allows these pupils to 
respond independently, gives them
control, and gives them the freedom to 
express themselves as others do."

(Elaine Donald, 1998)

This Pack, which came out of the project is not intended to replace the User�s 
Guides that came with the program - which you should read. The pack is different 
from the product guides in that it gives you lessons and instructions for teaching 
students the skills needed to use speech recognition.

The Pack was evaluated by secondary schools in Scotland from November 2000 to 
March 2002, and modified in response to comments from staff and students. We 
chose to focus on Support for Learning Departments in secondary schools, rather 
than special schools or units, because the largest potential group of students in 
Scotland are those with specific learning difficulties in secondary education. 

 For each school, CALL provided:

¶ an initial on-site session to install the software, train staff and discuss which 
students might benefit from being involved in the project; 

¶ the option of a second visit to support staff when starting work with students; 

¶ the resource pack; 

¶ one copy of either IBM ViaVoice Millenium Pro 7, or Dragon NaturallySpeaking
Preferred 4 or 5 (half the schools got ViaVoice, the other NaturallySpeaking); 

¶ one high quality TalkMic or Plantronics microphone; 

¶ support by telephone and email.

Each school identified: 

¶ one PC capable of running the speech recognition program, in a suitable 
location (for example, a Learning Support base or other place which was 
readily accessible to students when they needed to use the system);

¶ a lead member of staff to co-ordinate the project; 

¶ up to three students to participate in the project. 

7



Introducing Speech Recognition in Schools IBM ViaVoice v.9 
CALL Centre Introduction

Following the first training session, the teacher(s) looked through the ten Training 
Sessions in the Pack and practised the exercises in each session to become 
confident with the system and the training. Once they had become familiar with the 
program and the training pack they had the option to contact CALL to arrange a 
second half-day training day. On this visit, we helped the staff go through the first 
Session with the student and attempted to resolve any problems or issues that had 
arisen with the program or its use in school. At the end of the project we asked staff 
and students to complete an evaluation form. Some of the comments and results 
from the evaluations are given here, and the full report is on the CD that 
accompanies the Pack.

Feedback on the Pack 
We asked staff to rate the support provided by CALL, and the Training Pack.

The responses show 
that the Pack was well 
received, but that the 
initial training was just 
as important. If you are 
intending to introduce 
speech recognition in 
your school, you should 
try and obtain training 
from a supplier or a 
centre like CALL before
you start.
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The most common suggestion for improvements was for a pack that students could 
work through independently, because the training was staff intensive. We have 
responded to this by including Student Tutorial sheets in the CD that comes with 
the Pack, but these should be used with caution: you are unlikely to be successful 
unless you put time into learning how to use the program and working with the 
student.
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How to use the Pack 
1. Attend a training course on the topic, or ideally arrange in-service training on site 

in your school from a supplier or organisation like CALL (see Appendix 3). 

2. Find a suitable computer in a suitable location (see What sort of computer is 
needed? later) and install the program. 

3. Learn to use the program by working through the Teacher�s Tutorial.

4. Look through the ten Sessions so you don�t experience any surprises when you 
start work with a student. 

5. Identify a small number of students (we suggest 3) to work with. 

6. Purchase extra microphones (see Microphones below) so that each student has 
their own. 

7. Set up a folder for each pupil on the speech recognition computer, and copy the 
contents of the ViaVoice Training Files folder from the Introducing Speech 
Recognition CD to the student's folder.

8. Obtain a loose-leaf folder for each student, to collect printouts of work.

9. Arrange a timetable for the training sessions, and for the student to have access to 
the computer for independent practice sessions. 

10.Prepare the resources that you will need for the sessions. For example, you may 
want to look on the CD and: 

¶ print out Student Tutorial sheets for each session;

¶ print and laminate the ViaVoice Quick Guides and stick them on the wall 
beside the computer;

¶ print out the ViaVoice Training Scripts so the student can practise reading them 
before starting training. 

11.Work through the sessions with the student. 

12.At the end of the sessions review progress with the student. Discuss: 

¶ whether the student will use speech recognition for school work from now on; 

¶ for which subjects the student will use speech recognition; 

¶ where the student will work � learning support base, library, ICT suite, 
classrooms;

¶ where / how the student will obtain printouts of work; 

¶ whether the student will use speech recognition for homework � if a laptop 
computer is used, can the student take it home; or is there a home computer 
that can be used (some students in the project commented that it was very 
helpful to be able to practise dictation at home); 

13. If the student needs access to speech recognition in several locations around the 
school:

¶ speak to the network or ICT coordinator or technician to discuss how the 
program can be made available on different computers. Remember you will 

9
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need multiple licences to install it on several machines. Also note that the 
program saves the user�s voice file on the desktop computer, not the server, so 
you will need to devise a procedure to copy voice files between computers; 

¶ or buy laptop computers. 

How long does it take to do the training? 
The training comprises ten Sessions, and each Session will generally be 
completed in about 50 minutes. However, it depends on the skills and abilities of 
the student and staff � some students will get through the exercises very quickly, 
while others will take a long time. The training sessions could be timetabled once 
or twice per week, or once a day. Feedback from schools suggests that students 

also benefit from extra time 
themselves to consolidate 
their learning and practise 
dictation, so you should 
plan for this.

The time to complete each session can vary a lot depending on 
the reading and ICT skills of the student.

One teacher said it took two 40 minute sessions to do Session 1: 

�For today, it was enough for him to learn to use the headset,
set the microphone and then adjust the levels. It has whet his
appetite without exhausting himself�. Boosting Mark�s self 
esteem is an important factor in this project, �it was therefore a 
pleasure for me to see him enjoy this lesson so much. It�s the 
first time that he has properly �engaged� with a lesson for a long 
time.�

Whereas another teacher reported:

�Training took 5 minutes. All key tasks completed.�

A few students found that 
they did not necessarily 
need to complete all 10
sessions � they did 8 or 9 
and felt they were 
confident enough to start 
using speech recognition 
for school work.

Ideally, a member of staff should work one-to-one with a student, and the pack was 
originally written assuming this arrangement. Many of the teachers who evaluated 
the training pack reported they did not have time for one-to-one sessions with 
pupils, and asked if we could produce instructions so that the students could work 
through the training themselves. Therefore, the instructions for each session are in 
two forms: this Pack has the more detailed master instructions for the trainer, and 
there are also shorter ViaVoice Student Tutorial sheets on the Introducing Speech 
Recognition in Schools CD. You should not just copy the student tutorials, hand 
them to the student and leave them to get on with it � success is unlikely unless the 
student is a good reader, has considerable ICT skills, and is highly motivated! 

If you do not have time to work on a one-to-one basis, you could train the student 
during small group teaching in a Support for Learning base. You would prepare the 
session and resources according to the instructions in the pack, start the student 
off, and leave them to work through the Student Tutorial, checking on progress 
every ten minutes or so. 

Alternatively, train a teaching assistant or another member of staff who does have 
one-to-one time allocated with the student by working through the Teacher�s 
Tutorial with them. Or, another student who already uses speech recognition may 
be able to tutor the novice student through the sessions.

The training should be done in a relatively quiet room - not so much because of the 
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speech recognition, which will work with some background noise - but because you 
need peace to work with the student. The average classroom is not the best place
to learn to use a speech recognition system (but once you have learned it, you can 
use it in the class). The microphones and software can filter out much background 
noise, but sudden, loud noises will be misrecognised as speech attempts, resulting 
in extra words appearing on screen. The distraction caused to the rest of the class 
by one person sitting dictating into a computer may be a bigger problem than 
background noise. The best place to practise in a school is usually a learning 
support base, or a quiet alcove within the library.

Once the training sessions are complete, and the student can use the system well 
(we hope!), it may be introduced and used in a subject classroom. 

At the end of the ten sessions, the student should be able to use speech 
recognition effectively to complete learning tasks. After training, close supervision 
may not be necessary all the time, but support should be available, if required. This 
obviously has management and timetabling implications for the school. 

Which students might benefit from using speech 
recognition?

A simple question to which there is no simple answer!

The best way to answer it is for you to work through the Teacher�s Tutorial and 
learn to use the program yourself, then think about the students in your school and 
their skills, the difficulties they face, and then answer the question yourself. 

Speech recognition can be useful for people with physical access difficulties (e.g. 
repetitive strain injury, arthritis, high spinal injury) that make writing difficult. It can 
also be effective for students with reading, writing or spelling difficulties (e.g. 
dyslexia) and for those with visual impairment. There are no �tests� that can predict 
whether a student will succeed with speech recognition � the only way to find out is 
to try it - but experience and reports indicate that success is most likely with 
students with:

¶ good oral communication skills; 

¶ word processing and IT skills; 

¶ high motivation to learn to use the system. 

The references in Appendix 3 list some research reports and case studies about 
speech recognition. The papers by Elaine Donald, Miles, Martin & Owen, Malcolm 
Litten, the BECTa reports and the Supporting Writing with Speech recognition
information sheet (on the Introducing Speech Recognition in Schools CD) give a lot 
of useful information.

Before starting work with the speech recognition program on the CALL project, we 
asked staff to score student skills, on a scale from �poor� to �excellent�, with respect 
to an �average� pupil. The chart below gives the average scores for the students, 
with separate bars for those who did and did not intend to continue using speech 
recognition, having tried it. The small numbers involved mean that the scores are 
not statistically significant, but they do illustrate some useful points for discussion. 
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WRITING

READING

SPELLING

ORAL SKILLS

OVERALL ACADEMIC ABILITY

PERSEVERANCE

ABILITY TO WORK INDEPENDENTLY

MOTIVATION TO WRITE

MOTIVATION TO USE SR

ICT SKILLS

SR SKILLS

12

ExcellentAveragePoor Fair Good

Students who will continue to use SRStudents who won't continue to use

Average of student abilities, scored by staff

(Based on scores for 17 pupils who intend to continue with speech recognition and 3 who do not)

Word processing and IT skills 
The students had �average� IT skills: clearly, it helps if students have some 
understanding of word processing, editing and file management before they start to 
use speech recognition (or any other ICT tool) for recording work. 

Motivation
Motivation to use speech recognition tended to be �good� or �excellent�, and there 
was little difference between successful and unsuccessful students: in fact, the 
latter were said to be more motivated. Learning to use speech recognition is hard 
work, and can be very frustrating, so you and the student need to be prepared to 
put in a lot of effort to get useful results.

Perseverance and ability to work independently 
Staff chose students with whom to work with above-average perseverance and 
ability to work independently. 

Oral communication 
To use speech recognition, a student must be able to: 

¶ think of what they want to say; 
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¶ compose their thoughts into written English sentences; 

¶ speak reasonably clearly. 

If a student has severe learning difficulties, and is not able to compose and speak 
clearly, speech recognition is unlikely to be successful. In our sample, those who 
were successful tended to have slightly better oral skills than those who were not
successful. Several staff noted that students who were already skilled at using 
dictaphones found it easier to compose text before dictating to ViaVoice. 

Reading and literacy skills
All the students had reading, spelling and writing skills which were worse than 
average � hence their reason for evaluating speech recognition. Those who were 
successful had slightly better reading skills than those who were not. It is generally 
agreed that it helps if the student has some reading, or at least word recognition, 
skills. This is because the programs will always make mistakes, and so to write 
independently, the student must be able to spot the mistakes and correct them.

Having said that, students who are poor readers do use speech recognition 
successfully. ViaVoice Preferred has a text-to-speech facility to read back the text 
that has been dictated; or a specialist speech output program like Keystone 
ScreenSpeaker or TextHelp can be used; or the writer can get help from staff or 
other students to proof read and correct errors. It may be harder for a poor reader 
to be successful with speech recognition than a good reader but poor readers may 
well be more motivated to persevere than other students because they have few 
alternatives.

Handwritten:

Dictated and then sent by email�..

�I really like the IBM program. I think it will help me a lot. To do my work in the class/es. I would like to 
use it in all my subjects at the Academy. I was surprised because I did not think a computer could
listen and learn so easily. I was very surprised when the words I was saying came up on the screen. I 
thought it was really excellent.�

Scott, age 12, reading age 8 years 3 months

13
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What support is needed? 
Results from the CALL and other projects shows that the success or otherwise of 
introducing speech recognition in schools depends as much on school and staff 
resources, as on the skills of the individual student:

The BECTa project suggests that success depends on the �Three T�s� � the right 
Technology, sufficient Time, and suitable Training. Time is a major factor in 

achieving success with 
speech recognition. We 
asked staff to record how
often they worked with the 
student on speech 
recognition, and the table 
shows the results.  It is 
clear that those students 
who say they will continue 
to use speech recognition 
had more frequent practice.

A simple interpretation is that if you practise once a week or more you are more 
than twice as likely to be successful, compared with practising less often. Of 
course, other factors will have an effect on success � for example, 3 of the 8 
students who decided not to use speech recognition gave up after 4 or fewer 
sessions because they found accuracy was so poor. Nevertheless, there is no 
doubt that students will require regular practice to become successful with speech 
recognition. This may mean that the student�s (or staff member�s) timetable has to 
be altered while he or she is learning to use speech recognition, or that the student 
is given preferential access to a computer. 

% who won�t
continue

% who will
continue

Every day 0% 0%
A few times per week 13% 26%
Once a week 25% 65%
Less than once a week 63% 9%

Frequency of practice of students who will and won�t
continue with speech recognition

(Based on 23 students who will use SR and 8 who will not)

We asked staff involved in the CALL project to say whether the student intended to 
use speech recognition for school work � this seemed to us to be the best measure 
of �success�. Of the 32 evaluations that we received: 

¶ 23 (72%) students intended to continue using speech recognition; 

¶ 1 (3%) was not sure; 

¶ 8 (25%) did not intend to continue. 

The reasons given were: 

Reasons for not continuing to use speech recognition:

§ 

§ 

§ 

�Feeling that this project did not meet the pupil's needs fully. Have investigated other software
which has improved writing skills and motivation.� [Boy, S2, IBM ViaVoice 4, Pentium II, 64 MB]

�The speech recognition was too unpredictable: sometimes good, sometimes poor. Her final 
session was in conditions more like what would normally happen and it did not work properly.
However she now uses an HP Jornada for computer access and finds this beneficial.� [Girl, S4,
muscular atrophy, using IBM ViaVoice 4, Pentium 4, 128 MB RAM]

�Found it difficult and time consuming to produce accurate results. He preferred using his 
laptop. Pupil had difficulty speaking clearly and slowly enough for the system to give an
accurate response. He got easily frustrated and often needed a break because of an illness and
did not wish to continue with the training.� [Boy, S2, specific learning difficulties, using IBM 
ViaVoice 5] 

14
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¶ �Pupil felt the laptop was of more benefit to him and more convenient as he could use it in any
room and did not have to come to the support base to complete writing tasks. It was difficult to 
identify time from the S3 curriculum for training, particularly as the pupil gets frustrated by the
number of attempts needed to correct the numerous errors made.� [Boy, S3, specific learning 
difficulties, using IBM ViaVoice 5] 

¶ �Only one lesson completed. A change of timetable meant I lost the free period I was using. Her 
visits to the base no longer suited the use of the PC.�  [Girl, S1, learning difficulties, using IBM 
ViaVoice 5] 

¶ �It is not helping him at all. He would rather word process than continue with the package. Only
completed 3 sessions due to his speech: it was not a successful program. (He is a poor speaker,
heavy accent, lots of pauses, comments during lessons etc).� [Boy, S4, cerebral palsy, using IBM 
ViaVoice 5] 

¶ �We have had problems with the program but also with the computer on which it was installed.
Unfortunately it is out of commission at present and being repaired. Great difficulty with program�s
accuracy which led to frustration on part of pupil. 4 lessons completed but with very limited
success.� [Boy, S1, specific learning difficulties, using IBM ViaVoice] 

¶ "School not appropriate. Pupil now working on another computer program. If the program worked,
home would be the best place for pupils to use this. An individual room in school is not often 
available. Computer kept crashing and was networked - less flexibility and the pupil was self 
conscious about others hearing him.� [Boy, S2, dyslexic, using IBM ViaVoice, Celeron, 64 MB]

One significant point is that 6 of the 8 said that having 
trialled speech recognition, they preferred to use a 
word processor or other program (such as a word 
predictor). This underlines the fact that speech 
recognition is just another writing tool, which suits 
some, but not all writers. 

�I prefer to type as I make fewer
mistakes than when I dictate. 
Although I cannot use all the 
words I know or would like to use. 
I think I would need to still practis
a lot more before I got any go

e
od.�

Student

Other possible reasons for lack of success, apart from time, which we discussed
earlier, are the technology (i.e. the program or the computer), and the skills of the 
student.

Six of the eight pupils who will not continue used Dragon NaturallySpeaking, which 
might suggest that it is less effective than ViaVoice. In fact, we do not believe this 
to be the case � the numbers are too small to be significant (8 students in 6 
schools, 4 of which used NaturallySpeaking and 2 of which used ViaVoice).
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What do students use speech recognition for? 
We asked staff and students to say why they intended to continue using speech 
recognition, and for what subjects and learning tasks. The most common reasons 
to use speech recognition were: the speed at which text could be produced; the 
legibility and spelling accuracy; and independence. Students generally intended to 
use speech recognition for longer pieces of work in English or for projects and 
reports.

Some reasons to continue to use speech recognition:

§ 

§ 

�Only way to produce work that can be read. Whenever extended writing is required.� [Boy, S2,
dyslexic, using ViaVoice 4]

�To assist with redrafting long pieces of text - typing slow - spell check difficult. Use in mainly
English.� [Boy, S5, dyslexic, using IBM ViaVoice]

¶ �Poor speller. Any extended writing but mainly for Standard Grade folio work.� [Boy, S2, dyslexic,
using IBM ViaVoice]

¶ �Best way to produce work which can be read easily. As many [subjects] as possible where
extended writing is required.� [Boy, S1, dyslexic, using ViaVoice 5]

¶ �It is definitely the solution to his learning difficulties. English and subjects where there is 
extended writing requirements.� [Boy, S2, dyspraxic & very poor spelling, using IBM ViaVoice]

¶ �Will continue because it should speed up writing and increase independence from scribe.� [Boy,
S3, spastic diplegia, poor handwriting, using IBM ViaVoice]

¶ �To facilitate speed of output: handwriting is slow, keyboarding faster, but not as fast as speech
recognition. Initially to be used for extended pieces of writing in English.� [Boy, S2, dyspraxic,
laboured handwriting and erratic spelling, using ViaVoice 5, Celeron 600, 64 MB]

Can young children use speech recognition? 
Speech recognition programs are designed for adult voices and so young 
children�s voices may be pitched too high to work well. Having said that, Rosemary 
Savison and Lindy Springett (Savison & Springett, 2002) reported children aged 
nine using the programs successfully. If in doubt, try going through the initial 
training � when my daughters aged seven and ten tried it the program did not 
recognise anything at all in the initial training.

What happens if a student�s voice changes? 
Some students report that the accuracy of the programs 
dropped drastically if they had a cold, or if their voice 
changed � due to voice breaking, for example. In these 
cases, there is no option but to retrain the voice file again or 
to start again with a new one. 

�It was all right for a start
but then it got bugging
because it stopped
recognising my voice.�

Student (after his voice
broke)
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Can the program understand strong local accents? 
Sometimes! It is designed for standard British English,
and accents do not cause too many problems provided 
your speech is still clear and distinct. Local dialects are a 
different matter � if words are spoken in a quite different 
way to �standard� English (e.g. �fit� for �what�, �ken� for 
�know�) then ViaVoice will not recognise the words 
unless you correct and train them individually.

�Iain has a heavy accent and 
his speech is not the clearest.
He tends to speak quickly with
lots of extra words �Oh! Eh? 
No? Whit? etc�. This confused
the package.

Teacher (Aberdeenshire)

Will using speech recognition make students lazy and 
less able to write or type? 

No � in fact, the opposite is often the case. In a ten-week trial of IBM Simply 
Speaking with eleven children (Miles, Martin & Owen 1998), the reading age of the 
pupils increased by an average of 13.4 months (British Ability Scales Reading 
Test) and the average spelling age by 6.1 months (Schonell test).

With this in mind, we asked staff to test reading and spelling before and after going 
through the CALL speech recognition training. We also asked staff to estimate how 
student�s skills had changed, and the chart below gives the scores averaged 
across all the students. 

 WRITING QUANTITY

WRITING QUALITY

SR DICTATION QUANTITY

SR DICTATION QUALITY

READING

SPELLING

ORAL SKILLS

PERSEVERENCE

ABILIY TO WORK INDEPENDENTLY

 MOTIVATION TO WRITE

MOTIVATION TO USE SR

KEYBOARD SKILLS

ICT SKILLS

SR SKILLS

Pupils who will continue with SRPupils who won't continue wit

Worse No change
Significant

improvement
Moderate

improvement
Slight improvement

Mean changes in abilities reported by staff
 (Based on 17 pupils who intend to continue with speech recognition and 6 who do not)
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Most students who intend to continue with speech recognition were reported as 
having improved in all areas. The biggest changes were in skills and motivation to 
use speech recognition itself. There were also increases in writing, spelling and 
reading skills but staff did not report the dramatic improvements in reading and 
spelling recorded by Miles and his colleagues. Only four staff actually tested five 
students� reading and spelling directly before and after the speech recognition 
training and the results were patchy: some students showed no change, while 
others showed huge improvement (e.g. 3.6 years Reading age improvement, over 
4 months; 2 years Reading Age improvement over 10 weeks; 2 years Spelling age 
improvement over 4 months.) The project report on the CD gives full details of 
these scores. 

Most of the students who did not find speech recognition useful reported no change 
or a slight improvement across the range of skills, although several had less 
motivation to use speech recognition, as would be expected.

Which speech recognition program is best? 
Windows

We generally recommend either IBM ViaVoice Pro, or IBM NaturallySpeaking
Preferred. The older Dragon Dictate (a �discrete� program where you dictate one 
word at a time, with a pause between each word) is still available and may be 
appropriate for people who have speech difficulties, or those with learning 
difficulties who find it helpful to concentrate on speaking and correcting one word at 
a time. 

The final Resource Packs were written for ViaVoice Pro version 9, and 
NaturallySpeaking version 5, but by the time you read this there will probably be 
newer versions of both available. Much of the Pack will still be relevant for new 
versions but you may find that the program menus and functions are in different 
places. See www.dyslexic.com for a good up to date comparison of the current 
programs that are available. If you have very old versions of the programs (i.e. pre 
1999), bin them and buy new ones - the new versions are much more accurate and 
easier to train and use. The exception to this is Dragon Dictate, which although old 
still has an application for users who have less clear speech.

In education generally, NaturallySpeaking seems to be more popular than 
ViaVoice, but we do not think there is much difference between them. In fact, when 
we look at the �success rate� of students in the project, ViaVoice is better.

Number of students who intend to continue with Speech Recognition, or not

Yes No Not sure Success rate 

Dragon NaturallySpeaking 11 6 1 61 %

ViaVoice 12 2 86 %

The other factors involved (student and staff skills, computer specifications, time 
spent using the software, etc) may mean that these figures are not representative. 
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A better comparison is given in the chart below, which shows the average scores 
scale from �Poor� to �Excellent� given by staff for the programs.

Reliability Enrolment Accuracy Correction Overall

Naturally SpeakingViaVoice

Excellent

Good

Average

Poor

Fair

Average ratings, from staff, of the speech recognition programs

NaturallySpeaking was rated by 16 staff, ViaVoice by 12 

Overall, both programs were regarded as being very similar. ViaVoice was rated as 
slightly more reliable, whereas the NaturallySpeaking initial training (which can 
mean reading 51 sentences if you have a fast computer, as opposed to 70 for 
ViaVoice) and method of correction are slightly easier. 

MacOS
Two of the schools used IBM ViaVoice Millenium Pro USB on Apple Macs and 
found it effective. ViaVoice is the best program for the Mac at the time of writing in 
June 2002, and versions are available for MacOS 9.1 or MacOS X. Make sure you 
get the version with the USB microphone - the cheaper version with an ordinary 
mic often has problems with some Mac sound systems. A version of the Pack for 
ViaVoice for Mac is on the Introducing Speech Recognition CD. The Mac OS 9 
version is not as flexible as the PC version � you can only dictate into the 
SpeakPad word processor, not into AppleWorks, or email programs, for example. 
The OS X version can be used to dictate into other applications, and is claimed to 
be more accurate.

Where should I buy a speech recognition program? 
We recommend you buy the software from a specialist such as iANSYST or Words 
Worldwide, as their expertise and after sales support are much better than mail 
order or high street retailers. See Appendix 3 for addresses. 
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What sort of computer is needed? 
ViaVoice Version 9 runs on a computer with: 

OS: Windows 98 SE, 2000, Windows XP. 

Processor: Pentium 300 with MMX or equivalent (e.g. Celeron, Pentium II/III, 
AMD K6-2/3, Athlon etc).

Ideally you want a Pentium III or 4; 500 MHz or faster. 

RAM: IBM say 64 MB for Win 98, 96 MB for Win 2000, and 192 MB for Win 
XP but you really want to add at least 64 MB to these specs. In 
general, the more RAM you have, the faster and more accurate the 
program will be, so it�s worth putting in as much as you can � 512 MB 
or more is good. 

USB mic: USB port for microphone, or use a standard mic and sound card

Sound card: If you are not using the USB mic, you will need a 16 bit Creative Labs
Soundblaster compatible sound card.

Hard disc: 510 MB free. 

CD: CD-ROM drive.

We asked the schools involved in the project to give details of the computers they 
used, and there was a very wide range, from 2 year old Celerons to a 6 month old 
Pentium 4. The processor or amount of RAM actually appeared to make no 
difference to the success or otherwise of the speech recognition: for example, one 
school reported great success (including being able to use the �short� training on 
NaturallySpeaking) with a Celeron 300 and 64 MB of RAM � the bare minimum for 
running the program. It is generally agreed, though, that your chances of a 
satisfactory experience with speech recognition are higher if you use a Pentium III 
or better and 128 MB or (preferably a lot) more. 

Can the program work on a networked computer? 
Ç You can install the program on a computer on a network, but it is less

straightforward than installing on a standalone computer not attached to the 
network.

Ç The standard ViaVoice program does not work when installed on a network server 
- it must be installed on the workstation computer itself. IBM sell an �Enterprise� 
version for networks � contact IBM or the suppliers in Appendix 3 to see if it would
work on your network. 

Ç Many schools have computers running Windows 98, which are controlled and 
administered by a server running Windows NT. The NT server system stores files, 
presents a specified desktop and may restrict access to the Control Panels, for 
example, so that students cannot change settings or install programs.

Ç You must ask your network administrator to install ViaVoice on a computer 
connected to this sort of network. Different networks need different tweaks, but 
you will need to set the user�s permissions in the profile so that: 
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¶ the user can write to the C drive (the program does this when it updates the 
user's speech data); 

¶ the MS-DOS prompt is enabled (ViaVoice executes some DOS programs when 
it is running). 

While it is generally easier to install the program on a standalone machine that is 
not part of the managed network, it does defeat the purpose of a network 
somewhat � clearly, it is much better if students can access the work they have 
dictated anywhere on the network. It would also be better if the ViaVoice program 
itself could be accessed from any networked computer, or at least on several 
specified machines. 

Microphones and Soundcards 
Speech recognition requires a high quality sound input signal, which means a good 
quality microphone and soundcard in the computer. The microphone supplied with 
ViaVoice is satisfactory, but we recommend the better TalkMic mics from 
iANSYST. These are high performance microphones and are also light, 
comfortable and stable to wear. It is very difficult to give hard and fast advice about 
microphones because the models change so often, and because some types seem 
to work better with some computers than others. For example, one school thought 
the TalkMics were too flimsy, bought bigger, chunkier headset microphones from a 
high street computer shop for £10 each, and found they were perfectly satisfactory.

Do you REALLY want to do this? 
The CALL project, and the others we have listed in Appendix 3, have shown that 
successful introducing of speech recognition needs a lot of time, energy and 
commitment from teaching staff, management, parents and, especially, the 
student. It also requires access to a suitable computer. 

If this cannot be provided, then it may be better to consider some of the 
alternatives, such as the use of a computer, word predictor, typing, or tape 
recorder.

Still interested? Then read on�.. 
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Teacher�s Tutorial 

Work through this tutorial before you start training the student.

You will need: 
Ç A reasonable knowledge of the Windows operating system 

Ç To be able to use and adjust the basic multi-media functions of Windows � Sound 
Recorder, microphone and speaker volume settings 

Ç A basic knowledge of word processing: creating, editing, printing, loading and 
saving files. 

In this tutorial you will learn how to: 
Ç Install the program on the computer 

Ç Start the program 

Ç Create a user voice file 

Ç Adjust the microphone settings 

Ç Train a voice file 

Ç Set up the ViaVoice Options 

Ç Dictate, Playback and correct

Ç Use Speech Output for proof reading 

Ç Use voice commands 

Ç Add new words to the ViaVoice dictionary 

Ç Save and load documents

Ç Use ViaVoice to complete a sample comprehension exercise 
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Install the program 
If your machine is networked, you will need to ask the technician or administrator to 
install the program. He or she will have to log on as the administrator, and make 
adjustments so that ViaVoice can write to the hard disc. 

If you have a standalone machine, there should be no problem. 

If you have a laptop computer, power it from the mains while you install and train 
the program. 

1. Read the chapter 1 in the ViaVoice User�s Guide, on installing ViaVoice.

2. Create a folder for �Speech Recognition� in the �My Documents� folder.

3. Copy all the ViaVoice files from the CALL Introducing Speech Recognition in 
Schools CD to the Speech Recognition folder. 

4. Read the ReadMe file on the ViaVoice CD � it has lots of information on installing 
and configuring ViaVoice,  e.g. for different sound cards

5. Put the CD into the drive, and run the setup program to install the program.

6. We suggest you choose the following options when installing:

¶ Don�t tick Add VoiceCentre to the Startup menu

¶ Don�t tick Install MS Office support (unless you are sure you want to use 
Office � it is faster and easier to use the ViaVoice word 
processor, which can save files in Word format) 

¶ Do tick Run product registration

Get started 
Ç Plug in the USB microphone.  Windows will ask you if you want to install software 

for it: click Next until the software is installed.

Ç Load ViaVoice (unless it has already started): Click Start > Programs > IBM 
ViaVoice-UK English > VoiceCentre

1. If you are the first person to use the program
on that particular computer, follow the User 
Wizard instructions and the ViaVoice User�s 
Guide. Instructions for setting up the
microphone are provided on-screen. The first 
thing you need to do is to create a user voice 
file.

2. Type in a name for the user voice file.

3. Click Next.

4. Select the �Microphone plug via USB adapter� if
you are using the recommended USB mic.

5. Put on the microphone and adjust it so it is 
about 2 cm away from your mouth, and slightly 

to one side.

6. Click Next.
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Audio Setup
Ç ViaVoice will now adjust the volume settings for the mic, and check the sound 

quality.

1. Click on Start and read the 
paragraph. (Note you don�t have to 
read the text shown � say anything 
as long as it is in your normal voice.) 

2. When the computer has adjusted 
the volume it will beep. 

3. If it does not beep, check that the 
mic is plugged in and adjusted
correctly, or try another microphone. 
Then look at the trouble shooting
section in Appendix 1. 

4. Click Next.

5. If the quality is poor, try: 

¶ speaking slightly louder and more clearly; 

¶ moving the mic closer or further away; 

¶ a different mic; 

¶ using the Sound Recorder to check the sound (Appendix 1) 

¶ clicking on the Fixing Poor Audio Quality button for more help, and see Appendix 1 in 
this Pack.

Train ViaVoice 
Before you start, switch off any screen savers, plug the mains adapter in if you 
have a laptop, and switch off any power saver features. 

1. Click Start and read the paragraph
on screen. You should see the text 
turn from black to grey as ViaVoice 
listens to your voice. 

2. If ViaVoice does not understand you, 
the program will beep and indicate 
where you should start reading.
Click Pause, wait for the program to 
calm down, and then click Start, and
read the sentence again. Wait for 
the text to turn grey, then carry on 
with the next sentence. 

3. Click Next.
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ViaVoice training stories.

1. Choose a story to read. 

2. Click OK.

Reading the Training story 

1. The text to be read is shown on screen, and as the program recognises the
speech, the words change from black to grey.

2. Click Start, read the first phrase 
or short sentence, and then wait 
for the text to turn grey before 
carrying on with the next phrase. 
Once you get into the swing of 
it, you can dictate more text 
without pausing. 

3. Dictate a few words or a phrase 
at a time, rather than speaking
individual words and pausing
between each word. 

4. If the program doesn�t seem to 
recognise anything, click 
Pause, and start again by
reading the first few words. 
Make a conscious effort to 
speak clearly, and wait until the 
text turns grey before 

continuing.

5. When the student does the training you can click on Pause after each phrase or 
sentence, to stop recording, so the student can practise reading the next one. You can
even pause to practise every word if necessary - but the training will take a long time if
you do! Although you can speak each word one at a time, it is better to say short phrases 
if you can.

6. If the student has problems reading the text, you can whisper it to them, or Pause
and have them practise it before clicking Resume.

7. You can make he story text larger and easier to read by clicking on the buttons
just above �Cancel�. This also means you see fewer words on each screen, so it 
will easier for students with reading difficulties to read.

8. If you stutter, or say a word wrongly, ViaVoice will beep and mark the 
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unrecognised word blue. You should repeat the word until it is recognised. If you 
get stuck on a word, and it refuses to turn grey, click Pause, wait for the computer 
to stop beeping, then Resume, and try again. 

9. Stop and have a rest at least three or four times during training to relax and have a 
sip of water.

10. A good feature of ViaVoice is that you can stop the enrolment at any time - 
ViaVoice will remember how far you have got, and you can carry on from the same 
place later. If you run out of time and need to stop the training, click on the Cancel
button, and then click Yes to save the voice file made so far. 

11. To resume the training the next session, use ViaVoice Options to select the 
student's voice model, and then choose the training story, and you will be able to 
carry on from where you left off. 

Once you have finished reading the text the computer will analyse the recording
and create the voice model.

Ç Document Analyser 

ViaVoice will ask if you want to run the Dcument Analyser. We will do this later - click Next.

Set up user options
¶ Once ViaVoice has started up, click on the ViaVoice button in the top left hand corner.

¶ Select User Options > ViaVoice Options

¶ In the User tab, click on the arrow at the end of Vocabulary  to choose a �base� 
vocabulary (see p. 100 in the User�s Guide). If you have more than 96 MB and a 
processor faster than 300 MHz, choose the �Maximum Accuracy� vocabulary. Otherwise 
choose the �Fast Vocabulary�. Click Apply.

Click here to open the ViaVoice menu
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¶ Click At Startup and tick Toggle Microphone so that you can use the F12 key to switch 
the mic on and off. 

¶ Click on Dictation and tick Attention Word Required, Auto find new words and
Improve my voice model. Click OK

Dictate some text 
Ç Open the SpeakPad ViaVoice word processor 

Click on ViaVoice > Dictate to > SpeakPad 

As soon as the SpeakPad starts up, the mic will be switched on � switch it off 
immediately

Ç Turn off the mic 

Press the F12 key or click the mic button at the top left of the ViaVoice toolbar.

Ç Think of a few sentences. Then switch the mic on, and dictate. Remember that 
you have to dictate the punctuation by saying �full stop�, �comma�, etc. 

Press the F12 key or click the mic button at the top left of the ViaVoice toolbar.

Say  �My name is ����, �Today is ���.�, �I am talking to this computer.� 

Ç Notice that ViaVoice can handle context and grammar 

Dictate �I can hear music. Here is a new way of writing. There were two teachers with
their computers.� 

Ç Turn off the mic 

Press the F12 key or click the mic button

Dictation procedure

¶ Get comfortable, sit up straight, and breathe deeply so you can speak clearly.

¶ Make sure the mic is switched off. 

¶ Compose (and if necessary practise) your sentence. 

¶ Switch the mic on. 

¶ Don�t mutter, sigh, sniff, say �ummm�, �er� etc before you start the sentence � 
the computer will pick these up.

¶ Speak the phrase or sentence clearly, with a comma or full stop. Use a 
"dictating voice", speaking slightly more slowly and carefully than you would 
for conversation. Try to speak like a newscaster � you can speak with an 
accent, but you must be clear and distinct. Avoid running words together, or 
letting your voice tail off at the ends of words and sentences. 

¶ There is often a delay with the first sentence you speak before the words 
appear on screen, so wait until they do before dictating the next sentence. 
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¶ Wait silently until the words appear on screen � don�t say �Ooh look it�s 
great/rubbish/what�s it doing now etc� � it will pick this up. 

¶ Switch the mic off and compose the next piece of dictation. 

¶ Once accuracy improves, you can dictate a paragraph or two before stopping 
to correct mistakes, but at first you should correct each sentence as soon as 
it is dictated. 

Correct errors with PlayBack and Computer Speech 
Ç Make sure that the Correction Window is visible

Click on the Correction button, or press F2 to bring up the Correction Box 

Make sure that Auto-play selected text is on 

Ç Use Playback to hear a recording of the dictated text: 

Double click on a word, or select a word or phrase and a recording of your voice 
should be played back to you. 

Ç Use computer speech for proof-reading and correcting 

Select the text to be read, then click on Dictation > Begin Reading (or press ALT-D,
then B). ViaVoice will read out the text. This is useful for proof reading the dictation 
and checking the text matches what you dictated.

Ç Correct the error 

When ViaVoice makes a recognition error, you must correct it, otherwise ViaVoice
won�t improve its accuracy. There are several ways you can correct recognition errors.
Try them out to see which method you like, and think about which method would suit 
your students best.

1. Select the mis-recognised word or phrase using the mouse. 

2. Dictate the correct word or phrase to replace the error.

3. If that doesn�t work, type the correct text over the error using the keyboard 

4. The best method is to 
use the Correction Box 
to correct errors. Click 
on the Correction 
button or press F2  to 
bring up the Correction
Box.

5. Click on the Playback
(speaker) button to 
hear what you actually 
said.

6. If the correct word or 
phrase is in the list, 
click it to select it. 

7. If the word is not in the 
list, click on the text in 

the Correction Box and type the correct text in. Note that ViaVoice predicts words as you
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type each letter, so if you see the word, just click on it. Once the word is completed, press 
Return to correct the word in the SpeakPad. 

8. See Chapter 6 in the ViaVoice User�s Guide for more on correcting errors.

Ç Understand the difference between correction and text revision

With previous versions of ViaVoice you always had to use the Correction Box to 
correct errors because this taught ViaVoice how you spoke � if you just re-typed over 
the text, it would change the text in the document, but ViaVoice would not adapt to 
your voice. 

With the latest ViaVoice version 9 you can correct errors by selecting them and typing
or re-dictating over them in the SpeakPad. When you close the document, ViaVoice 
will scan it for new words and save them to your voice file. This can be faster than 
using the Correction Box but since new words and corrections are not saved until the
end of the dictation session, it�s best to use the Correction Box until the student
achieves good accuracy with ViaVoice.

¶ For the first six or seven sessions, use the Correct Box to correct errors rather
than dictating or re-typing over the mistakes.

¶ Once ViaVoice has been trained and has adapted to the student�s voice, you can 
try selecting errors and dictating over them without using the Correction Box. 

¶ Students with poor spelling should not type over errors to correct them � if they 
misspell a word, ViaVoice will try to add the misspelled word to its dictionary.
Instead, they should use the Correction Box. 

Using the Correction Box helps the student focus on the errors, which is likely to make 
the correction accurate, and will also improve the student�s spelling.

Ç Adjust the correction window, if necessary 

1. Click on ViaVoice > User Options >
ViaVoice Options > Correction, and set 
the number of words to be displayed in 
the Correction Window. Generally we 
recommend a setting of 5, but this can be 
reduced for students with reading 
difficulties.

2. If the words in the box are too small, you
can make them bigger. Right-click
anywhere on the Windows desktop and
then select Properties > Appearance.
Click on the Item arrow and choose 
Menu. Then choose a suitable font and
size. This will not only alter the ViaVoice 
Correction Box, but also all the other 
menus in the PC. 
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Ç Save the document 

Click File > Save

Voice commands
Ç ViaVoice can understand commands as well as text. When you say the 

commands below, run the words together � if you pause between each word 
ViaVoice will probably type the words rather than carry out the command. 

Ç Saying �Computer� lets ViaVoice know you are giving it a command. You can 
choose a different �Attention Word� (e.g. �Command�) by going to ViaVoice > User 
Options > ViaVoice options > Command Sets.

Ç Dictate:

�Computer-Go-to-Top�

�New�Line� �New-Line�

�Computer-Bold-On, Computer-Capitalise-On� 

�Speech recognition training session� 

" Computer-Bold-Off, Computer- Capitalise -Off " 

�Computer-Go-To-Bottom�

�As well as dictating I can also tell the computer what to do [Exclamation Mark]� 

�Computer-Go-To-Sleep�

Ç Say "Go-To-Sleep" to turn the mic off temporarily, and �Wake Up� to wake it up. 

Ç If ViaVoice gets it completely wrong, or if you suddenly splutter, cough or 
otherwise generate a lot of rubbish on screen, say �Scratch That� to delete it. 
Only use Scratch-That when most of the phrase is wrong � if only a word or two
needs corrected, use the Correction Box. 

Ç Use voice to correct errors � say �Computer-Correct word� where word is the 
mis-recognised word. To choose a word from the correction list, say �Pick n�,
where n is the number in the list. 

Ç Use voice to select and edit text. Dictate �Select Speech recognition training 
session�, then �Uppercase-This� to put each word into capitals. �Select tell�
then �instruct� to replace the word tell with instruct.

Ç To print and save the document, dictate: 

�Computer-Print�, OK�

�Computer-Save�

Type the name of the file in, and say �Save�

Ç You can also control programs and the mouse. Dictate: 

�Computer-Start-Program-WordPad� to open the WordPad. 

�Computer-Begin-Voice-Mouse�  to start the �voice mouse� 

�Computer-Move-Up-slowly��.�Faster�..�Stop� to move the mouse up the screen

�Computer-click� to click 

�Computer-End-Voice-Mouse�

"Start-program-Calculator" � the Windows Calculator should open 

33



Introducing Speech Recognition in Schools IBM ViaVoice v.9 
CALL Centre Teacher�s Tutorial

"Four plus five equals" 

"Five hundred and twenty three divided by seven equals" 

"Close-program-Calculator"

Ç Click on ViaVoice > What can I say?, look through and try out some of the 
commands. Remember to say �Computer� before speaking them. 

Ç Review the ViaVoice commands in Chapters 8 and 9 in the User�s Guide. 

Save a speech session to correct later 
Ç Dictate more text, but don't correct any errors 

Ç Save the speech session. When you save a speech session, ViaVoice saves the 
text and also the recording of the dictation, so that you can come back another 
time, open the speech session, and use Playback and Correct to correct any 
errors.

Click File > Save Session, then type a name for the session.

Ç Close SpeakPad, then open it again and open the saved speech session 

File > Open Session 

Ç Correct any errors and save the document. 

Add new words to the dictionary
Ç One word at a time� 

1. Dictate a sentence with an unusual word or rare proper noun (e.g. Muggles,
Dalbeattie, Eminem), and then select and correct it. Type the word into the 
Correction Box and then click on the Tick.

2. ViaVoice will ask you if you want the word added to the dictionary. Click Yes. Click
Record and say the word.

3. Once you have recorded the word, dictate it again to make sure it has been
learned.

4. Check the word is in the dictionary by clicking on ViaVoice > Tools > Manage my
Vocabulary and looking for the new word in the list. 

Ç And from a text file� 

1. Click on ViaVoice > 
Tools > Analyse My
Documents. Click Next
then Find.
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Schools CD. 

3. Click Find. Then select the �Haggis text.txt� file, click Add, then click Close.

4. Click Next, then tick the words you want 
to add to the dictionary. Only choose 
words you are likely to need to dictate.
Click Next.

5. If ViaVoice thinks it needs you to record 
the word, it will offer you the chance next.

6. Click on the Record
button and record
each word in the list. 

7. Click Done, then 
Finish.

Try an example
Ç Open the Haggis questions file from the Speech Recognition folder on your hard 

disc, where you put the files from the Introducing Speech Recognition in Schools
CD.

File > Open > select �Haggis questions� 

Ç Use Begin Reading to read the text and questions 

Select the text to read, then Dictation > Begin Reading.

Move the cursor around by saying �Computer-Go-To-Top�, �Computer-Next-line�,
�Computer-previous-line�.

Select some text and read it by saying �Computer-Begin-Reading�.

Ç Dictate and correct the answers 

Ç Print and save the file under a new name 

Say �Computer-Print�, then �Computer-Save as�
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Check accuracy 
Ç If you have time, start a new document, and then dictate five paragraphs from 

Homework Story 2 at the end of Session 2. Don�t correct any errors. 

Ç Select the errors and mark them (underline, or make them bold) so you will be 
able to count them easily. Copy and paste the text into Microsoft Word, or another 
program that can count words. Click on Tools > Word Count in Word to count the 
number of words. Count the errors and divide by the total number of words to get 
an accuracy score: 

Accuracy = Number of words - Number of errors
                Number of words

Ç For example, if you have 10 errors in 300 words, this gives an accuracy of 96.6%. 

Ç Don�t count unknown words, or proper names as errors if they are not in the 
dictionary; a short phrase with a couple of errors counts as one error; and so does 
a word split into two words. 

Ç Repeat this exercise every so often to monitor accuracy. 

Finish
Ç Close the program down by clicking ViaVoice > Exit ViaVoice.

After the training session and before the first 
session with the student you should: 
Ç Read through Chapters 1 to 4 in the ViaVoice User�s Guide. 

Ç Go through the 10 Sessions and make sure you are able to use the features of 
ViaVoice described in them. 

Ç Create a 'Test' voice model and go through the training process to train the test 
model.

Ç Set up a folder for each pupil on the speech recognition computer, and copy the 
ViaVoice Training Files from the Introducing Speech Recognition CD to the 
student's folder.

Ç Obtain a loose-leaf folder for each student, to collect printouts of work.

Ç Arrange a timetable for the training sessions, and for the student to have access to 
the computer for independent practice sessions. 

Ç Prepare the resources that you will need for the sessions. For example, you may 
want to look on the CD and: 

¶ print out Student Tutorial sheets for each session;

¶ print and laminate the ViaVoice Quick Guides and stick them on the wall 
beside the computer;

¶ print out the ViaVoice Training Scripts so the student can practise reading them 
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before starting training. 

Student Sessions 
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Session 1 Train the program 

In Session 1 the student will learn to: 

Ç Connect and adjust the microphone 

Ç Start up ViaVoice and open his or her voice file 

Ç Train ViaVoice to recognise his or her voice 

Before the student arrives:
Ç Have a paper copy of the Homework Story text available (it�s given at the end of 

this session, and on the CALL Introducing Speech Recognition in Schools CD) 

Ç Depending on the student, it may be a good idea to go through the training text on 
the paper copy, identifying any words that he / she finds difficult 

Connect the microphone 
Show the student how to plug the microphone in to the computer. 

 Start ViaVoice
Ask the student to double click on the ViaVoice icon on the desktop, or click Start > 
Programs > IBM ViaVoice VoiceCentre.

Demonstrate ViaVoice 
Demonstrate ViaVoice to the student by dictating a short piece of text � say, 50 � 
100 words � making any corrections that are necessary at the end of the passage. 
It�s usually best if this text has been practised beforehand, to reduce the likelihood 
of something going seriously wrong! Make sure that the font is big enough for the 
student to read easily.

Discuss the demonstration with the student, trying to find out what their first 
impressions are and whether they think it might help them. Make it clear that you 
are using the computer as a writing tool, not having a conversation with it. This is 
an important point that is worth repeating at regular intervals. The aim of using the 
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system is to produce a piece of written English, not a transcript of a conversation. 
ViaVoice bases part of its recognition process on people speaking in grammatical 
sentences, not the broken phrases typical of conversational English. 

Assuming the student sees the relevance of the system and is willing to give it a 
try, go through the steps involved in creating a new user file, verbally, before 
moving back to the computer. 

Create a new user speech file 
The first time ViaVoice is used, it automatically asks for a speech file to be created. 
Thereafter, it will assume that the same person is always using the system until a 
new user is created.

1. Create a new user file for the student, by clicking on ViaVoice > User Options >
ViaVoice Options.

2. Click User and then Add User.

3. Type in the name of the new user. 

4. Click Next

Click here to open the ViaVoice menu

Hint!
When speech models have been created for more than one person on a 
computer, it is vital that you only use your own speech model. If you use 
another person�s model, not only will the computer be less successful at 
recognising your speech, the other person�s model will be changed, making it 
more difficult for the computer to recognise them the next time they use the 
system.
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Microphone and Audio Setup 
Next, set up the microphone with the student. Consistent positioning of the 
microphone in relation to the user�s mouth is vital for speech recognition. First
position the headset so that it is comfortable and then adjust the position of the 
microphone in relation to your mouth. The microphone should be placed a little to 
the side of the mouth, to reduce interference from �breathing noises�, and about a 
thumb�s width from the lips. This distance can be adjusted slightly, depending on 
the user�s voice level. A quiet speaker will need a smaller distance for best results, 
while a person with a loud voice may want to move the microphone further away. 
Most microphones for speech recognition are �unidirectional�, with the sound signal 
maximised from one direction. The better microphones feature �active noise 
cancellation�, to damp down noise coming from any other direction. It is important 
to make sure that the direction of the best signal (usually indicated by a white or 
red dot on the end of the microphone) is towards the user�s mouth. 

Adjust the microphone volume 
After adjusting the microphone position the student must read some text into the 
machine so that ViaVoice can adjust the microphone volume and check the sound 
quality. The text is shown below, but the user need not read those particular words 
- he or she can say anything provided it is spoken clearly and at a normal volume 
and speed.

Adjusting the Microphone Level

This is a short paragraph that I am reading in my normal relaxed tone of voice. 
I will pause naturally between phrases and sentences. The computer is using 
this to set my audio level. When it has finished, I will hear a short tone and 
the system will show me the audio quality level. I will repeat this paragraph 
until I hear the tone. 

1. Click on Start and read the text. 

2. When the computer has adjusted 
the volume it will beep. 

3. Click Next

4. If it does not beep, check that the 
mic is plugged in and adjusted
correctly, or try another 
microphone.

5. Check the sound by using the 
SoundRecorder (see below). 
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ViaVoice will show the quality of the audio input - if it says the audio is poor quality, 
click on the 'Fix poor audio quality' button to get some advice about improving it. 
Do not carry on with ViaVoice until you have sorted the audio quality out - you will 
be wasting your time. 

Hint!

If the program does not seem to hear or recognise the user, try running the
Sound Recorder. Look in Start > Programs > Accessories > Entertainment > 
Sound Recorder, and adjust the position of the microphone to get the best 
signal, by recording and playing back a few seconds of speech with the 
microphone in different positions, until the recorded signal is strong and clear, 
with no interference. Try also connecting the microphone and recording and 
playing back a few seconds of �silence�. The �playback� should also be silent - 
if the recording has a lot of �hiss�, your sound system is noisy and speech 
recognition may not work very well. Make sure the mic is plugged in securely, 
or try a different microphone. 

Train ViaVoice to recognise the user�s voice 
Train the program in the same room that it will be used, if possible - the systems 
can be sensitive to changes in background acoustics. It�s also a good idea to have 
a little background noise during the training, rather than �perfect silence�. Have a 
radio playing quietly, or a conversation going on across the room.

Before you start, switch off any screen savers, plug the mains adapter in if you 
have a laptop, and switch off any power saver features.

To create the voice model, the user must read out the text shown on the computer 
screen. Have the user practise the text before you start recording. As ViaVoice
recognises the speech, the text will turn grey to indicate the system is working. If 
the user stutters, or misses a word, ViaVoice will make the word blue - if this 
happens, start reading again from the blue word, until the words turn grey.

Creating my Personal Voice Model text 

Speak clearly with a relaxed tone of voice when you dictate. During dictation, 
you must dictate punctuation marks to tell the system where to place them. 
But when you create or improve your personal voice model, you do not need to 
dictate all punctuation marks. 
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1. Click Start and read the 
paragraph

2. The text will turn grey as the 
computer recognises the speech. 

3. If the user has difficulty reading 
the text, click on the 'Pause'
button after each sentence, or 
even every few words. Read the 
text to the user, and have them 
practise it. Then click on 
'Resume' and try the next few 
words or sentence.

ViaVoice will then 'process' the recording to create a basic voice model for the 
user's voice. Before you can start dictating though, you must train the system some 
more. Click on Next and choose a story from the list. The easiest to read is the 
Homework Story. 

1. Choose a story to read. 

2. Click OK.

Before you start training with the student, read the next sections on helping the 
student get through the training. 
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Helping the student get through training 
The Homework Story 1 will take at least 10 minutes to read through - more if the 
student has difficulty with some of the words. 

A printed version of the text is at the end of this section, to give the student an 
opportunity to practise before training.

Before you start training, go over the text with the student and practise any difficult 
words or phrases. You may want to print out the text in a larger font, from the CALL 
Introducing Speech Recognition in Schools CD. 

1. The text to be read is shown on screen, and as the program recognises the
speech, the words change from black to grey.

2. Click Start, read the first
phrase or short sentence, and 
then wait for the text to turn 
grey before carrying on with the 
next phrase. Once you get into 
the swing of it, you can dictate
more text without pausing.

3. The student should follow the 
text with the mouse pointer as it 
is read. 

4. Dictate a few words or a phrase 
at a time, rather than speaking
individual words and pausing
between each word. 

5. If the program doesn�t seem to 
recognise anything, click 
Pause, and start again by

reading the first few words. Make a conscious effort to speak clearly, and wait until the
text turns grey before continuing. 

6. You can click on Pause after each phrase or sentence, to stop recording, so the 
student can practise reading the next one. You can even pause to practise every 
word if necessary - but the training will take a long time if you do! Although you 
can speak each word one at a time, it is better to say short phrases if you can.

7. If the student has problems reading the text, whisper it to them, or Pause and 
have them practise it before clicking Resume.

8. You can make he story text larger and easier to read by clicking on the buttons
just above �Cancel�. This also means you see fewer words on each screen, so it 
will easier for students with reading difficulties to read.

9. If you stutter, or say a word wrongly, ViaVoice will beep and mark the 
unrecognised word blue. You should repeat the word until it is recognised. If you 
get stuck on a word, and it refuses to turn grey, click Pause, wait for the computer 
to stop beeping, then Resume, and try again. 

10. Stop and have a rest at least three or four times during training to relax and have a 
sip of water.

11. A good feature of ViaVoice is that you can stop the enrolment at any time - 
ViaVoice will remember how far you have got, and you can carry on from the same 
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place later. If you run out of time and need to stop the training, click on the Cancel
button, and then click Yes to save the voice file made so far. 

12. To resume the training the next session, use ViaVoice Options to select the 
student's voice model, and then choose the training story, and you will be able to 
carry on from where you left off. 

Hint!
Prolonged dictation can lead to a dry throat so it is a good idea to have a glass 
of water nearby and to take occasional sips. You should train the system with 
your normal voice, not a dry, croaky voice! 

The Homework Story script is on the CD, so you could open it in your word 
processor and print it out with each sentence on a separate line, then ask the 
student to read from the paper rather than the screen. Use the Pause and Resume
buttons and prompt the student when to start and stop speaking. The student could 
use a piece of card to keep the place when reading from the paper. 

You can use TextHelp Read and Write v5 or TextHelp ScreenReader see 
Appendix 3) to speak out the training text if the student has difficulty reading it. This 
works quite well if you set the ViaVoice text size to be as large as possible because 
TextHelp will read the one or two sentences shown, and then the student can 
repeat it. To set TextHelp to read the training text: 

1. Select Speech Options in the TextHelp menu 

2. Choose the Screen Reading tab 

3. Tick �I would like to use Screen Reading�

4. Tick the �Editable text� in the list, and tick both �Read Basic text� and �Read Extra 
Information�

5. Untick the rest of the items in the list, unless you want them to be spoken

6. Move the mouse pointer over the training text, and it should be spoken out

Or, you could load the training text into the ViaVoice window (or into another talking 
word processor, like Write:Outloud, TextEase or First Word). Arrange the word 
processor window beside the training window, and then use the computer speech 
to read the text before dictating it. 

When the training text has been completed, the computer will create a voice file for 
the student. If you have a fast Pentium III or 4 computer this will take a few minutes 
- with a slower machine it may take 20 or 30 minutes. This is a good time to 
conclude the formal part of Session 1.
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Switch to test user 
Before you exit from ViaVoice, use ViaVoice > User Options > ViaVoice Options 
> User to switch to the dummy test user you created before. 

Finish
If you have time at the end of the session click on ViaVoice > Help > Information 
Central and look through the Help files. 

Take a few minutes to discuss how the session went.

Shut down ViaVoice by clicking on ViaVoice > Exit ViaVoice.
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Homework Story 1 
To improve your voice model you should read this text aloud, speaking naturally 
and as clearly as possible, then wait for the next screen to appear. 

We hope you enjoy the story. 

_____________________________________________________

Sam opened his homework diary. 

He had put it off for long enough.

He had traveled home by bus, as usual, and walked Suzy home. 

After that he made himself a snack, checked what was on television and fed 
the cat. 

_____________________________________________________

Now the evil moment had arrived! 

It was Thursday and that meant physics and history. 

They were his two worst subjects. 

He often wondered why he had chosen them.

_____________________________________________________

The History tonight was not too bad, in fact. 

They had been studying life under Queen Victoria. 

_____________________________________________________

The teacher had said, "Put yourself in the place of a child living in the mid-
19th century. You can pretend you come from a rich or poor family. 

Describe a day in your life. This is a chance to really use your imagination."

Sam enjoyed this kind of work. 

_____________________________________________________

He never had a problem with using his imagination and often found that he 
had, without realising it was happening, stopped listening in class. 

He would find himself transported to some strange world, or into the middle 
of some exciting event.

_____________________________________________________

He would always be brought back to earth by the teacher asking him a 
question.

Of course he could not supply the answer. 
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On every school report he had ever had, it said that he needed to learn to
concentrate.

He really did try. 

He couldn't help it if his brain had a mind of its own! 

_____________________________________________________

He wrote a couple of pages, painting a vivid picture of life without electric 
light, or television, or even a proper education unless you were very rich. 

He was pleased with what he had done. 

_____________________________________________________

The spelling might not be brilliant, but at least his account of the daily 
existence of a poor child in London sounded convincing.

It hadn't taken him long either.

He looked at his watch: quarter to five: time for a break. 

_____________________________________________________

Sam went downstairs, poured himself some lemonade and ate the last of the 
chocolate biscuits. 

He sat, thinking that in some ways it might have been fun to be a child in 1850. 

He would be prepared to bet they didn't have physics homework! 

He trudged back up the stairs to his bedroom. 

He switched on his stereo.

He would need some music to help him through this next homework.

_____________________________________________________

In his homework diary he had written Physics, for Friday, answer the following
in detail: 

  1) What is power? 

  2) How is it measured? 

_____________________________________________________

  3) Give examples of different kinds of power used in everyday situations.

"Why do teachers come up with such pointless tasks?" He thought to himself. 

What use could it be to him in later life to be able to define the word power?

_____________________________________________________

48



Introducing Speech Recognition in Schools IBM ViaVoice v.9 
CALL Centre Session 1 Train the program

He got up to get the science encyclopedia, nearly treading on the cat. 

She had draped herself around a chair leg, next to the radiator.

It was March but it felt more like January. 

It was cold and the wind was getting up. 

_____________________________________________________

He could hear it rattling the tiles on the garage.

Although it was only just after five o'clock it had suddenly got very dark. 

He put the light on and took the encyclopedia off the shelf.

_____________________________________________________

Back at his desk, he opened it at page three hundred and twenty four. 

"Power," he read aloud to the cat, "is the rate at which energy is turned from 
one form into another. 

The unit in which it is measured is the Watt." 

_____________________________________________________

(Good! That was the answer to question two) 

"Power is important because almost all the processes in our everyday lives 
involve using energy to do work. 

_____________________________________________________

For example, the power of the engine in a vehicle is the rate at which it can 
turn the chemical energy stored in the fuel into mechanical energy to drive 
the vehicle."

Sam stopped concentrating on the words he was reading. 

_____________________________________________________

His eyes registered them, but his imagination went off on one of its sudden 
voyages.

He seemed to be standing outside a classroom, looking through the glass panel 
of a door. 

He saw himself sitting at a desk. 

_____________________________________________________

Facing him was the physics teacher, Mr. Morgan, with a pencil stuck behind his 
left ear, as usual. 

He was a small man; he strutted around with his head in the air, as if that 
would make him taller. 
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Now his face was bright red and his grey hair was standing up in spikes all over 
his head. 

He looked as if he was about to explode into a thousand little pieces. 

"What is this?" 

_____________________________________________________

He boomed, making the classroom shake. 

Mr. Morgan was holding Sam's homework in his hand. 

Sam looked at what he had written. 

"Power is being able to set stupid homework to students who have to do them. 

It is often exercised by teachers who are small, to make them feel 
important."

Sam laughed out loud and pushed his chair back. The cat yowled.

_____________________________________________________

This, along with the sound of the first raindrops pattering against the window, 
brought him back to reality. 

How he would love to be brave enough to write those words! 

He copied the definition on to the blank page in front of him and sighed.
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Session 2 Dictate and correct 

In Session 2 the student will learn to:

Ç Start ViaVoice and select the correct voice file 

Ç Turn the microphone on and off 

Ç Dictate some text

Ç Use Playback to check dictation 

Ç Correct mis-recognised words 

Ç Understand the difference between correcting dictation and text revision 

Ç Exit from the program

Review
During the first session the student learned about how to position the microphone 
on his / her head and trained the system to recognise his / her voice by dictating a 
number of sentences into the computer. The student's voice model should now be 
good enough to start some dictation - but bear in mind that more training and use 
will be needed to improve the voice model. 

Start ViaVoice
1. Check that the microphone is connected and positioned correctly.

2. Load ViaVoice  by clicking on the desktop icon, or on Start > Programs > IBM 
ViaVoice- UK English > VoiceCentre.

3. Select the student�s voice by opening ViaVoice > User Options > ViaVoice 
Options > User.

Hint!
Be sure to select the correct user's voice file when loading the program. You 
can check the current voice file at any time in ViaVoice by looking in the top
right corner of the ViaVoice Toolbar � the current user will be shown. 
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Hint!
You can make the program easier to load by creating a Shortcut to it on the 
desktop of the computer. This is done by selecting (but not loading) the 
program via the Start menu, as before. Now click with the right button of 
your mouse and select Create Shortcut. A new shortcut link will appear, which 
you can drag onto the desktop of the computer as a new icon.

Set up the ViaVoice Options 
1. Once ViaVoice has started up, click on the ViaVoice button in the top left hand corner.

2. Select User Options > ViaVoice Options

3. In the User tab, click on the arrow at the end of Vocabulary  to choose a �base� 
vocabulary (see p. 100 in the User�s Guide). If you have more than 96 MB and a 
processor faster than 300 MHz, choose the �Maximum Accuracy� vocabulary. Otherwise 
choose the �Fast Vocabulary�. Click Apply.

4. Click At Startup and tick Microphone Off, and Toggle Microphone so that you can use 
the F12 key to switch the mic on and off. 

5. Click on Dictation and tick Attention Word Required, Auto find new words and
Improve my voice model. Click OK

Current voice model Mic on/off ViaVoice menu
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Set up the font and size for the student, and save it 
as a blank page 

¶ Click on ViaVoice > Dictate to > SpeakPad to open the SpeakPad word 
processor

¶ Immediately switch off the mic.

¶ Click on View  and then check that all the toolbars are ticked.

¶ Use the Format Bar to select a suitable font and size that the student can read 
comfortably. Arial, Tahoma or Comic Sans, all size 14 or bigger, are most suitable
for students with reading difficulties. Use a bigger font if the student has a visual 
impairment.

¶ Close the SpeakPad � the next time you open it, you will have the font set by 
default.

¶ Click ViaVoice > Dictate to > SpeakPad

¶ Type in the student's name at the top of the document, then add a few blank lines.

¶ Click on File > Save, to open the Save dialog box. 

¶ Create a new folder for the student�s speech recognition work, by clicking on the 
third button from the right on what looks like the �exploding� folder.

¶ Type in Student's name blank page as the File Name, and click Save.

Show the student how to open this blank document every time they use ViaVoice.

Turn the Microphone on and off 
When using a speech recognition system it is important to be able to switch the 
microphone off quickly: the student may have a question; the teacher may want to 
talk about something that has happened on screen; there may be some 
disturbance in the room. There are three ways to turn the microphone off: 

With the Mouse � Click on the microphone icon on the ViaVoice button bar. This is 
more reliable than turning the microphone off by voice, but is slower than using the 
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keyboard. It means the student gets into the habit of checking that the mic is 
switched off before turning and chatting to other people. 

With the Keyboard �The F12 key can be used to switch the microphone off and 
on. The keyboard is also a better option for students who have difficulty with the 
mouse.

By Voice � The command Computer Microphone Off can be used to turn the 
microphone off � it can then only be turned on by using the keyboard or mouse. 
Use the command Computer Go to Sleep to turn the mic off. Say Computer
Wake Up to turn the microphone on again. We don�t generally recommend this 
method. While it is asleep, the system �listens� for the phrase Wake Up before 
reactivating the microphone. It may misinterpret some other phrase as the Wake
Up call, and will then try to interpret any later speech as dictation, resulting in 
unwanted text appearing on screen. 

Hint!
To start with, click with the mouse or use the keyboard to switch the mic on 
and off, and to look at the mic button to make sure it has not been left on by 
mistake. We recommend that the teacher should control the microphone for 
the first couple of sessions � it gives the student less to worry about! 

Dictate Words and Phrases 

Major Hint! 
It is very important to get into a good �rhythm�  of dictation as quickly as 
possible. When you first start dictating, the routine is: 

1. Sit up straight and make sure you can breathe properly, so you can speak 
clearly.

2. Make sure the mic is switched off. 

3. Compose and practise a sentence. 

4. Switch the mic on. 

5. Don�t mutter, sigh, sniff, say �ummm�, �er� etc before you start the sentence 
� the computer will pick these up.

6. Speak the phrase or sentence clearly, with a comma or full stop. Use a 
"dictating voice", speaking slightly more slowly and carefully than you would 
for conversation. Try to speak like a newcaster � you can speak with an 
accent, but you must be clear and distinct. Avoid running words together, 
or letting your voice tail off at the ends of words and sentences. 
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7. Speak slowly and watch the words as they appear on screen, to try and spot 
errors. This will help you learn a good rhythm and will also help improve
your word recognition and spelling skills. 

8. Wait silently until the words appear on screen � don�t say �Ooh look it�s 
great/rubbish/what�s it doing now etc� � it will pick this up. 

9. Switch the mic off. 

10. Play back and correct the errors for the sentence.

Once accuracy improves, you can dictate a paragraph or two before stopping to 
correct mistakes, but at first you should correct each sentence as soon as it is 
dictated.

Turn the microphone on and ask the student to dictate the following: 

My name is....(student name) [FULL STOP] [NEWLINE] 

Today is... (day of the week) [FULL STOP] [NEWLINE] 

This is the first time that I have spoken to a computer [FULL STOP] 
[NEWLINE]

Turn off the microphone. 

Use Playback to listen to what was said
Now turn off the microphone and review the text with the student. You can �play 
back� a recording of what the student actually said and compare it to the text, to 
check accuracy. 

1. Use the mouse to highlight a word, phrase or sentence you need to check.

2. Click on Dictation > Playback, or press ALT-D, then P.

 Correct errors 
If there are no mis-recognised words so far, ask the student to dictate a few more 
sentences until the computer makes a mistake. Explain that the program will often 
mis-hear and type the wrong word, so we have to correct it so that it understands 
the student�s speech properly. 

1. Use Playback to listen to the recording of the dictation, to find any mis-recognised
words.

2. Click the Correction button on the SpeakPad or press F2 on the keyboard to bring 
up the Correction Box.

3. To correct a single word, just click once on the word and it will appear in the 
Correction Box along with a list of alternatives. If two words are incorrect, highlight
them both. 

4. When the words appear in the Correction Box, they will be played back. If they are 
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not played back, tick Auto-Play selected text.

5. See if the desired word is in the list. If it is, select it with the mouse. If the word is 
not offered, type it in. Note that ViaVoice predicts words as you type each letter, so 
if you see the word, just click on it. Once the word is completed, press Return to 
correct the word in the SpeakPad. 

6. If the word is correct, but you want to capitalise the first letter or change the case, 
click on the Format button. 

7. Save the document (File > Save) as StudentsNameSession2

When the misrecognitions have been corrected and trained, ask the student to 
repeat the dictated text. The results should be better the second time. 

Correcting without the Correction Box
With previous versions of ViaVoice you always had to use the Correction Box to 
correct errors because this taught ViaVoice how you spoke � if you just re-typed 
over the text, it would change the text in the document, but ViaVoice would not
adapt to your voice. 

With the latest ViaVoice version 9 you can correct errors by selecting them and 
typing or re-dictating over them in the SpeakPad. When you close the document, 
ViaVoice will scan it for new words and save them to your voice file. This can be 
faster than using the Correction Box but is does not actually alter your speech files 
until the end of the dictation session. This means that it is best to use the 
Correction Box at least until the student achieves good accuracy with ViaVoice. For 
the first six or seven sessions, use the Correct Box to correct errors rather than 
dictating or re-typing over the mistakes. 

Once ViaVoice has been trained and has adapted to the student�s voice, you can 
try selecting errors and dictating over them without using the Correction Box. 

Students with poor spelling should not type over errors to correct them � if they 
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misspell a word, ViaVoice will try to add the misspelled word to its dictionary. 
Instead, they should use the Correction Box. 

Using the Correction Box also helps the student focus on the errors, which is likely 
to make the correction more accurate, and will also improve the student�s spelling. 

Major Hint! 
Explain to the student that it is very important to correct mis-recognised 
words - if you don't, ViaVoice will probably make the same mistake the next 
time. Until the student has fully trained ViaVoice and achieved good accuracy,
recognitions errors MUST be corrected with the Correction Box - do not just 
type over or delete mistakes with the keyboard as this does not improve
accuracy until the end of the dictation session. See Chapter 6 in the ViaVoice 
User�s Guide for more on correcting errors. 

Problems reading the correction box list 
If the student has difficulty spotting the correct word in the correction window, you 
can make the words larger. To do this, go to the Start Menu and select Start > 
Control Panels and open up Display. Click on Appearance. Under Item, select
Menu, and then make set font size to the size you want - 14, for example. Click on 
Apply, and the text in the ViaVoice Correction Window will be set to that size. 
(Note that this will also set the menus on the computer to be the same size, which 
may or may not be what you want.) 

Adjust the Menu font and size�.  �.to make the correction box easier to read 

You can also change the number of words in the Correction Box: click Dictation > 
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Correction Options in the SpeakPad menu. 

TextHelp Read and Write or ScreenReader can speak out the words in the 
Correction Box, if the student has difficulty reading them. Set up TextHelp to read 
�list items� (see the instructions on adjusting TextHelp in Session 1). 

Practise dictation 
Ask the student to dictate a few paragraphs from a piece of writing they have 
previously handwritten or typed. Or, dictate new work using sentence starters, such 
as �Last weekend I...�, Next weekend I will..�, "My favourite band / team / 
book / is �". Encourage the student to think about what he / she wants to say and 
to practise it with the microphone off, before turning the microphone on and starting 
to dictate. It can also be helpful for the student to write the text out by hand before 
they start to dictate. Discuss the student�s initial feelings about using speech 
recognition and see if he or she is willing to dictate a couple of sentences to 
describe how they feel. Remember to correct and train any misrecognised words 
and to dictate all the punctuation. 

Recap
Ask the student to dictate what they have learned this session � for example �I can 
dictate by speaking clearly�.I must always fix mistakes by using the 
Correction window�.

Print and save again.

Start Homework Story 2 
Open ViaVoice Options > User and click on Add/Modify, make sure you have a 
Voice Model selected, and click Next twice. Select Homework Story 2 from the list. 
Do the first third of the training (or more if you have time). Read through the text at 
the end of this session and practise any difficult words or sentences before you 
start. Click Cancel to stop, and then Yes to save the voice file.

Finish
Change to the Test User. Close the program: click ViaVoice > Exit ViaVoice.
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Homework Story 2 

Half past five, another half an hour to go until mum came home to get tea. 

_____________________________________________________

However, if he could finish this physics he would be able to watch the football 
game on television and get to level ten on his new computer game, before he 
had a shower and went to bed. 

He walked over to the window to pull the curtains, negotiating his way between 
books, tapes, shoes and sports kit. 

_____________________________________________________

It was quite dark now and the rain was almost horizontal. 

He heard the first rumble of thunder.

He supposed he had better walk around the house to get inspiration for the 
last question: examples of power used in everyday situations.

_____________________________________________________

Then it happened! A deafening clap of thunder right overhead made him jump. 

The cat raced for a hiding place under his bed, its fur sticking out in terror. 

Click! The light went out. 

_____________________________________________________

The rap song that had been playing was replaced with the sound of persistent 
rain.

All the familiar sounds of the house died. 

Sam waited for a few moments. 

Surely the power would come back on. 

_____________________________________________________

Usually these power cuts didn't last very long. 

It was so quiet apart from the rain, the crashing of the thunder and the 
howling of the wind. 

_____________________________________________________

It was so dark apart from the flashes of lightning, which sent a violent white 
light streaking across the room. 

At least the Victorians would have had candles, or gas lamps!

Sam got up and started to feel his way across the room. 
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He stumbled on the shoes he had left lying on the floor. 

He groped his way to the bedside table. 

His torch was not there. He cursed. 

He was certain he had left it on the table, beside his clock. 

_____________________________________________________

Where was it? 

It crossed his mind that perhaps he should have tidied his room when his
mother had told him for the 10th time that it was a tip and refused to vacuum 
it any more. 

But it was too late now. 

_____________________________________________________

He felt under the bed. His fingers caught hold of something. 

The cat screeched angrily as she moved her tail from his grasp. 

He hurtled back in terror, hitting his head on the underneath of his desk. 

_____________________________________________________

Eventually his searching fingers found the shape of the torch. 

He felt a little more secure now. What should he do?

Any minute now the room would be flooded with light and life would return to 
normal.

_____________________________________________________

In the meantime he would just go downstairs and make another snack. 

He'd finished the biscuits, but there was some bread. 

He remembered that it was old and dry; his mother would bring a fresh loaf
home with her. 

_____________________________________________________

He could toast it though. Oh no he couldn't! The power was off. 

Well then, he'd sit and keep warm and listen to the radio. 

Another stupid idea. The radio wasn't going to work either and the radiators 
would gradually be losing their heat now. 

_____________________________________________________

He found a thick jumper amongst the jumble of clothes at the end of his bed. 

Better to be prepared! 
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He wondered how long the torch batteries would last. 

He knew he had some spares, but where?

_____________________________________________________

He didn't think he could face searching for them with only the fading light of 
a small torch.

It would be rather like trying to pick out a friend in a World Cup football
crowd.

He thought about his plans for the evening.

_____________________________________________________

Tea - the cooker was electric. 

Television - well, that was a non-starter! 

A shower - only standing outside in the garden. 

Computer games - think again! 

_____________________________________________________

Sam had a sudden inspiration - he would phone Suzy.

Maybe her part of the town had not been plunged back into the early days of 
Queen Victoria!

With the light of the torch getting dimmer, Sam walked back downstairs. 

_____________________________________________________

The phone was not on its hook. Oh no! 

He had called Jack before school this morning. 

Then the phone had already been in his bedroom, because Suzy had phoned 
late last night to tell him about a party on Saturday.

_____________________________________________________

Eventually he found the phone, on the floor, under a pair of dirty jeans. 

He pressed "talk", feeling relieved that he could do something to break the 
dark silence. 

Nothing happened. It was quite dead. 

_____________________________________________________

Guiltily he realised that it had not been charged for nearly 24 hours. 

His mum would kill him! He could just see her face. 

She would give him one of those looks which made unwanted callers beat a 
hasty retreat to the front gate. 
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He and his father usually went scurrying to the garage to do something they 
had just realised they had left unfinished! 

Sam sat down. 

The cat, who had followed him downstairs and up again, had just chosen the 
same bit of bed. 

_____________________________________________________

It just wasn't her day!

He heard the car pull up outside and the sound of the key in the front door. 

_____________________________________________________

He moved quickly going to greet his mother via the living room, where he 
popped the phone back praying the power would come back on before she 
realised what had happened. 

"Sam, why on earth are you sitting around in the dark?" 

_____________________________________________________

Sometimes parents were very stupid!

"There's been a power cut mum," he replied patiently. 

"Have you tried the trip switch?" 

Sam was glad it was dark. 

_____________________________________________________

He felt the blush spread across his face. 

It had simply not occurred to him. What a fool! 

"Well, I thought I'd just try to soak up a bit of atmosphere to help me write
about life in early Victorian times," he lied. 

_____________________________________________________

His mother had already groped her way to the kitchen cupboard, reached up 
and flicked on the trip switch. 

Light and sound filled the house. 

_____________________________________________________

The fridge resumed its normal humming, the clock ticked and the local news on 
the radio, which Sam had put on when he'd first come home, started telling 
them about the effect of the severe storms in the South of England. 

The telephone began to recharge, silently.

_____________________________________________________
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"I'll just give your father a ring," his mother was saying.

"I'm late home, so I'll ask him to pick up fish and chips for supper." 

"Don't bother mum," Sam replied quickly. 

_____________________________________________________

"Sam, is something wrong?" said his mother in that half warning tone he knew 
so well. 

She had just reached the phone and picked it up.

_____________________________________________________

Sam called, "I'll just get back upstairs and finish my physics," as he and the 
cat took the stairs two at a time. 

They could feel the look that followed them. 

They didn't need to turn round! 

_____________________________________________________

Sam did not rate his chances of getting to watch the football very highly now. 

Oh well! There was still the computer game. 

And at least he had some answers for the last part of his physics homework!
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Session 3 Voice Commands 

In Session 3 the student will learn to: 

Ç Use voice to control basic functions in IBMPad 

Ç Use �Scratch That� 

Review
In the last session the student started dictation, learned to play back recorded 
speech, and corrected mis-recognised words with the keyboard. In this session, we 
do more dictation, show how to correct errors in more detail and introduce voice
commands.

Get Started 
1. Put the microphone on. 

2. Start up ViaVoice and select the student�s voice file.

3. Open the Student'sname2 file from last session.

4. Repeat the first three sentences dictated last session to make sure the system is 
working properly and the mic is in the correct position. If accuracy is poor, check 
mic position and try again. Correct any errors and save the file.

5. Switch the mic off. 

Dictate and correct errors 
6. Open the StudentsNameBlank file and fill in the date and number of the session. 

7. Switch off the microphone and  ask the student to practise the text below before 
dictating.

8. Switch the mic on and dictate: 
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My name is....(student name) [FULL-STOP] [NEWLINE] 

Today is... (day of the week) [FULL-STOP] [NEWLINE] 

This is the second time that I have spoken to a computer [FULL-STOP] 
[NEWLINE]

The program should be getting better at listening to my voice [FULL-STOP]
[NEWLINE]

Switch the mic off, and show the student again how to open the Correction Window 
and click on a word to correct it. Help the student to correct any mis-recognised
words.

Save the work as StudentsNameSession3.

Switch the mic on and ask the student to dictate the text below. Remind the student 
to say the punctuation. Don't correct any errors yet. 

It is important for you to know how to speak to this computer [FULL-STOP]
[NEW-LINE]

Each word should be spoken clearly to get the best accuracy [FULL-STOP] 
[NEW-LINE]

Try not to stutter and be careful not to breathe too loudly into the 
microphone [FULL-STOP] [NEW-LINE] 

Imagine that you are talking to someone who does not understand the language 
very well [FULL-STOP] [NEW-LINE]

Try not to confuse your computer too much [EXCLAMATION-MARK] [NEW-
LINE]

Talking too quickly makes it hard to keep up with the dictation [FULL-STOP] 
You also tend to slur your words [FULL-STOP] [NEW-LINE] 

 A good thing about speech recognition is that you never make spelling 
mistakes. [FULL-STOP] [NEW-LINE]

Switch the mic off. Select the text, copy it (press CTRL-C) and then paste it (CTRL-
v) so you have two copies. 

Working on the first copy, select the errors and mark them (underline, or make 
them bold) so you will be able to count them easily. Count the errors, subtract from 
the total number of words (108), and divide by the total number of words to get an 
accuracy score: 

        Accuracy = (108 - No. of errors)
            108 
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For example, if you have 10 errrors in the 108 words above, you have an accuracy 
of 90.7%. 
Count a short phrase with a couple of errors as one error; count a word split into 
two words as a single error. 

Type the accuracy score below the first copy of the text.

Now go through the second copy of the dictation with the student to correct any 
errors. Ask the student to point out the errors and the corrections. Give them help if 
necessary.

Save the file again. 

Close the SpeakPad 

Voice commands 
Explain that ViaVoice can understand dictation, for writing, and also commands,

for controlling the computer. To give ViaVoice a 
command, you say "Computer do this", "Computer
do that", etc.  When you say the command, run the 
words together otherwise ViaVoice may type them 
rather than carry out the action. Commands can 
control menus and buttons on the computer, and 
move the cursor or mouse around the screen. Some 
students find it great fun to tell the computer what to 

do, while others aren�t interested or have difficulty getting ViaVoice to understand 
commands. Have a go � if it doesn�t work or seem useful, don�t spend too much 
time on it. You will use more voice commands in Session 5. 

A good lesson � M. was well
impressed with commanding the 
computer to do tasks. He 
thought it was cool to be able to 
name the file. He liked the 
exclamation marks!!

Teacher

Ask the student to switch the mic on and then dictate: 

[COMPUTER-DICTATE-TO-SPEAKPAD]

[COMPUTER-OPEN ]and open the StudentsNameSession3 file

[COMPUTER-PRINT] then [OK] to print the file again. 

[COMPUTER-FILE] then [SAVE-AS] then [COMPUTER-DICTATE-DIRECTLY]

Now dictate a name for the file into the box � e.g. test document and say 
[COMPUTER-STOP-DIRECT-DICTATION] [SAVE] 

1. Switch the mic off. 

2. Click on ViaVoice > What can I say and browse through the commands to show 
the student what can be done with voice. Say that we will use some of the 
commands in later sessions.

3. Point out that the commands are also listed in the ViaVoice Command Reference
card.

4. If ViaVoice consistently fails to recognise a command, train it by clicking on
ViaVoice > What can I say?. Find the command in the list, double click on it, and 
then record your pronounciation of the command into the computer.
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The Attention Word 
At the start you set ViaVoice so you must say the �Attention Word� before each 
command, which makes it less likely that it will type commands when it should 
carry them out, and vice versa. If you want to actually type the word �computer�, 
pause slightly after you say the word. You can choose to use a different attention 
word by clicking on the Command Sets tab in the ViaVoice Options. You can also 
tell ViaVoice that you don�t want to say the attention word at all � click on the 
Dictation tab in the ViaVoice Options and untick Attention Word Required. We don�t 
recommend this until after the student has learned to use ViaVoice, as it can be 
confusing if the computer tries to perform odd commands rather than typing words. 

�Scratch That� 
Sometimes the program gets commands or dictation completely wrong and types a 
complete load of rubbish on screen. Rather than correcting the whole lot, it may be 
quicker to say �Computer-Scratch-That�, which deletes the last thing typed.

1. Ask the student to dictate a short sentence quickly and to slur their words. 

2. Say "Computer-Scratch-That". The sentence will be deleted.

3. Dictate the sentence properly again. 

Recap
Dictate a few sentences about what you have learned this session, about voice 
commands and Scratch That. Save the file. 

Homework Story 2 
Do the next third of Homework Story 2 and save the changes to the voice file. 

Finish
Change to the Test User. Exit from the program and remove and store the 
microphone.
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Session 4 Use �Begin Reading� to 
read back dictated text 

In Session 4 the student will learn to:

Ç Use computer speech for proof-reading and correcting 

Ç Back up the voice file 

After the session ask the student to bring along a favourite poster or magazine 
article to the next session, to use to practise dictation 

Review
In Session 3 you practised more dictation, the student started to correct errors, and 
also learned some voice commands. This session, we will continue with more 
dictation and show how the ViaVoice 'Begin Reading' command can be used for 
reading back the dictated text. 

Dictate and correct
Ask the student to connect the microphone, start ViaVoice, select their voice 
model, switch the mic on, and say "Computer-Dictate-to-SpeakPad". Switch the 
mic off. 

Practise, then dictate the text below.

Speech recognition training session 4 [NEW PARAGRAPH]

Name [COLON] student's name [NEW PARAGRAPH] 

Tom didn�t like writing [FULL STOP] [NEW-LINE] 

Whenever he picked up a pen his hand seemed to shake and the marks he made 
on the page never quite matched the ideas that were in his head [FULL STOP] 
[NEW-LINE]

It was so frustrating [EXCLAMATION MARK] [NEW-LINE]

Switch the mic off, and work with the student to correct errors. 
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Use computer speech for proof-reading 

Carry on dictating the text below:

Even when he tried to take a lot of time to produce his best handwriting 
people said that his spelling was atrocious [FULL STOP]

He had seen adverts on television for a speech recognition system [FULL 
STOP]

People talked into the computer and words would appear on the screen [FULL 
STOP]

It looked very impressive [COMMA] but there must be a catch [FULL STOP] 

Switch the mic off. Talk about the importance of correcting mis-recognised words 
again, and say that ViaVoice can speak out the text to help you find the mistakes. 
Explain the difference between the actual recording, which can be played back,
and the dictated text, which is read back. 

Switch the mic off. Talk about the importance of correcting mis-recognised words 
again, and say that ViaVoice can speak out the text to help you find the mistakes. 
Explain the difference between the actual recording, which can be played back
and the dictated text, which is read back. 

1. Highlight the text the student has just dictated, and then select Dictation > Begin 
Reading, or press Alt-D, then B. The �agent� will appear and read out the text. 
Click on the Pause button under the agent to pause after each sentence, or the 
red Stop button to stop.
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2. If you want to hear a particular word or sentence, highlight it and select Begin
Reading again. Ask the student to highlight each new sentence in turn and use 
the speech to listen to and find errors. Use Playback and Begin Reading to listen 
to what was dictated, and what was actually typed. Then use the Correction 
Window to fix any errors.

3. Once all the errors have been corrected, ask the student to say "Computer-
Print", and print the file.

4. Then say "Computer-Save" and save the file as Student'sname4A.

Begin Reading can be a very useful tool for students with poor reading skills 
because it can help them check the text and spot errors. Encourage the student to 
get into a routine of dictating, then reading back, then correcting, after every 
sentence or two. As accuracy increases, the student can dictate more sentences 
before correcting. 

Speech output programs like TextHelp Read and Write (see Appendix 2) are also 
worth investigating if the student is a poor reader. TextHelp Read and Write has a 
bigger range of speech facilities and the voice can be changed. 

Dictate dialogue 
When you dictate a story to the computer, you will need to use inverted commas to 
mark the words that are spoken by the characters in the story. Try dictating the 
following:

Scott put on the microphone and started the computer [FULL STOP] He 
clicked on the speech recognition program [COMMA] and made sure his voice 
file was loaded [FULL STOP]  He switched on the microphone and started to 
dictate [FULL STOP, NEW LINE] 

Suddenly the door opened and his little brother came in [FULL STOP] 

[OPEN QUOTE] What are you doing [QUESTION MARK] [CLOSE QUOTE] 
said his brother [FULL STOP] 

[OPEN QUOTE] Scram [COMMA] you wee pain [CLOSE QUOTE] said Scott 
[COMMA] in his usual brotherly manner [FULL STOP]

But he had forgotten to switch the microphone off and when he looked back at 
the computer he saw that it had typed [OPEN QUOTE] Scramble you read the 
[CLOSE QUOTE] [FULL STOP] 

[OPEN QUOTE] Now look what you�ve made me do [EXCLAMATION MARK] 
[CLOSE QUOTE] he shouted [FULL STOP] [OPEN BRACKET] And the 
computer typed [OPEN QUOTE] There equate mainly due [CLOSE QUOTE] on 
the screen.

His brother looked at the expression on Scott�s face and vanished [FULL 
STOP]
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Homework Story 2 
Complete the last part of the Homework story training.

Tell ViaVoice to process the voice file. 

Back up voice files 
Now that the student has spent time and effort creating a voice file, it is a good idea 
to back it up so that there is a copy in case anything happens to the working 
version.

Click Dictation > Dictation options > User and then click Backup user. ViaVoice 
will create a backup of the voice file. 

If the student�s own voice file gets damaged � for example, if a session goes badly 
and the changes get saved accidentally, or if someone else uses the voice file by 
mistake, the backup can be restored by clicking on Restore User.

Recap
Dictate the things that you have learned this session: about reading the text, using 
punctuation, training commands, and backing up your voice file. Save the file. 

Finish
Change to the Test User and exit from the program. Ask the student to bring a 
poster or picture from a magazine to the next session to practise dictation. 
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Session 5 Voice commands, composing 
and dictating text

In Session 5 the student will learn to:

Ç Move around the text and format with voice

Ç Control the mouse 

Ç Add a new word to the dictionary

Ç Plan, compose, dictate and correct text

Review
Last session you practised dictation and correction with 'Begin Reading' to help 
read back the dictated text. This session you will do some more dictation, add new 
words to the dictionary, and learn new voice commands. 

Get started 
Put on the microphone, start ViaVoice and open the blank page. 

Format text with voice 
Switch the mic on, and ask the student to start SpeakPad and open the blank page 
document. Dictate: 

COMPUTER-SELECT-ALL

COMPUTER-DELETE

This will delete the text in the blank document. Then dictate: 

COMPUTER-BOLD-ON, COMPUTER-UPPERCASE-ON

Speech recognition training session 5 [NEW PARAGRAPH] 

73



Introducing Speech Recognition in Schools IBM ViaVoice v.9 
CALL Centre Session 5  Compose and dictate

COMPUTER-BOLD-OFF, COMPUTER-UPPERCASE OFF 

Name [colon] student's name [NEW PARAGRAPH] 

As well as dictating I can also tell the computer what to do [EXCLAMATION 
MARK]�

COMPUTER-GO-TO-SLEEP

Hint!
Speak the command words together without a pause � say �Computer-bold-
on�� if you pause between each word, the program may type them on screen, 
instead of carrying out the command. If ViaVoice types your command instead
of performing it, say "Computer-Scratch-that" and the text will be deleted. 
Repeat the command.

Warn the student to avoid using Scratch-that  all the time. If only a few
errors are made in the sentence it is much better to correct them with the 
Correction Box, than delete the whole thing with "scratch-that". Use Scratch
That where more or less the whole phrase or sentence is messed up. 

Click on Help > Help Topics > Dictation > Edit and Format text with your voice to
see how other formatting can be done with voice. See Appendix B in the ViaVoice 
User�s Guide, and also the ViaVoice Command Reference Card. 

Plan, compose, dictate and correct text 
This session we will go through the process of planning, composing and dictating a 
new piece of work. 

Switch the mic off and discuss the poster or picture in a newspaper or magazine 
with the student. Talk about the elements that make up the poster or picture. 

Then switch the mic on, and ask the student to describe what's happening, using 
ViaVoice. Try to produce a few paragraphs of four or five sentences each.

Highlight each sentence in turn, and use Playback to listen to the dictation, and 
Begin Reading to what ViaVoice actually typed.

Don't correct any errors. If there are no errors, carry on dictating until the 
computer makes some. You will save the recording, and then correct the errors in 
Session 6.

Save speech session 
Switch the mic off and explain that you will save the text, and also the playback
recording of the speech, so you can correct any mistakes the next session. 
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The Save Session facility is very useful because a student can get on with dictation 
without worrying about having to correct any errors. Meanwhile, the teacher can be 
working with another pupil. At the end of the lesson, the student can save the 
complete recording of what they said. Then later the student and/or teacher can 
load the session and go through it, using Playback to listen to the dictation, and 
correct the errors.

Once you have finished dictating, say: 

[COMPUTER-FILE]

[SAVE SESSION]

[COMPUTER-DICTATE-DIRECTLY]

Now dictate the name of the file into the box -Student'sName5.

[COMPUTER-STOP-DIRECT-DICTATION]

[SAVE]

Hint!
Saving complete recordings of speech sessions takes up a lot of space on the 
hard disc - approximately 750 kb for every minute of dictation. Once you have 
finished with a speech session recording, delete it from the hard disc to free 
up space. 

Use voice to move around the document 
Ask the student to say �Computer-move-to-top� and the cursor should go to the 
top of the document. Remember to run the words together so that ViaVoice 
recognises the command rather than typing the words. Then say �Computer-
Move-down-3-lines� and then �Computer-Move-right-4-words�. Switch the mic 
off, and then click Help > Help Topics > Command Reference > Cursor 
Movement Commands. Go over the various voice commands with the student. 
See also Chapter 11 in the ViaVoice User�s Guide. 

Use voice to Playback and Read Back 
Ask the student to move the cursor to the top again, and then say �Computer-
Select-line� and "Computer-Play-This" - the recording will be played back. Then 
say "Computer-Begin-Reading" and the computer will read out the text written on 
screen. Point out that the student can use these commands to listen to what was 
said, and then what was typed as many times as he or she wants, to check for 
errors. Practise double-clicking on a word to select and play it back, and then 
saying �Computer-Begin-Reading� to listen to it. Do the same for phrases and 
sentences.
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Use voice to control the mouse and programs 
Click on Help > Help Topics > VoiceMouse. Review the various mouse 
commands, and then try a few out. Dictate: 

[COMPUTER-BEGIN-VOICE-MOUSE]  to start the �voice mouse� 

[COMPUTER-MOVE-UP-SLOWLY�.FASTER..STOP] to move the mouse up the 
screen

[COMPUTER-CLICK] to click 

[COMPUTER-END-VOICE-MOUSE]

[COMPUTER-START-PROGRAM-CALCULATOR] - the Windows Calculator 
should open 

Four plus five equals 

Five hundred and twenty three divided by seven equals 

[CLOSE-PROGRAM-CALCULATOR]

Add a new word to the dictionary 
Explain to the student that ViaVoice has a dictionary of hundreds of thousands of 
words, so it will know most words that are commonly spoken. However, sometimes 
you will say a word that is not in the dictionary, so you have to teach ViaVoice the 
new word.

Switch the mic on and ask the student to dictate: 

The computer knows lots of unusual words and proper names [COMMA] like 
Auchterarder [COMMA] Yamaha [COMMA] and Larsson. [FULL STOP] [NEW-
LINE]

But it does not know Quidditch [COMMA] Amoruso or Eminem [FULL STOP] 
[NEW-LINE]

1. ViaVoice will not have 
typed these words 
because they are not in 
the dictionary.

2. To add the word, click on
it, and then click
Correction.

3. Type in "Eminem" to the 
Correction Box. ViaVoice 
will ask if you want to add 

the word to the dictionary. Click Yes (you can always delete the word from the dictionary

76



Introducing Speech Recognition in Schools IBM ViaVoice v.9 
CALL Centre Session 5  Compose and dictate

later).

4. Click Record and say the word. 

5. Click Done and the new word will be added to the dictionary.

Test the new words by saying: 

Now the computer knows about Quidditch [COMMA] Amoruso and Eminem 
[EXCLAMATION-MARK] [NEW-LINE]

Open ViaVoice > Tools > Manage my Vocabulary and look through the new 
words that have been added to your dictionary. If you don�t want to use a word 
again, select it and then click Delete.

Recap
Dictate a few sentences about the things that have been covered in this session: 
text formatting, composing and dictating text, using voice to move around the 
document, and adding new words to the dictionary.  Save the file. 

 Finish 
Exit from the program and remove and store the microphone.
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Session 6 Reading and dictating

In Session 6 the student will learn to: 

Ç Use ViaVoice to read a passage and questions, and then dictate answers

Review
Last session you learned about voice commands, added new words to the 
ViaVoice dictionary, and planned and dictated a new story. This session you will 
put some skills into practice by reading and answering questions, and then do 
some more dictation practice. 

Get started 
Ask the student to put on the mic, start ViaVoice and select the voice file.

Load the speech session 
Switch the mic on and ask the student to say "Computer-Dictate-to-SpeakPad".

Switch the mic off, click File > Open Session and load the document the student 
dictated last time, about the poster or picture - Student'sName5.

Highlight each sentence in turn, and click Dictation > Playback to listen to the 
dictation. Note that you can select Dictation > Cancel Playback to stop the 
playback. Help the student to correct any errors with the Correction Box.

Discuss a few more new sentences about the poster or picture. Switch the mic on 
so the student can dictate some more. Use Playback and Begin Reading to listen 
to what was dictated, and what was actually typed. Then use the Correction 
Window to fix any errors. Ask the student to say "Computer-Print", and after the 
file has printed, "Computer-Save", to save the file as Student'sName6A.

Switch the mic off. 
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Use text to speech to read and then dictate answers 
Look in your speech recognition files you copied from the CALL Introducing
Speech Recognition in Schools CD, and open the "Using Speech Recognition"
file.

Remind the student that Begin Reading can be used to help read text loaded into 
the computer. 

¶ Highlight the first sentence and then select Tools > Begin Reading and the 
text will be spoken out. 

¶ Or, select the text to be read and then press ALT-D, then B.

¶ Put the cursor at the start of the next line and say "Computer-Begin-
Reading". If the computer types something instead of reading the line, say 
"Computer-Scratch-That", and try it again. 

Click on the Pause button under the agent to pause after each sentence, or the red 
Stop button to stop.

If you want to hear a particular word or sentence, highlight it and select Begin
Reading again.

Be careful once you have highlighted some text to read that you don�t type or 
dictate over it and replace it! Put the cursor at the end of the text ready for the next 
dictation before you switch the microphone on. 

Practice using the speech output to read the text and the questions, and then 
dictate answers. The answers should be in full sentences, such as "Before you
start dictating you should��.", rather than answers of just a few words. 

Print and save the file as Student'sName6.

Using speech recognition 

When you dictate to a computer, you must remember some important things.

a) Before you start dictating a sentence, think about it in your mind. Make 
sure the sentence makes sense before you open your mouth. Practise the 
sentence before you start, if you're not sure about it. 

b) Speak clearly without stuttering or mumbling. 

c) Switch the microphone off after dictating, so the computer doesn't pick up 
anything you say to friends. 

d) After dictating a few sentences or a paragraph, you MUST correct any 
errors it makes with the Correction Window. If you can't spell the correct 
word, ask for help. If you don't correct the errors, the program will not 
learn to recognise your voice. 
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Questions:

What should you do before you start dictating a sentence? 

How should you speak?

What do you do right after dictating? 

Why must you correct errors? 

More dictation
If you have time, open a new blank page and do some more dictation about a topic, 
such as a hobby, or going on holiday. It may help for you to write or type out the 
sentences first so that the student just has to read them out, rather than having to 
remember the sentence. Print and save the document with a suitable name � e.g. 
�My pets�, �Spanish Holiday�. 

Finish
Change to the Test User and exit. Remove and store the microphone.
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Session 7 Adapting the vocabulary 

In Session 7 the student will learn to: 

Ç Analyse documents to teach ViaVoice new words 

Ç Use ViaVoice to read and complete a comprehension exercise

Review
Session 6 covered speech output to read text and questions. In this session you 
will add new vocabulary to the dictionary and then complete another 
comprehension exercise. 

Get started 
Put on the mic, start ViaVoice and select the student's voice file.

Analyse documents 
Remind the student that ViaVoice knows a lot of words, but doesn't have every 
word in its dictionary. To save you adding all the extra words you might need one 
by one, it has a facility to add new words to the dictionary from files already on the 
computer or from the SpeakPad.

When ViaVoice analyses the document, it not only adds new words, but also 
adapts the user's voice model to the style of the text. This means it is better at 
recognising text because it will 'know' about the topic you are writing about. 

Before tackling a piece of writing on a particular topic - such as the Stewart Kings, 
or Magnetism � you can run text about the topic through the ViaVoice Document 
Analyser so that any new words or phrases are added. 
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1. Click on ViaVoice > Tools > Analyse My Documents. Click Next then Find.

2. Click Find and then 
Browse to select the 
Speech Recognition 
folder on your hard disc,
where you put the files 
from the Introducing
Speech Recognition in 
Schools CD. 

3. Click Find. Then select
the �Haggis text.txt� file, 
click Add, then click
Close.

4. Click Next

5. Tick the words you want to add to the
dictionary. Only choose words you are 
likely to need to dictate. Click Next.

6. If ViaVoice thinks it needs you to record 
the word, it will offer you the chance next.

7. Click on the Record
button and record
each word in the list. 

8. Click Done, then 
Finish.
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Comprehension activity - use speech output to read 
questions, and then dictate the answers 

Now ask the student to say "Computer-Dictate-to-Speakpad" followed by 
"Computer-Open". Look for the Haggis questions file, and open it.

Use the computer speech to read the text and the questions. Get the student to 
look back at the text to check on the answer to each question, and use speech 
again, if necessary. Once the student has practised each answer, switch on the 
mic and the student should dictate the answers. Use complete sentences, e.g. 
"Americans and other visitors to Scotland are often told... �".

Switch the mic off and save the file as Student'sName7.

Haggis
Americans and other visitors to Scotland are often told that the haggis is a 
small three-legged creature that runs around the mountains of Scotland. The 
haggis is a very well dressed creature, usually wearing a kilt in the family 
tartan - Royal Stewart is the most commonly seen tartan among the haggises
in the Cairngorm mountains but you can also catch an occasional glimpse of a 
haggis wearing the MacDuff tartan. 

The male haggis has its left hind leg longer than its right, which means that it 
has to run round the mountain in a clockwise direction or else it will fall over 
and tumble down the mountainside. If a haggis forgets about the leg problem 
and tries to go the opposite way, it shouts out �gardiloo� as it falls. The 
female, on the other hand, has a longer right hind leg and therefore runs in an 
anti-clockwise direction. As a result of the males and females always running 
round the mountain in opposite directions, they hardly ever meet. During the 
breeding season visitors to the Highlands can often hear the distinctive 
wailing cry of the male haggis as he tries to find a mate. The music of the 
Scottish bagpipes has been inspired by the wail of the haggis.

Haggises have a very limited diet which is why they are only found in Scotland.
They eat heather (�fraoch� � spoken as �freuch�) and drink water flavoured 
with berries called irnbru.

Some people say this is a myth - a story made up to confuse tourists. They say 
that haggis is actually Scotland's national dish, made from the liver, heart and 
lungs of a sheep, along with oatmeal, onions and spices, all chopped up and 
wrapped up in a sheep's stomach and then cooked. This seems unlikely to me - 
I mean, who would ever eat something like that? The idea about the small 
animal with different legs seems much more believable!
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Haggis Questions

1. What are Americans and other visitors to Scotland told about the haggis? 

2. Which tartans do haggises usually wear? 

3. What is the main difference between male and female haggises? 

4. What do haggises shout if they fall off the mountain? 

5. What was the inspiration for the music of the Scottish bagpipes? 

6. What do haggises eat and drink?

7. What are the �real� ingredients of a haggis? 

Recap
Dictate a few sentences about what the session has covered: analysing documents
to build a vocabulary; using text to speech to read; and dictation to answer 
questions.

Say �File� then �Print� then �OK� to print the document, and then save it as 
StudentsNameSession7.

If you have time�. 
Open a blank document and do some more dictation practice from a piece of work 
the student has written before, or from a text book. Print and save. 

Finish
Change to the Test User and exit. Remove and store the microphone. 
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Session 8 Dictate a Report 

In Session 8 the student will learn to: 

Ç Use speech recognition to plan and write a short report

Ç Correct errors by voice 

In the next Session 9 the student will use speech recognition for a class exercise. 
Discuss which exercise to use with the student and the subject teacher. Choose an 
exercise which can be completed within one session. You may need to create an 
electronic version of text or worksheet so that the student can use computer 
speech to read it, so prepare this in advance.

Review
Last session we looked at adding new vocabulary to ViaVoice, and then using it to 
complete an English comprehension activity. This session we will try another 
activity, and explore other ways of correcting errors. 

Get started 
Start ViaVoice, select the student's voice file, switch the mic on, and say 
"Computer-Dictate-to-SpeakPad", then "Computer-File" and " Computer-
Open". Find and open The Road Accident file from the Introducing Speech 
Recognition in Schools CD. 

The Road Accident 
This activity here is to plan and write a report of an accident, as an eye witness.
The report could be an important piece of evidence. The accident has happened to 
a cyclist. The student has to think up a situation and then describe it using the 
structure below.

Discuss accidents and their causes with the student, e.g. pedestrians not looking 
when they cross the road; drivers overtaking when they can't see; cyclists going 
too fast on pavements, drivers falling asleep, and so on.
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Talk about any accidents the student has seen or been involved in, and the 
causes.

The Road Accident. 
Report.

Name:

Date:

1. The circumstances

At what time of day did the accident occur? 

What were the weather conditions at the time? 

2. Where did the accident take place?

3. Who was involved, and what happened? 

4. How quickly did help (police, ambulance) come? 

What kind of help was given by passers by and ambulance crew? 

Discuss the report with the student - talk about: 

¶ the time of day when the accident occurred; 

¶ the weather conditions;
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¶ where the accident took place; 

¶ who was involved and what happened 

¶ how quickly police/medical help arrived and what they did. 

Read and dictate text 
Switch the mic on and ask the student to say "Computer-Begin-Reading" to listen 
to the whole text and questions. 

Use voice commands to move around the text (e.g. "Computer-Move-down-1-
line") to put the cursor in the correct place to read and add answers.

Help the student to compose and then dictate a few short sentences for each 
section of the report. The text does not need to be dictated in order - text for 
section 4 can be put in first, for example. 

Correct errors by voice 
Use Playback and Speech Output to check for errors after each sentence. To 
correct an error, don't use the keyboard in the correction window. Instead, say 
"Computer-Correct-word", where word is the word to be corrected. 

If there are several words and the wrong one is selected, say "Computer-Try-
again" and ViaVoice will select the next occurrence of word. The Correction 
Window will open, with the word in. If you see the word you want, say "Pick x" - x
is the number of the word. If the word is not in the list, type it in and then press 
return.

To hear a playback of the words in the Correction Window, say "Play this�.

Click on Help > Help Topics > Correction to learn more about correction. 

When the student has finished putting in answers, print the document and save it 
as Student'sName8.

More comprehension practice 
If you have time in this session, say "File" then "Open" and open the "Snow
questions" file on the CALL Introducing Speech Recognition in Schools CD.

Use Speech Output to read the text and questions, and dictate the answers. Print 
and then save the file as Student'sName8B.
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Snow
I like snow! It is so cool to wake up on a winter�s morning to find the ground 
covered with fresh snow. If its the weekend, I�ll wrap up warm, with a coat,
scarf and gloves, and rush out to play. Sometimes I like to make a snowman, 
using two big balls of snow to make a body and a smaller ball for a head. Fresh 
snow that�s not too dry and powdery is best for making a snowman as long as its 
not too wet and slushy. I usually use small stones to make a nose and eyes. I�ve 
got an old scarf that I sometimes wrap around his neck to make him look smart. 

Sometimes my pals Liam, Mark and Chloe come round and we�ll have a snowball 
fight. That�s a good laugh! We never pack the snow too hard when we make 
snowballs so nobody gets hurt. Some people put stones in snowballs, but I think 
that is very bad.

Mark has a sledge so we sometimes go up the Doune Brae and sledge down the 
hill. Somebody usually falls off each time we go down so we all get covered with 
snow by the end of the morning. It�s good fun! After that we�ll go back home for 
a hot bowl of soup and to change into dry clothes. 

When I am older I hope to learn how to ski - I am sure that I would love it! 

1.  What clothes does the writer wear for playing in the snow? 

2. What is the best snow for making a snowman? 

3. What are the three activities that the writer enjoys doing in the snow?

4. What two things does the author not do when making a snowball? 

5. What does the author hope to do when she is older? 

Prepare for Session 9 
In the next Session 9 the student will use speech recognition for a class exercise. 
Discuss which exercise to use with the student and the subject teacher. Choose an 
exercise from a communication subject like English or History that can be 
completed within one session. Discuss completing the exercise with speech 
recognition with the student and the subject teacher. 

Get paper copies of any supporting materials - story texts, worksheets, etc - and if 
possible, get electronic copies on disc as well.
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If you have the text on a disc, you may be able to copy it so that the SpeakPad 
word processor can read it. To do this, open the file in your usual word processor 
and then either: 

1. copy and paste it into SpeakPad, or

2. save it as a Word 6, text or Rich Text File document, and then open it in 
SpeakPad.

If electronic copies are not available, either use a scanner and OCR program to 
scan them into the computer, dictate them yourself, or type them in. Save the files 
in Word 6 or 'RTF' format, so that they can be read by SpeakPad. If the text 
contains unusual words or place name, use the ViaVoice Vocabulary Analyser to 
analyse the text and add the terms to the dictionary.

Finish
Change to the Test User and exit. Remove and store the microphone.
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Session 9 Dictate school work 

In Session 9 the student will learn to: 

Ç Dictate numbers 

Ç Use speech recognition for a classwork exercise 

 Review 
So far, you have trained ViaVoice to the student's voice, learned to dictate, proof-
read and correct errors, and practised a little with voice commands and editing. In 
this session, you put these skills together to tackle a piece of classwork. You will 
also look at dictating numbers in various formats. 

Get started 
Start ViaVoice, select the student's voice file, and say "Computer-Dictate-to-
SpeakPad".

Dictating numbers 
Ask the user to repeat the following text. Use �Computer-Go-To-Sleep� to switch
the mic off after each sentence if you need to practise before dictating. When you 
say the times, run the words together � say �Nine-a-m� as one phrase. 

A CD costs about fifteen pounds. [Full-stop] [New Line] 

My birthday is on January twelfth nineteen sixty two [Full-stop] [New Line]
(or whatever the student's date is) 

Half of five is two point five [Full-stop] [New Line]

A woman won five hundred thousand pounds on television [Full-stop] [New Line] 

At the third stroke, the time will be two o'clock [Full-stop] [New Paragraph]

Nine a m [Computer-tab] [Computer-tab] English [New Line] 

Nine fifty a m [Computer-tab] [Computer-tab] Maths [New Line] 
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Point out that ViaVoice formats the numbers correctly. Look at p. 46 in the 
ViaVoice User's Guide for more on dictating numbers. 

Ask the student to say "Computer-save" and save the file as Student'sName9.

Preparation for dictating an exercise 
Before the session, identify a suitable exercise that the student has to complete, 
from a communication subject like English or History. Discuss completing the 
exercise with the student and the subject teacher. Choose work that can be 
completed during one dictation session. Get paper copies of any supporting 
materials - story texts, worksheets, etc - and if possible, get electronic copies as 
well. If electronic copies are not available, either scan them into the computer with 
a scanner and OCR program, dictate them yourself, or have them typed in. Save 
the files in Word 6 format, so that they can be read by ViaVoice. 

If the text contains unusual words or place name, use the ViaVoice Analyser to 
analyse the text and add the terms to the dictionary. 

Activity
Give the student the exercise on disc, and ask them to go through the whole 
process of starting ViaVoice, loading in the exercise, reading with Speech Output, 
inserting dictation, finding and correcting errors, and printing and saving the text. 
Give help and support where necessary - it is very important that the student is 
successful in this activity.

If the student does not complete the activity in this Session, correct what you have 
done and save so you can finish it in Session 10. 

Talk about how other items of work could be completed in the same way - who and 
how would work get put onto disc; when would the student use the speech 
recognition program to complete them; how would the results be kept with other 
written material. 

Print and save the document.

Prepare another activity for Session 10 
If you have finished the first class exercise, choose another class exercise to do for 
Session 10. Arrange to get paper and if possible electronic copies of the text in 
advance.

Finish
Change to the Test User and exit. Remove and store the microphone.
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Session 10 Plan using speech 
recognition for school work 

In Session 10 the student will:

Ç Use speech recognition for another classwork exercise

Ç Discuss and plan how speech recognition will be used for school work from now 
on

Review
Discuss how the last session went with the student and staff.

Complete the exercise from Session 9� 
If the last session did not work out, discuss why. Was it the task, something about 
ViaVoice, or was the task not suited to dictation? Try to find a solution to any 
problems and repeat the activity. 

Or start another one� 
If the last session was completed successfully, repeat the process for another 
piece of work. Carry out the preparation with the student - collecting the paper and 
files on disk, analysing any text, and doing and checking the work. If you have a 
scanner, try scanning in a simple worksheet, save it as a Word 6 or  'RTF' 
document, and then open it in ViaVoice. Or, copy and paste the text into ViaVoice. 
Then use ViaVoice to read and complete the exercise. Print and save. 

Check accuracy
Find a passage of text of 300 words or so (about 5 paragraphs). Start a new 
document, and then ask the student to dictate the text. Don�t correct any errors. 

Select the errors and mark them (underline, or make them bold) so you will be able 
to count them easily. Copy and paste the text into Microsoft Word, or another 
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program that can count words. Click on Tools > Word Count in Word to count the 
number of words. Count the errors and divide by the total number of words to get 
an accuracy score: 

Accuracy = (Total number of words - Number of errors)

   Total number of words

For example, if you have 10 errors in 300 words, this gives an accuracy of 96.6%. 

Don�t count unknown words, or proper names as errors if they are not in the 
dictionary; a short phrase with a couple of errors counts as one error; and so does 
a word split into two words. Type the score in and save as StudentsSession10.

Switch off the Attention Word Required 
Throughout the training you have had to say �Computer..� before giving a 
command. We set this in the ViaVoice options at the very start of training to try and 
prevent ViaVoice typing the command instead of doing it. Now that the student has 
learned to use the program, you may want to switch off the Computer attention
word so that it does not need to be spoken. If so, select ViaVoice > User Options 
> ViaVoice Options, click Dictation, and uncheck Attention Word Required.

Plan how you will use speech recognition from now on 
Discuss how the student has found the speech recognition program and training. 
Some questions to consider are: 

1. Will the student use speech recognition for school work from now on? 

2. For which subjects and assignments? 

3. Where will the student work � learning support base, library, ICT suite, 
classrooms?

4. Where will the student obtain printouts of work? 

5. Will the student use speech recognition for homework � if a laptop computer is 
used, can the student take it home; or is there a home computer that can be used 
(some students in the project commented that it was very helpful to be able to 
practise dictation at home); 

6. Does the student needs access to speech recognition in several locations around 
the school? If so: 

¶ speak to the network or ICT coordinator or technician to discuss how the 
program can be made available on different computers. Remember you will 
need multiple licences to install it on several machines. Also note that the 
program saves the user�s voice file on the desktop computer, not the server, so 
you will either need a smart technician to copy voice files across the network or 
use Zip discs;

¶ or buy a laptop computer. 
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Appendix 1 Dictating directly into 
other applications 

Most of the time it is best to use ViaVoice SpeakPad for dictation because it is 
fastest and easiest. You can also dictate into other programs, like Microsoft Word, 
or email or web browser applications. However, when you use Word, for example, 
ViaVoice is much slower to respond unless you have a lot of RAM in your 
computer.

You may want to use Word or another word processor to save you converting files 
from Word to RTF format all the time; or because you need facilities like 
headers/footers or tables.

If you are going to use Word, you should install the Microsoft Office support files 
from the CD first (see p. 41 in the User�s Guide), and read Chapter 5 in the 
ViaVoice User's Guide. 

1.Switch the mic on and say: "Computer-Start-Program-WordPad ", or �Computer-
Start-Program-Microsoft-Word� (or whatever your word processor is called).

2. Select ViaVoice > Dictate to and choose either Word, or Directly to Application.
Dictate as usual. Be aware that dictation is often slower when you talk into Microsoft
Word because it takes more memory than the ViaVoice word processor, so you may
have to wait for a while before the words start to appear on screen. 

3. If you have the Word support installed, the playback and correction should work OK 
with Word and WordPad. It may not work with other word processors � see below. 

Scanning worksheets into the computer 
If speech recognition is to work practically in school, you will need to get printed 
materials and worksheets into the computer, use Vocabulary Analyser to add new 
words to the vocabulary, and open the file in SpeakPad so the student can use 
Speech Output to read the material and tasks. 

There are several programs you can use for scanning text into the computer. 
Kurzweil 3000 or WYNN are very fast, easy to use scanning programs designed 
specifically for students with literacy difficulties. You slap the page on the scanner, 
press scan, and the program does the rest. It scans, re-sizes, rotates as 
necessary, and presents the scanned image of the page on screen. You can then 
use the speech to listen to the text and Kurzweil or WYNN highlights the word and 
sentence being read as they speak. You can change the text colours and sizes to 
suit the reader, and can add text and recorded voice notes, bookmarks, and 
highlights. They have spellcheckers and other writing tools like word prediction.

However, Kurzweil 3000 and WYNN are expensive, and at time of writing do not 
work particular well with ViaVoice. 

Other scanning programs are: 

Wordsmith & Read and Write Gold. These are based on TextHelp Read and 
Write and add speech output and scanning facilities to Microsoft Word (Wordsmith) 
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or any other application (R & W Gold). We do not think they are as good or reliable 
as Kurzweil or Wynn at time of writing, but they are also not as expensive. 

A cheaper alternative is to use the scanning and optical character recognition 
software that was supplied with your scanner. The OCR software provided with the 
scanner will probably be a basic version, so it is worth upgrading to a full version of 
TextBridge, OmniPage or FineReader. All these programs can scan directly into 
Microsoft Word, and then you can use the ViaVoice text to speech to read the text, 
and dictate answers. They work well with documents that are mainly text, but 
pages with complicated layout and lots of graphics (like worksheets) often lose 
formatting and do not look much like the original unless you spend some time 
editing and adjusting them. 

Once the text is scanned in, you will need a program to read it out. The ViaVoice
computer speech is fairly limited, so it is worth looking at TextHelp Read and 
Write or TextHelp ScreenReader, both of which have better speech output 
facilities. They give more control over the speech, and also highlight the words as 
they are read so it is easier to follow. 

The advantage of scanning into Word and then using speech output is that the full 
set of ViaVoice tools, including Playback and Correction, are available. The 
disadvantage, compared to Kurzweil, for example, is that you end up using four 
different programs � the OCR, Word, ViaVoice, and maybe also a speech output 
program. This is more complicated than just using Kurzweil or WYNN plus 
ViaVoice, may therefore be fiddly and less reliable, and may require lots of memory 
in your computer. 

Dictating into Email
Close Word, switch the mic on, and say �Start-Program-Outlook-Express� (or 
whatever the email program is called). Your email program should start up. Click 
ViaVoice > User Options > ViaVoice options > Command Sets tab. Make sure 
the Mail Applications and Outlook Natural Commands are ticked. 

Try creating and writing an email message. For example, in Outlook Express, say: 

1. �Computer-Compose-Message� to start a message. 

2. Dictate the name of the recipient. To say �.� Or �@�, you must go into �Spell Mode� 
by saying �Begin-Spell�. To go back to dictating words, say �Return�. E.g.
�Tom�,
�Begin-Spell, �dot� �Return�
 �Brown� 
�Begin-Spell, �at sign� �Return�

3. Move from �To� to �Subject� to the message box by saying �Computer-Next-
field�.

4. Note that Correction, Playback and computer speech don�t work in email, so you 
may want to compose and correct the message in SpeakPad, and then transfer or 
cut and paste into the Mail program � see below on how to do this. 

Refer to Chapter 10 in the User�s Guide on more on how to dictate into email and 
Internet Explorer. 
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Dictating into other applications 
There are two techniques for dictating into other applications:

¶ dictate directly into the program; 

¶ dictate into SpeakPad, and then use the Transfer button to copy and paste 
into the program. 

Dictate directly 
You can dictate into almost anything, but some of the ViaVoice commands and 
facilities do not work with some programs - see below. The advantage of using 
Word, or one of the other programs supported by ViaVoice, is that playback and 
correction work properly, and you can edit, format and use the Word menus.

To dictate directly into a word processor, open up a new page, and then click on 
ViaVoice > Dictate to > Directly into Application. Switch on the mic, click on the 
word processor window and start dictating. 

You will probably find that the text appears a little slower (and if you have an older 
computer with only 64 MB of RAM, a lot slower) than it would if you were using the 
SpeakPad word processor. To stop dictating either switch the mic off, or say 
"Computer-Microphone-Off". Straighforward dictation seemed to work in most 
applications, but we found that playback and correction often did not: 

¶ Don't use F2 to open the correction window because F2 will probably be used 
by the word processor. Instead, say "Computer-Show-Correction-Window". 

¶ The manual suggests that you can select words to correct with voice, i.e. by 
saying "Computer-Correct-thing" but we did not find that this worked. Instead, 
select the word or phrase with the mouse or keyboard and then click on the 
Correction Box so that it appears in the Correction Window. Sometimes the 
Correction did not seem to work at all. 

¶ You may be able to use playback (say �Computer-Play-This�) and also Begin 
Reading (either right-click on the ViaVoice microphone at the right hand side of 
the TaskBar and choose Begin Reading, or say �Computer-Begin-Reading�).

¶ With most programs can also use voice commands to move around the 
document ("Computer-Next-Line", "Computer-Go-To-Top� etc) and open, 
close, save and access menus ("Computer-Save"). 

We tried dictating directly into some talking word processors because it can be 
helpful if the user gets spoken confirmation about the text as it is dictated. We 
tested ViaVoice with Clicker 4, TextEase 2000, WriteOutloud 3 and Writing with 
Symbols 2000. We found that straightforward dictation worked fine, and the 
program could read back each sentence after the full stop was dictated. However, 
when corrections were made, the corrected word was often inserted in the wrong 
place, or playback did not work properly. Also, speech feedback of every word 
does not work very well because the talking word processor waits until it receives a 
space before reading the word, which means it is always one word behind the 
dictation.
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You can also get symbol support by dictating into Writing with Symbols or 
Clicker 4. The screen shot shows how Clicker automatically types a symbol on 
screen to match the text as it is dictated. Although it may seem slightly strange to 
suggest that a poor reader who needs symbols to support their reading might use 
speech recognition, we think it is worth considering. If the student can get through 
the initial training, speech recognition may offer a motivating technique to record 
work. You would not expect the student to generate large quantities of text, but 
rather dictate small amounts, with help from staff, as an alternative to using symbol 
grids or overlay keyboards. 

Transferring dictation to another application 
The second technique for using ViaVoice with other applications is to compose the 
text with SpeakPad, then copy and paste it into the target program. For example, to 
write an email you would: 

1. Open SpeakPad and the email program. 

2. Click the SpeakPad Select Target button and drag the pointer to the email program, then 
click OK.

3. Dictate the email with SpeakPad, correct any errors and click the Transfer button to 
transfer the text to the email.

4. You can set ViaVoice to either cut or copy the text when it is transferred from SpeakPad. 
Click ViaVoice > User Options > ViaVoice Options > Dictation to choose to cut or 
copy.
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Appendix 2 Technical issues 

Poor audio quality 
If you get poor audio quality when you go through the audio setup sequence, you 
must try to fix it otherwise you will be wasting your time with speech recognition. 
Poor audio is due to: 

a) The microphone being plugged into the wrong socket on the computer or the 
USB adapter. This is easier to do than you might think! Check it. The 
microphone plug is usually red or pink and the socket on the computer marked 
with a picture of a microphone. 

b) ViaVoice being set up to use the wrong microphone. Click ViaVoice > Audio 
Setup, then Next, and make sure the Sound Card Input is set to USB Audio
Device (assuming you are using the USB mic). 

c) Poor microphone positioning. Check that the mic is positioned to the side of 
your mouth, about 2cm away. Check the mic is facing your mouth - some mics
have a small dot and this must be facing your mouth. If it faces the room it will 
be doing it's best to cancel out your voice, and listen to the rest of the room!

d) Poor or defunct microphone. The mic may not be working properly, or it might 
have got broken, or the cable snagged. Try a different mic to see if that makes 
a difference. 

e) Sound card settings. If you are using an ordinary microphone rather than the 
USB one, check your sound card settings against the instructions on the 
ReadMe file on the ViaVoice CD. You can usually adjust the settings by right-
clicking on the volume or speaker icon at the right side of the TaskBar. For 
example:
Soundblaster 16/Live!, SoundMax: turn on AGC or +20 bD gain 
SoundBlaster AWE 64, Crystal, Yamaha DS-XG turn off AGC or Mic Boost 

f) If you are using an analogue mic plugged into a sound card, the sound card 
may be poor quality. Some soundcards are better than others at getting a good 
clean signal for speech recognition. Laptops in particular may have poor sound 
input because the electronics are all jammed in close together and the signal 
can pick up noise from other components. Use the Sound Recorder (see below) 
to check the sound input � if it is �hissy� and noisy, you should either fit another 
sound card, or use the USB.

g) Sound input settings. It is possible that your computer's sound input settings 
may be switched off, or adjusted in some way that effects sound input. For 
example, if your sound card is set to apply reverb or echo to sounds, it will 
obviously effect the recognition!
Click on Start > Settings > Control Panel, and open the Multimedia Control 
panel. Click on Advanced and make sure that everything is set to 'standard', 
and that no effects are being applied to the sound input. 
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Sound Recorder 
Use the Sound Recorder to check the sound quality. Click on Start > Programs > 
Accessories > Entertainment > Sound Recorder. Click Edit > Audio 
Properties and make sure the Recording Preferred Device is the one you are 
using for speech recognition. Record some speech, and then play it back. You may 
find that the signal is far too loud, or that is very crackly and noisy when played 
back. If it sounds too loud and seems to pick up your breathing, move the mic away 
from you mouth, or speak more quietly.

If you have tried different mics, adjusted the sound input settings, and 
experimented with different positions without success, you may have to give up on 
the sound card in your computer or try a USB mic or pod.

Poor accuracy 
1. If you experience poor accuracy, first run the Audio Setup (ViaVoice > Advanced 

> Check Audio) to make sure the sound is set up properly � see earlier. 

2. Equipment
The USB Mic supplied with ViaVoice gets round many of the problems with 
microphones. You need a good microphone and soundcard that produce a 
consistent, clean signal (see above). The TalkMic (iANSYST) and Plantronics
(Words Worldwide) mics are good, and the Shure HW505 and Andrea ANC-600
are also recommended. Make sure the mic is adjusted correctly and consistently. 
If you don�t have a good mic and sound system, you are wasting your time. 
Sound cards with a good name are the Ensoniq Audio PCI, Turtle Beach Montego 
II, and new Creative Labs Soundblaster Live. See the iANSYST web site for more 
on sound cards. 
The minimum computer specification quoted by IBM will give you minimum results, 
so get more memory (and/or buy a faster computer). Memory is cheaper and also 
appears to make more of a difference than a faster processor. Go for lots of RAM
� 256, 512 MB or more if you can.

3. Mic positioning
The microphone must be positioned in the same correct place every time. It 
should be 2 cm away from the corner of your mouth. Practise putting it in the 
correct place using a mirror if necessary. If the accuracy suddenly changes from 
the previous session, try adjusting the mic a little. Use the Sound Recorder (see 
above) once when accuracy is good and save the recording. Then if accuracy is 
bad, use the Sound Recorder again and compare the saved good recording with 
the current sound. Adjust the mic to try and replicate the good recording. 

4. Complete the training and do more
Make sure you read through the ViaVoice training text. If accuracy is still poor 
choose another story and do more training. Click on ViaVoice > User Options > 
ViaVoice Options > User, and click Add/Modify. Make sure the First Voice 
Model is selected, and then choose another training story to read. 

5. Correct errors / train mis-recognised words
Use the Correction Box to correct errors.

6. Speak clearly
Sit up straight, and try to speak like a newsreader. You can still have your own 
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accent, but you need to speak confidently and clearly, without slurring or missing 
small words, or tailing off at the end of the sentence. 

7. Speak sense
ViaVoice is not a mind reader � it will only recognise sounds. It does not know 
what words mean, so if you want it to print a word, you have to say the word. If 
you talk nonsense, change your mind halfway through a sentence, say �umm�,
�ahh�, etc, that�s what ViaVoice will type on the screen.

8. Speak in short phrases, rather than single words. 

9. Use the Vocabulary Analyser to adapt your dictionary for the words you use. 

Problems getting through training 
1. Before you start training, go over the text with the student and practice any difficult 

words or phrases. You may want to print out the text in a larger font, from the 
CALL Disc for Schools. You could also try printing the text out with each sentence 
on a separate line, then ask the student to read from the paper rather than the 
screen. Use the Pause and Resume buttons and prompt the student when to start 
and stop speaking. The student could use a piece of card to keep the place when 
reading from the paper. 

2. Click Start, read the first phrase or short sentence, and then wait for the text to 
turn grey before carrying on with the next phrase. Once you get into the swing of 
it, you can dictate more text without pausing. 

3. The student should follow the text with the mouse pointer as it is read. 

4. Dictate a few words or a phrase at a time, rather than speaking individual words 
and pausing between each word. 

5. If the program doesn�t seem to recognise anything, click Pause, and start again 
by reading the first few words. Make a conscious effort to speak clearly, and wait 
until the text turns grey before continuing. 

6. You can click on Pause after each phrase or sentence, to stop recording, so the 
student can practise reading the next one. You can even pause to practise every 
word if necessary - but the training will take a long time if you do! Although you 
can speak each word one at a time, it is better to say short phrases if you can.

7. If the student has problems reading the text, Pause and whisper it to them before 
clicking Resume.

8. You can make the story text larger and easier to read by clicking on the buttons 
just above �Cancel�. This also means you see fewer words on each screen, so it 
will be easier for students with reading difficulties to read. 

9. If you stutter, or say a word wrongly, ViaVoice will beep and mark the 
unrecognised word blue. You should repeat the word until it is recognised. If you 
get stuck on a word, and it refuses to turn grey, click Pause, wait for the computer
to stop beeping, then Resume, and try again. 

10.Stop and have a rest at least three or four times during training to relax and have a 
sip of water. 

11. If the student has reading difficulties you can use TextHelp Read and Write v5 or 
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TextHelp ScreenReader to speak out the training text. This works quite well if you 
set the ViaVoice text size to be as large as possible because TextHelp will read 
the one or two sentences shown, and then the student can repeat it. See Session 
1 on how to set this up.

12.Or, you could load the training text into the ViaVoice window (or into another 
talking word processor, like Write:Outloud, TextEase or First Word). Arrange the 
word processor window beside the training window, and then use the computer 
speech to read the text before dictating it. 

Network issues 
If speech recognition is to work successfully in secondary schools, the students 
must have access to the program in different locations across the school.
Therefore, either the student must have their own individual laptop computer, or the 
program must be installed on several desktop computers, or it must be available on 
the network server. 

An �Enterprise� version of the program is available from IBM for installation on 
network servers.  However, since most schools run networks where each computer 
has its own Windows operating system, with only files and desktops controlled from 
the server, enterprise versions may not work � it depends on the type of network 
you have. Contact IBM for advice if you want to follow this up. 

In situations where a student is using more than one computer, without an 
�Enterprise� edition, you will need to copy voice files from one machine to another 
using the Backup and Restore functions.

Transferring voice files between computers 

1. On the first computer, open ViaVoice and click ViaVoice > User Options > 
ViaVoice Options > User

2. Select your voice file from the list of users. 

3. Click Backup User and follow the instructions on screen. Click OK 

4. Go to the second computer, open ViaVoice and click ViaVoice > User Options > 
ViaVoice Options > User.

5. Click Restore User and follow the instructions. Click OK. 
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Appendix 3 Resources and suppliers 

Hardware and software 

Item Description Price ex
VAT

Supplier

Dragon NaturallySpeaking
Preferred v 5

Recommended version of 
NaturallySpeaking

£85 IANSYST,
Words Worldwide,
computer shops

IBM Dictate Power Edition Older �discrete� speech recognition
program

£150 IANSYST,
Words Worldwide

IBM ViaVoice Pro v8 / v 9 
USB

Recommended version of ViaVoice 
for PC. V9 has a USB mic.

£85 (v.9) IANSYST,
Words Worldwide,
computer shops

IBM ViaVoice Millenium Mac
(OS 9) with USB mic

Recommended version of ViaVoice 
for Mac OS 9 with USB mic

£59 IANSYST, Dabs,
computer shops

IBM ViaVoice Mac OS X 
Edition with USB mic

Recommended version of ViaVoice 
for Mac OS X

£62 IANSYST, Dabs,
computer shops

TalkMic mic with speaker Good mic with earpiece speaker £49 IANSYST

Andrea USB Adapter Pod Connects standard mic to a USB 
compatible computer, bypassing 
sound card 

£33 IANSYST

Telex USB mic USB mic for computers with no or 
poor sound card

£49 IANSYST

Keystone ScreenSpeaker Reads back dictated text as it is 
dictated with NaturallySpeaking.
Also reads correction list and has
simpler training scripts. Package 
includes a copy of 
NaturallySpeaking.

£250 Words Worldwide

IANSYST

TextHelp Read and Write Reads text and menus etc in any 
program; has spellchecker, word 
prediction.

From
£115

IANSYST

Concept Northern

TextHelp ScreenReader Same speech output as Read and 
Write, but without spellchecker,
word prediction etc. 

£30 IANSYST

Concept Northern

Textbridge Pro Millenium 
(competitive upgrade)

Good scanning OCR program. Cost
£55 to upgrade from your existing
program

£55 IANSYST,
computer shops

OmniPage Pro 11 
(competitive upgrade)

Claims to be the most accurate
OCR. Cost £90 to upgrade from 
your existing program.

£90 IANSYST,
computer shops

FineReader v6 Pro Good scanning OCR program £49 Computer shops

Kurzweil 3000 Scan/Read Excellent program for scanning and
reading. Lots of useful study tools. 
Expensive.

£500
(mono)

£725
(colour)

Sight and Sound,

IANSYST
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WYNN Similar to Kurzweil 3000 £673 Don Johnston
Special Needs 

Wordsmith Integrates TextHelp Read and
Write and scanning to Word 
97/2000.

£295 IANSYST

Concept Northern

Write:Outloud 3 Simple talking word processor.
Scottish schools can buy it for £22 
per licence from LTS. 

£71 (£22) Don Johnston

(LT Scotland)

TextEase Good word processor/desktop
publishing program.

£85 Softease

Clicker 4 On-screen grid program with talking 
word processor. Scottish schools
can buy it from LTS for £50.

£90 Crick

Inclusive
Technology

Writing with Symbols Word processor with symbols and
grids

£160 Widgit

Inclusive
Technology

Suppliers
Concept Northern
14 St Bryde Street 
The Village 
East Kilbride 
Tel. 01355 573173
Fax  01355 573073
http://www.conceptnorthern.co.uk

Crick Software,
35 Charter Gate,
Quarry Park Close,
Moulton Park 
Northampton
NN3 6QB.
Tel. 01604 671691
http://www.cricksoft.com

Dabs
Direct House
Wingates Industrial Park
Westhoughton
Bolton
BL5 3XD 
0870 429 3120
www.dabs.com

Don Johnston Special
Needs
18 Clarendon Court 
Calver Road
Winwick Quay
Warrington WA2 8QP 
Tel: 01925 241 642 
Fax: 01925 241 745 
www.donjohnston.com/uk/

iANSYST Ltd 
The White House
72 Fen Road
CAMBRIDGE, CB4 1UN 
Sales FREEphone 0500 14 15 
15
www.dyslexic.com
Tel: (+44)   01223 42 01 01
Fax: (+44)   01223 42 66 44

Inclusive Technology
Saddleworth Business Centre
Delph
Oldham OL3 5DF 
Tel. 01457 819790
fax. 01457 819799
http://www.inclusive.co.uk

Sight & Sound Technology
Qantel House
Anglia Way 
Moulton Park 
Northampton NN3 6JA 
Telephone: +44 (0) 1604
798070
Fax: +44 (0) 1604 798090
sales@sightandsound.co.uk
http://sightandsound.co.uk

Words Worldwide
Ash House
Belle Villas Ponteland 
Newcastle Upon Tyne
NE20 9BE 
www. keyspell.com
Tel.  01661 860999
Fax. 01661 822777
http://www.keyspell.com/

Widgit Software 
102 Radford Road, Leamington
Spa, CV31 1LF.
Tel. 01926 885303
Fax. 01926 885293
http://www.widgit.com
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Web sites
BECTa (British Educational Communications Technology Agency) 
http://www.BECTa.org.uk/inclusion/speechrecog/index.cfm. Information, reports and case studies
from the BECTa Speech Recognition Project. Probably the best place to start looking for 
information about speech recognition in schools.

British Dyslexia Association  � http://www.bda-dyslexia.org.uk  Information about dyslexia
and downloadable information sheets on a wide range of related topics including the use of 
technology to support writing. 

CALL Centre (UK) http://callcentre.education.ed.ac.uk. Electronic versions of this Pack plus other 
resources on speech recognition, plus information on a range of curriculum-based topics related to 
augmentative communication and assistive technology.

Comp.Speech FAQ http://svr-www.eng.cam.ac.uk/comp.speech/index.html . This is a site with
answers to frequently asked questions regarding all aspects of computers and speech. Chapter 6 is 
devoted to voice recognition. Some of the information is quite technical, but the site contains a 
comprehensive guide to the many different packages available, with links to manufacturers� web
sites, and a lot of useful background material, including material on health issues.

Computing Outloud (USA) http://www.out-loud.com   This site brings together the thoughts of a 
number of speech recognition users on different programs, with useful information and tips.

Dragon Systems http://www.scansoft.com/naturallyspeaking  Developers of DragonDictate and
NaturallySpeaking. Support, hints and tips and advice. 

IBM Software http://www-4.ibm.com/software/speech  Information on ViaVoice and other IBM 
products. Support, hints and tips and advice.

IBM ViaVoice Support site http://www-3.ibm.com/software/speech/support Frequently asked 
questions and answers on ViaVoice. 

Iansyst Ltd. http://www.dyslexic.com  Specialist supplier for speech recognition in education. The
site is regularly updated with comparative reviews and the latest pricing information. Probably the 
second best place to start looking for information on speech recognition.

LD On-Line (USA) � http://ldonline.org Massive collection of resources covering a wide range of 
SEN issues. The LD In Depth section contains a number of articles looking at strategies for
introducing and using spellcheckers, word prediction, voice recognition and other supportive writing 
technologies.

The Literacy Centre (USA) http://www.the-literacy-center.com   Deals with literacy and students
with SEN; includes case studies and hints and tips on speech recognition.

Microphones.com (USA) http://www.microphones.com  US microphone company � good for 
seeing which mics are currently recommended.

NCIP (National Center to Improve Practice in Special Education) (USA) � 
http://www.edc.org/FSC/NCIP  Project which ran until 1998 to look at different aspects of the use of 
technology in Special Education. Site includes detailed articles and case studies on word prediction,
organisational software, voice recognition systems, portable computers and other subjects.

SNOW (Special Needs Opportunities Window) (Canada) � http://snow.utoronto.ca  Massive
collection of material, including curriculum resources (e.g. on-line electronic books), lesson plans
and guides to good practice (e.g. guidelines for introducing IBM Dictate voice recognition).

Speak to Your PC (USA) http://www.microspeech.com/asktechguy/ Supplier site with details of 
software and accessories and useful information on how to use speech recognition systems.

Speaking to Write (USA) http://www.edc.org/spk2wrt  This is an American project exploring the use
of voice recognition technology to support secondary age students with disabilities. The site
includes an archived discussion group, including contributions from the UK, where many 
educational and practical issues are discussed. 

Typing Injury FAQ: Speech Recognition http://www.tifaq.com/speech.html  Detailed reviews of 
most of the systems available and lots of links to other sites. People should be able to track down
any information they want from this, or the Comp.Speech FAQ site.
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VoiceUsers Mailing List (USA) http://voicerecognition.com/voice-users  Details of a discussion
group for people using VR systems, including an archive of previous discussions, can be obtained
from this site.

Voice Recognition Software: Ensuring Effective Training And Usage
http://www.worc.ac.uk/services/equalopps/VRproject.htm  Project to develop and test good practice
guides for speech recognition in Universities. Downloadable training resources.

Words Worldwide Ltd. � http://www.keyspell.com  Information on Keystone, ViaVoice and voice 
recognition systems. 

Books, articles and papers
See the BECTa, iANSYST (dyslexic.com) and Words Worldwide web sites for some of 
these, and other articles and case studies.

Baumgarten, J. Alan, Barksdale, Karl & Rutter, Michael (2000) IBM ViaVoice QuickTorial
Pub. South Western Educational Publishing.

BECTa SEN Speech Recognition Project � Final Report. BECTa. Available, with reports
from schools at: http://www.BECTa.org.uk/technology/speechrecog/project/index.html

Donald, E. (1998) Voicetext: Evaluation of System when used by Students with Special 
Educational Needs. Perth High School, Perth, Scotland. 

Donegan, Mick (2000) Voice Recognition Technology in Education: Factors for Success 
Ace Centre Oxford. ISBN 1 903303 00 1.

Donegan, Mick (2001) Ready for Happy Talking? Special Children January 2001 pp 28 � 
32;also http://www.keyspell.com/Speechproducts/speechproducts.htm

Fulton, Susan (1998) The Essential Simply Speaking Gold Pub. Science and Humanities
Press.

Fulton, Susan (1999) Begin Dictation Using ViaVoice Gold Pub. Science and Humanities
Press.

Gandhi, Parmod et al (2000) IBM ViaVoice Complete Pub. InSync Software Ltd. 

Icke, Nancy, Perella, Rachel & Temple, Cheryl (2001) You can Talk to your Computer, but 
will it Listen? Closing the Gap August/Septemper 2001 pp 1, 20, 21. 

Kambeyanda, Dona, Singer, Lois & Cronk, Stan (1997) Potential Problems Associated
with the Use of Speech Recognition Products Assistive Technology Vol 9.2 pp 95 101.

Kelway, Peter (1996) Speaking to Text Interactive June 1996 pp 34 � 37.

Kotler, Ava-Lee & Thomas-Stonell, Nancy (1997) Effects of Speech Training on the 
Accuracy of Speech Recognition for an Individual with a Speech Impairment AAC Vol. 13 
(2) pp 71 � 80. 

Kambeyanda, Dona, Singer, Lois & Cronk, Stan (1997) Potential Problems Associated
with the Use of Speech Recognition Products Assistive Technology Vol 9.2 pp 95 � 101.

Litten, M. Usable Voice Recognition Software: The Mark College Experience! Dyslexia
Review, Vol. 13 No. 2. Also http://www.keyspell.com/Speechproducts/speechproducts.htm

Miles, Martin, Martin, Di & Owen, Jim (1998) A Pilot Study into the Effects of Using Voice
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Dictation  Software with Secondary Dyslexic Students. Devon LEA. 

Nisbet, P.D. (1999) Supportive Writing Technology. CALL Centre, University of Edinburgh. 
ISBN 1 898042 13 6. 

Rahamim, Lesley (1997) Talking with Computers Special! Autumn 1997 pp 57 � 59. 

Savison, Rosemary & Springett, Lindy (2002) When Writing means Talking. In Dyslexia 
Contact. BDA, 98 London Road, Reading RG1 5AU. 

Tam, Cynthia & Kotler, Ava-Lee (1995) Assessment Criteria for Using Voice Recognition
Systems as Writing Aids Closing the Gap December 1995 pp 14  17. 

Wetzel, Keith (1996) Speech-Recognizing Computers: A Written Communication Tool for 
Students with Learning Disabilities? Journal of Learning Disabilities, Vol. 29 (4), pp 371
380.

Wilson, A. (2000) Speech Recognition Systems. CALL Information Sheet 15. CALL 
Centre, Edinburgh.
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